1.1.2 Downgrade & AnySIM

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

cypher23

New Member
Nov 6, 2007
8
0
0
#1
I've been reading these forums and finally bought an iPhone hoping that it would be running firmware 1.1.1. Unfortunately, it was already running 1.1.2! I downgraded to 1.1.1 but now want to use AnySIM to unlock it. I'm not interested in upgrading to 1.1.2 but REALLY need to unlock it to use my non-AT&T SIM in it. PLEASE HELP SOMEBODY! I installed AnySIM version 1.2.1u for 4.02.13_G via WinSCP but everytime I get to the Slide to Unlock screen, it doesn't let me slide and then goes back to the Springboard screen. So basically I have an OTB 1.1.2 downgraded to 1.1.1 then Jailbroken but not unlocked. I don't have AT&T and really want to use my SIM card but don't know what else to do to get it there.
 

ravman

Zealot
Gold
Oct 4, 2007
1,197
0
36
Mean Streets of LA.
#2
You need to set the permissions of the anySim app when you FTP'd it over.

Go back to WinSCP, log onto your iPhone and select all the files in the anySIM directory. Right click and select properties and ensure all check boxes in the first 3 columns are selected. The property value should go up to 0755. Then anySim will run fine. Make sure all files/directories in the anySim directory are set to 0755.

But if you have the Installer.app installed, you can download and install anySim from there without having to mess about with permissions. In theory, you can jailbreak and unlock your iPhone all over WIFI and never have to touch a PC/Mac. I did this today with 2 iPhones.



I've been reading these forums and finally bought an iPhone hoping that it would be running firmware 1.1.1. Unfortunately, it was already running 1.1.2! I downgraded to 1.1.1 but now want to use AnySIM to unlock it. I'm not interested in upgrading to 1.1.2 but REALLY need to unlock it to use my non-AT&T SIM in it. PLEASE HELP SOMEBODY! I installed AnySIM version 1.2.1u for 4.02.13_G via WinSCP but everytime I get to the Slide to Unlock screen, it doesn't let me slide and then goes back to the Springboard screen. So basically I have an OTB 1.1.2 downgraded to 1.1.1 then Jailbroken but not unlocked. I don't have AT&T and really want to use my SIM card but don't know what else to do to get it there.
 

cypher23

New Member
Nov 6, 2007
8
0
0
#3
ravman...thanks for the heads up. I'll try that next. As for the installer.app, I don't see anySIM 1.2 on the list. There are 2 anySIMs on the list but I don't think they will unlock baseband 4.02.13_G.
 

ravman

Zealot
Gold
Oct 4, 2007
1,197
0
36
Mean Streets of LA.
#4
Oh I see. You have the 1.1.2 baseband, but the 1.1.1 software. I'm not sure how bug free the new anySIM app is for the 1.1.2 baseband. Last I heard it was riddled with bugs and not to use it? But I'm sure someone out there will have better experience than me about this.

But yes, your problem is a permissions issue. I had the same problem before myself.



ravman...thanks for the heads up. I'll try that next. As for the installer.app, I don't see anySIM 1.2 on the list. There are 2 anySIMs on the list but I don't think they will unlock baseband 4.02.13_G.
 

cypher23

New Member
Nov 6, 2007
8
0
0
#5
ravman...thanks...I just tried the process you explained. when I Right-Click the files and go to Properties, I don't see the columns that you were talking about. The only thing I see are the Attributes and the check boxes: Read-Only and Hidden. Am I missing something? Should I transfer the files over then Right-Click?
 

ravman

Zealot
Gold
Oct 4, 2007
1,197
0
36
Mean Streets of LA.
#6
That could be the same thing. There should be like 11 ish check boxes there? 4 columns. The first 2 columns are all selected, but none of the boxes in the 3rd column are selected. They are the ones you need to select to bring the permission level up to 0755. I am going via memory here, it was a few weeks since I did this last.


ravman...thanks...I just tried the process you explained. when I Right-Click the files and go to Properties, I don't see the columns that you were talking about. The only thing I see are the Attributes and the check boxes: Read-Only and Hidden. Am I missing something? Should I transfer the files over then Right-Click?
 

cypher23

New Member
Nov 6, 2007
8
0
0
#7
Got it! Thanks again ravman! I got it all installed, permission level up to 0755, and started the process to run anySIM 1.2 on my 1.1.1 (downgraded from 1.1.2) with a baseband version 4.02.13_G. AND.....................................................................nothing. It says that it cannot Unlock it and for me to restart my iPhone after anySIM quits. Arghhhhhhh! Thanks for your help though. Any other suggestions? Can I flash my baseband to 4.01.13_G then UNLOCK it?
 

ravman

Zealot
Gold
Oct 4, 2007
1,197
0
36
Mean Streets of LA.
#8
Right now, I personally would suggest bringing your baseband down to 1.1.1 and anySIM that. I would not try to anySIM 1.1.2 yet. It's too new and not sure if anything out there can unlock it. But yes, you can bring the baseband down. I had to do that the other day myself.

I used this site:

http://www.modmyi.com/forums/showthread.php?t=15310&highlight=1.1.2+activation

But I didn't follow it to a T. I downgraded to 1.0.2 using iBrickr & iTunes, then started at step 6.

It looks complicated, but it is not. All the relevant downloads you need are there.

But someone else also suggested iDemocracy2. Apparantely that does everything for you.

http://www.modmyi.com/forums/showthread.php?t=16653



Got it! Thanks again ravman! I got it all installed, permission level up to 0755, and started the process to run anySIM 1.2 on my 1.1.1 (downgraded from 1.1.2) with a baseband version 4.02.13_G. AND.....................................................................nothing. It says that it cannot Unlock it and for me to restart my iPhone after anySIM quits. Arghhhhhhh! Thanks for your help though. Any other suggestions? Can I flash my baseband to 4.01.13_G then UNLOCK it?
 

ravman

Zealot
Gold
Oct 4, 2007
1,197
0
36
Mean Streets of LA.
#9
I'm sorry, I meant I started at step 3. iBrickr bought the iPhone down to 1.0.2 for me.


Right now, I personally would suggest bringing your baseband down to 1.1.1 and anySIM that. I would not try to anySIM 1.1.2 yet. It's too new and not sure if anything out there can unlock it. But yes, you can bring the baseband down. I had to do that the other day myself.

I used this site:

http://www.modmyi.com/forums/showthread.php?t=15310&highlight=1.1.2+activation

But I didn't follow it to a T. I downgraded to 1.0.2 using iBrickr & iTunes, then started at step 6.

It looks complicated, but it is not. All the relevant downloads you need are there.

But someone else also suggested iDemocracy2. Apparantely that does everything for you.

http://www.modmyi.com/forums/showthread.php?t=16653
 

cypher23

New Member
Nov 6, 2007
8
0
0
#10
hey ravman...I tried to do the same thing. as of right now i'm at 1.0.2 with a 4.02.13_G baseband. I tried to flash the baseband using the link to the guide that you posted. for some reason I can't erase the baseband using iEraser. ARe you sure you did this same exact procedure to downgrade 1.1.2? Was it an out of box 1.1.2?
 

meiphones_brill

New Member
Silver
Nov 16, 2007
797
0
0
#11
As far as I've read so far, there isn't an unlock for OOTB 1.1.2 phones like are being shipped in the UK.

I'm going to have a look at some French forums as a friend of mine who's usually right about stuff tells me the legal situation in France is different and their phones couldn't be crippled.

Here's a typical post - from one of the two forums I've read - basically my mate is wrong, looks like the baguette munchers are in the same bateau as us.

[snip]

Bonsoir,

Malheureusement il n'existe aucun moyen de debloquer un iPhone natif avec la version 1.1.2 d'origine.

La version de anySIM1.2 ne fonctionne pas sur le nouveay bootloader du iPhone 1.1.2.

Voici la version du bootloader que j'ai reussi a identifier sur mon iPhone virgin 1.1.2 :

firmware: DEV_ICE_MODEM_04.02.13_G
eep version: EEP_VERSION:208
eep revision: EEP_REVISION:1
bootloader: BOOTLOADER_VERSION:4.6_M3S2

Normalement iDomocracy vient d'annoncer la nouvelle version 2 de son programme et il devrait prendre en compte le bootloader 4.6_M3S2 de la version UK/US/ALL de l'iPhone.

[/snip]
 

ravman

Zealot
Gold
Oct 4, 2007
1,197
0
36
Mean Streets of LA.
#12
Yes the two phones I flashed down were 1.1.2 OTB (US models, not European). I took them out of the box, plugged them to a PC and used iBrickr & iTunes to get them both down to 1.0.2. I then ran those commands and got the baseband down to 1.0.2. I then ran iTunes and restored back to 1.1.1, then ran the jailbreak and anySim procedures.

Have you tried iDemocracy2?



hey ravman...I tried to do the same thing. as of right now i'm at 1.0.2 with a 4.02.13_G baseband. I tried to flash the baseband using the link to the guide that you posted. for some reason I can't erase the baseband using iEraser. ARe you sure you did this same exact procedure to downgrade 1.1.2? Was it an out of box 1.1.2?
 

kinjalk

New Member
Bronze
Oct 31, 2007
32
0
0
#13
You need to set the permissions of the anySim app when you FTP'd it over.

Go back to WinSCP, log onto your iPhone and select all the files in the anySIM directory. Right click and select properties and ensure all check boxes in the first 3 columns are selected. The property value should go up to 0755. Then anySim will run fine. Make sure all files/directories in the anySim directory are set to 0755.

But if you have the Installer.app installed, you can download and install anySim from there without having to mess about with permissions. In theory, you can jailbreak and unlock your iPhone all over WIFI and never have to touch a PC/Mac. I did this today with 2 iPhones.
Ravman, hey i have the same problem, i got new iPhone firmware 1.1.2, downgraded to 1.1.1. I jailbreaked 1.1.1 using wifi, and then upgraded to 1.1.2 and then jailbreaked that too. Now its telling me to us WinScp. Now is this program for mac or pc? How do i open WinSCP? where do i find that program? Do i already have it? i'm sorry i'm not too computer savvy. Can you help?
 

kinjalk

New Member
Bronze
Oct 31, 2007
32
0
0
#15
kinjalk - you'll find winSCP on download.com or tucows.com

If you're on a mac look for Fugu <-- I like this

M.

I have pc so i just have to download WinSCP and open it ? how does it work? do i open it with iTunes? man i'm so lost lol its crazy. I spent so much time yesterday trying to unlock the phone and i was stuck on this step. So i just download WinScp and open it on my computer and follow instructions right? Oh its FTP program lol wish i knew, ok so i open up and transfer stuff to iPhone eh?
 

meiphones_brill

New Member
Silver
Nov 16, 2007
797
0
0
#16
yep - it's very much like an ftp programme except that it uses ssh in stead of FTP.

I don't know what instructions you're following but yes - it'll be for copying files to the iPhone. As the iPhone is a bsd/linuxy thing you'll need to watch what the owner / group details are and what the permissions are after transferring files. This should be in the guide
 

kinjalk

New Member
Bronze
Oct 31, 2007
32
0
0
#17
yep - it's very much like an ftp programme except that it uses ssh in stead of FTP.

I don't know what instructions you're following but yes - it'll be for copying files to the iPhone. As the iPhone is a bsd/linuxy thing you'll need to watch what the owner / group details are and what the permissions are after transferring files. This should be in the guide
Sweet, i will try this today and spend some more hours tonight and see if it works, thank you for your help we'll find out tonight if it works. Thanks buddy
 

wildonrio

New Member
Gold
Jul 4, 2007
2,002
6
0
Provo, UT
#19
There is no way to unlock an out of box 1.1.2 iPhone currently, so give up now. Check hackint0sh.org frequently to wait and see if the hacking community comes up with a solution.

The reason it won't work is because the out of box 1.1.2 iPhones come with a new bootloader, version 4.6, instead of version 3.9 which is found on 1.1.1 iPhones and 1.1.2 upgraded iPhones. There is no way to downgrade the bootloader.

Go here http://docs.google.com/View?docid=dgzw9xs_0gfhxns to check the status of OOB 1.1.2 iPhones and wait for that "No" to turn to "Yes" and then head over to hackint0sh.org for instructions.