3 second delay opening settings or contacts or messages

Sep 24, 2008
9
0
0
#1
I have started noticing a 3 second delay when I hit messages or contacts and I am wondering why. The phone didn't do it when I got it and I only have 90 contacts, 4 sms conversations and one and a half pages of apps (including bookmarks and Apple stuff. Maybe 4 add-on applications in total).

Anyone got any ideas? Is this normal? It's not the end of the world, just weird that it has suddenly started doing it.
 

FlwrPwer

Evangelist
Gold
Aug 7, 2008
1,855
77
63
39
Montgomery, NY
#2
I have started noticing a 3 second delay when I hit messages or contacts and I am wondering why. The phone didn't do it when I got it and I only have 90 contacts, 4 sms conversations and one and a half pages of apps (including bookmarks and Apple stuff. Maybe 4 add-on applications in total).

Anyone got any ideas? Is this normal? It's not the end of the world, just weird that it has suddenly started doing it.
What version firmware are you running? There was a lag on the contacts prior to 2.1

I had this and it drove me slightly crazy, but I haven't really had it since I downloaded and upgraded to 2.1
 

Sharunda

Genius
Gold
Jun 16, 2008
4,992
1,100
113
One Horse Town, New Jersey
#3
I have a delay when opening things too. I have the new 2.1 software too. When I first downloaded the software it was great. Everything moved faster, but now, things are slower. Also, before the download the battery power drained faster, but after the download battery power appeared to be better. The battery power as well as the lag as well as the 3G is starting to revert back to what it was before the download is what's happening to my phone now.

What I have been doing is a hard restart of the phone from time to time to try and recapture that fresh downloaded speed sensation that it had the first time i installed the new update.

I even reinstalled last night and today things are going great. I think this last one will do the trick for a while anyway.

Hard restarts and reinstalls seem to help.
 

Rockky

New Member
Bronze
Aug 8, 2007
333
0
0
#6
restored my phone and it helps now for like one day...then back to big lags
 

cliffeman

Zealot
Gold
Oct 13, 2007
2,142
80
48
Feenix, Amizona
#7
I started to notice lag on my keyboard lately. I reboot several times when i update or install certain apps that require a reboot.
 
Sep 24, 2008
9
0
0
#8
What version firmware are you running? There was a lag on the contacts prior to 2.1

I had this and it drove me slightly crazy, but I haven't really had it since I downloaded and upgraded to 2.1
I'm running 2.1
 

DrBlack72

New Member
Oct 1, 2008
4
0
0
#9
Lag in SMS, Contacts, Keyboard, etc.

I have the same problem. When I upgraded to 2.1, Everything was pretty fast. For a while. SMS, contacts and keyboard speed gradually began to slow down and I am now at a crawl until I do a hard reboot. That seems too help a little for a little while. Anyone have an ideas on how to fix this?
 
Sep 6, 2008
16
0
0
#12
I'm having the same problem, I'm on version 2.1 and my phone isn't jailbroken. I did a hard reset and that didn't seem to help much either...
 

Devori

New Member
Jun 15, 2007
131
0
0
Long island NY
#13
I have been told in the past, that because the iPhone is very much like a mini computer, it should be power cycled at least once a day. this would help with any lag... This will also help with reception, as you are re-establishing your sim on the nearest towers.
 

Youngbinks

Zealot
Gold
Jun 4, 2007
7,617
3
38
31
Atlanta, Georgia
#14
Also, Jailbreaking the iPhone is likely to cause it to run a bit slower, which may lead to the delay when opening some programs.
 

samy

New Member
Bronze
Sep 23, 2008
33
0
0
California
#15
Also, Jailbreaking the iPhone is likely to cause it to run a bit slower, which may lead to the delay when opening some programs.
This is what I was going to say, mine has slight delay when it's jailbroken.

ps-why is your head cut off in you avatar?
 

showguy

Member
Silver
Dec 2, 2007
769
15
18
Long Island, NY
#16
I have a delay when opening things too. I have the new 2.1 software too. When I first downloaded the software it was great. Everything moved faster, but now, things are slower. Also, before the download the battery power drained faster, but after the download battery power appeared to be better. The battery power as well as the lag as well as the 3G is starting to revert back to what it was before the download is what's happening to my phone now.

What I have been doing is a hard restart of the phone from time to time to try and recapture that fresh downloaded speed sensation that it had the first time i installed the new update.

I even reinstalled last night and today things are going great. I think this last one will do the trick for a while anyway.

Hard restarts and reinstalls seem to help.
The exact same thing was happening to me out of nowhere. On top of that my battery seemed to be heating up and my battery meter was doing strange things. So yesterday I had the phone replaced. The replacement came with software 2.02. I upgraded to 2.1. All seams fine again. We shall see.
 

DrBlack72

New Member
Oct 1, 2008
4
0
0
#17
I also read that with version 2.1, we should be prompted to "click here to see more messages", or something like that when we have a long txt message conversation with someone. I don't see that. This is frustrating. Any help anyone can provide would be greatly appreciated. Thanks!
 

Youngbinks

Zealot
Gold
Jun 4, 2007
7,617
3
38
31
Atlanta, Georgia
#19
This is what I was going to say, mine has slight delay when it's jailbroken.

ps-why is your head cut off in you avatar?
I asked my father (who is very iPhone incompatible) to take a picture of me with the mountain in the back ground and that is what I got. Time for a change soon though.
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#20
I asked my father (who is very iPhone incompatible) to take a picture of me with the mountain in the back ground and that is what I got. Time for a change soon though.
It's funny, my mother-in-law has issues with using an LCD screen on a camera as well. She says, and I quote, "It's disorienting how when I move the camera left, the image on the screen goes right"

How do you help someone like that?

Sorry to threadjack.