3G internet connection problem

Jan 26, 2009
5
0
0
#1
This is on my iPhone 3G 8 gig. Everytime I switch the connection to 3G it stays on 3G for like 5 secs and then goes back to edge. Even when it was on 5 bars. Ive tried restoring no good there. Any help would be appreciated.
 

LuvKeane

New Member
Bronze
May 10, 2009
186
0
0
Broadway
#4
I have this same problem. It's when I'm in certain areas AND I was using a Bold! So it's not an Apple thing but AT&T. I'm living in NYC and up where I live, no problems. But in midtown, it switches back and forth like there's no tomorrow along with the signal bars.
 

MrEous

Member
Silver
Dec 11, 2008
649
1
18
Dallas, TX
#5
I would say it's the area you're in as well...also if there are a lot of 3G att users in your area at one time it can lower the 3G availability.
 
Jan 26, 2009
5
0
0
#6
Well heres the thing we have 3 other iPhones in this house and they all get 3G connections no problem. It seems like this one phone is refusing it or something.
 

dturner

Zealot
Gold
Dec 15, 2007
5,725
12
38
Louisville, Ky.
#7
Well heres the thing we have 3 other iPhones in this house and they all get 3G connections no problem. It seems like this one phone is refusing it or something.
Try Settings-General-Reset-Reset Network Settings, then power off and back on and see if this helps.
 
Jan 26, 2009
5
0
0
#8
nope no luck there. i set an appointment for me local Apple store 2maro and hopefully theyll have a solution
 
Jan 26, 2009
5
0
0
#9
wow factory defect who wuda thoght kinda pisses u off don't it........
well anyways they gave me a new iPhone hooray