3G iPhone on 3.1 no MMS?

bluedrib

New Member
Bronze
Nov 27, 2007
62
0
0
The Boot "Louisiana"
#1
i have a 8gb 3G iPhone i updated the 5.5 carrier file and no mms. i cant send, or receive. I have restored the iPhone and tried again, and still no MMS.

Can ANYONE help or have fix and has this happened to anyone else?
 

BigCiX

Zealot
Gold
Jul 11, 2008
1,445
5
38
Bakersfield, CA
#2
- Download and install the update
- hit update again and download the carrier update
- hold home and power to reset your phone.

U now have mms. Go under setting/messages and make sure. U should have a camera icon when u text message.
 

uPhone559

New Member
Bronze
Jul 18, 2007
389
1
0
#3
one of my other iPhones is having that same problem, i've tried restoring as new and it doesn't work. The camera icon is there but i still get a red !.

maybee a call to 611 tomorrow will fix it.
 

FlwrPwer

Evangelist
Gold
Aug 7, 2008
1,855
77
63
39
Montgomery, NY
#4
Same issue here. Just tried to send my first MMS....and I'm getting the red exclamation point.
 

Watcher

Zealot
Gold
Mar 29, 2009
1,785
30
48
Phoenix, AZ
#5
To those who're having problems, you all rebooted after you updated to the new carrier file, didn't you?
 

FlwrPwer

Evangelist
Gold
Aug 7, 2008
1,855
77
63
39
Montgomery, NY
#6
Got mine working. Just had to have more patience. It just takes a long time.
 

Eragon

Zealot
Gold
Jan 8, 2008
3,056
5
38
50
Frederick, MD
#7
The red exclamation points are a sign that AT&T has not turned off the MMS opt-out on your line. A call to AT&T should fix the problem.
 
Sep 19, 2007
3
0
0
Texas
#8
I'm also having this problem. I called ATT this morning and spoke with a customer service person and an ATT technical support person. Both stated there is no switch on my account to turn on/off MMS. I can send a text only message, but no picture in a text message. I also can receive a text only message, but again, not with a picture.
 

KevJD

Member
Bronze
Aug 30, 2008
168
4
18
#9
I'm also having this problem. I called ATT this morning and spoke with a customer service person and an ATT technical support person. Both stated there is no switch on my account to turn on/off MMS. I can send a text only message, but no picture in a text message. I also can receive a text only message, but again, not with a picture.
I'm assuming that the little camera button is present and you are able to attach a picture, but it fails to send...correct? Do you have a strong Edge signal, or even better a strong 3g signal? If you don't have a good signal, the mms will time-out while trying to send. You can't send an MMS via just wifi either. You may want to roll-back your carrier file to 4.0, and then update back to 5.5 through iTunes again. Don't forget to reset your phone first thing after updating to 5.5
 
Sep 19, 2007
3
0
0
Texas
#10
You're correct. I have the camera icon, I can attach the picture to a text message, and after pressing Send it times out. I've tried edge and 3G with full bars and I'm not using wifi. I'll try rolling back the carrier file and see what happens. I'll post back if it works.
 
Sep 19, 2007
3
0
0
Texas
#11
Problem solved! I called ATT and apparently when I upgraded from the original iPhone to the iPhone 3G some sort of equipment code was not updated. So, my 3G iPhone couldn't send an MMS message because ATT thought I still had an original iPhone, which doesn't support MMS.

By the way, this was the second call to ATT technical support. The first call yielded nothing from tech support. If you call them ask them to check the equipment code specifically.
 

torbo401

New Member
Nov 5, 2007
6
0
0
#12
that was my problem too, i upgraded to 3.0 like a butthead and it still didn't work until i called AT&T Apple put me on the 2g plan from when i had a refub. but now its working like a charm
 

dyzfnctional

New Member
Bronze
Jul 1, 2007
59
0
0
#13
are you guys getting trouble receiving mms from friends using other carriers etc? i don't seem to receive any mms from friends who are with sprint/tmobile..etc
 
S

skyshirbi

Guest
#14
Got mine working. Just had to have more patience. It just takes a long time.
Glad to hear you're using this: I plan to keep it much more aggressively up-to-date than has been the case in the past, but don't hesitate to let me know if you find errors or need clarifications.;)
 

bluedrib

New Member
Bronze
Nov 27, 2007
62
0
0
The Boot "Louisiana"
#15
3g mms fix for 3.1 mms

ok so i was having pproblems sending and receiving mms, but not any more and this is how you fix it.

Call ATT or get in one of those customer support IM windows and tell them to check and make sure your 3G iPhone is on the 3G texting plan. Thats it! For some reason they had me on the 2G texting plan so it was still blocking it........which also leads me to believe that 2G iPhone owners Technically could have MMS if ATT would just un block it!
 
Apr 1, 2009
6
0
0
#16
I was on phone for an hour. I told them first to check equipment code bc i switched to 3g bout 6 months ago. First guy didn't. I then talked to the specialist, he updated my equipment code to 3g and voila, it worked.
 
Jul 28, 2007
29
0
6
#17
i was on the phone for 2 hours today with AT&T and they checked everything from equipment code to text plan to opt out mms and nothing worked....restored back to original and loaded everything on again and still nothing...still get the red exclamation points....very frustrating.....
they have a case open and are supposed to be working on it.....they want me to go to att store and try my sim card in a phone that actually can send mms and see what happens...gonna try it tomorrow....
 
Jul 28, 2007
29
0
6
#18
wow! went to my local office and guy went into my account and reset it somehow.....bammmm....mms working.....5 minutes tops....jeez...the 2 hour call to att couldn't do a darn thing....this guy 5 minutes.....all i remember is he said he reset my account.....those still having trouble i would call this office in Daphne, Alabama....guy was tall and dark headed....real smart.....i know it sounds like a crazy idea but it might work since he got mine working.