3G Jailbroken to v3.0, but NO copy-paste

eye-Fone

Zealot
Gold
Jul 5, 2008
1,024
14
38
Sunny, southern California.
#1
Environment: iPhone 3G 16Gb, Windows PC, jailbroken 3.0 (used RedSn0w)

Problem: I can select text, but there is no "Copy" popup command. :(

I successfuly upgraded to 3.0 and JB'ed it. Everything else works well, except for the above. I can select text using the two "handles" that I drag around, but the "Copy" command doesn't present itself. In order for me to get the selection handles, I have to double tap on the text and then the handles appear, usually around one word (where I tapped). I can then stretch the selection area using the handles, but then there is nothing else I can do. If I tap and hold, the selection goes away. If I double tap, the selection goes away.

How can I get the "Copy" command to appear?

Thanks!
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,507
113
Utah
#2
I'm not sure, but you could just use hClipboard since you are JB now. It's better than the 3.0 copy paste anyway.
 

michael180

Zealot
Gold
Jun 14, 2007
1,249
3
38
Santa Cruz, CA
moderntimes.com
#3
Environment: iPhone 3G 16Gb, Windows PC, jailbroken 3.0 (used RedSn0w)

Problem: I can select text, but there is no "Copy" popup command. :(

I successfuly upgraded to 3.0 and JB'ed it. Everything else works well, except for the above. I can select text using the two "handles" that I drag around, but the "Copy" command doesn't present itself. In order for me to get the selection handles, I have to double tap on the text and then the handles appear, usually around one word (where I tapped). I can then stretch the selection area using the handles, but then there is nothing else I can do. If I tap and hold, the selection goes away. If I double tap, the selection goes away.

How can I get the "Copy" command to appear?

Thanks!
I too am on a jailbroken 3.0. I selected text on a web page, was able to stretch and select, and the copy balloon appeared. I then went into Notes, and tapped to get the circle, and got the past balloon. It pasted fine.
 

eye-Fone

Zealot
Gold
Jul 5, 2008
1,024
14
38
Sunny, southern California.
#4
I know.

When I went to 3.0 JB, I wanted to get rid of Clippy (which I've used since its inception) and use the native copy-n-paste. It looks like I may have to re-evaluate third-party c-n-p utilities.

So, has anyone else experienced this half-baked c-n-p on a newly JB'ed 3.0 on the 3G?
 

eye-Fone

Zealot
Gold
Jul 5, 2008
1,024
14
38
Sunny, southern California.
#5
I too am on a jailbroken 3.0. I selected text on a web page, was able to stretch and select, and the copy balloon appeared. I then went into Notes, and tapped to get the circle, and got the past balloon. It pasted fine.
You're on the second-generation iPhone (the 3G), yes?

If so, I may have to re-JB tonight and see what happens.

Thanks.
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
701
113
#6
You're on the second-generation iPhone (the 3G), yes?

If so, I may have to re-JB tonight and see what happens.

Thanks.
I think re-jb'ing your phone is the best bet, delete the custom FW and get a new one and see how you get on.
 

Rip

Member
Silver
Oct 23, 2007
636
0
16
Northern England
#8
That's certainly weird.

I had both hclipboard and clippy installed (pretty limited compared to the native) on 2.2.1 and upgraded to 3.0 and JB with redsn0w.

Copy paste is working fine, so it's unlikely to be installation of 3rd party copy/paste that's caused the problem.

However, restoring doesn't remove every trace of jailbreak apps. My SBSettings config was still there after a restore and set-up s new iPhone!

Hope you get it sorted.
 

eye-Fone

Zealot
Gold
Jul 5, 2008
1,024
14
38
Sunny, southern California.
#9
That's certainly weird.

I had both hclipboard and clippy installed (pretty limited compared to the native) on 2.2.1 and upgraded to 3.0 and JB with redsn0w.

Copy paste is working fine, so it's unlikely to be installation of 3rd party copy/paste that's caused the problem.

However, restoring doesn't remove every trace of jailbreak apps. My SBSettings config was still there after a restore and set-up s new iPhone!
I had Clippy installed prior to the upgrade and I haven't installed any 3rd party c-n-p apps since the 3.0 JB upgrade.

When I JB'ed from 2.2.1 to 3.0, I did a "Shift-Restore" from iTunes. Doesn't this remove everything and starts from scratch?
 

eye-Fone

Zealot
Gold
Jul 5, 2008
1,024
14
38
Sunny, southern California.
#10
Here's an update...

I can successfuly c-n-p from the notes app, Safari/web pages, text messages, calendar appointments, Twinkle (twitter app), but NOT from any email messages!

Argh! :(
 

Rip

Member
Silver
Oct 23, 2007
636
0
16
Northern England
#11
Bizarre!

I just checked and it should work.

You have to open the message first (at the risk of stating the obvious).
 

eye-Fone

Zealot
Gold
Jul 5, 2008
1,024
14
38
Sunny, southern California.
#12
Bizarre!

I just checked and it should work.

You have to open the message first (at the risk of stating the obvious).
Yeah, I open an email, scroll down to the middle of the text and I am able to select the text (using the two handles that stretch over the text), but there is no "Copy" popup (nor is there a "Select", "Select All" popup). These popups appear in other apps, but just not in an email message.
 

iErik

Zealot
Gold
Oct 27, 2007
1,221
72
48
Las Vegas, NV
#13
I second restoring (set up as new phone) and rejailbreak. When I jailbroke over the weekend my option to set auto-lock to "never" was gone. I had to re-jailbreak (twice) to get it back.
 

eye-Fone

Zealot
Gold
Jul 5, 2008
1,024
14
38
Sunny, southern California.
#14
Problem Solved!

My c-n-p problem in email has been solved! :)

I wanted to go into some apps like Intelliscreen and Winterboard to see if there was something in their settings that could be related to my problem. Nothing was found in those apps.

However, when I went into the "Rock" application--the one that gets installed when you install Intelliscreen, a message was displayed. It said something to the effect of, "due to license changes, a reboot is required" (or something similar). I tapped OK and it rebooted the Springboard. When it was done, I went into an email message and voila!...c-n-p was working! :laugh2: I checked the other apps and c-n-p still works! Cool!

I don't know what the Rock app did, but I'm just happy to have everything working in 3.0 JB.
 

wd_stroke

New Member
Bronze
Apr 12, 2008
114
0
0
#15
I'm not sure, but you could just use hClipboard since you are JB now. It's better than the 3.0 copy paste anyway.
That's my favorite app...but it's NOT working on FW3.0
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,507
113
Utah
#16
I have a 3G and used QuickPWN and Ultrasn0w and the 3.0 copy/paste is working fine for me.