3G Sucks (with update 2.0.2)!

mcaram16

Member
Silver
Jul 26, 2007
715
0
16
Long Island, NY
#1
Since i've upgraded to 2.0.2 ive had nothing but problems with 3G! When it looks for my email which i have it setup to automatically check every 15 min, all it does is say "connecting" but never connects. It keeps trying for hours and hours until i reboot the phone....the internet will work 1 minute, then the next minute it won't...and this is all while i have full service and 3G!
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#2
Perhaps try resetting your network settings?
 

jerryf

New Member
Jul 16, 2008
9
0
0
#3
I have the same problem with 3G. I have turned it off and am using Edge for the time being. Hopefully, Apple will acknowledge that this is a problem and fix it in the September update.
 

dturner

Zealot
Gold
Dec 15, 2007
5,725
12
38
Louisville, Ky.
#4
Hopefully, Apple will acknowledge that this is a problem and fix it in the September update.
Apple has finally fessed up to the problem but seem to be leaving it up to Infineon to come up with a fix. Said that it could take several months for this to happen.
 

iB4STiD

New Member
Aug 20, 2008
8
0
0
#5
Or Good old Apple could just recall these iPhones, Will they? No lol :cool:
 

damstr

Member
Bronze
Jul 2, 2007
133
1
18
#6
Apple has finally fessed up to the problem but seem to be leaving it up to Infineon to come up with a fix. Said that it could take several months for this to happen.
Oh thats just awesome, everyone has perfectly working 3G before the update, they release it and suddenly almost everyone is having problems with 3G but they want to let someone else fix it. Amazing.
 

Drunken

New Member
Aug 17, 2008
22
0
0
#7
The 2.0.2 update fixed the problem for some, and for some it made it worse. (It works a lot better for some people, and not at all for some.)
 

mcaram16

Member
Silver
Jul 26, 2007
715
0
16
Long Island, NY
#8
The 2.0.2 update fixed the problem for some, and for some it made it worse. (It works a lot better for some people, and not at all for some.)

It is crazy! And i continue to have nothing but issues with 3G....whats funny is that it only seems to be messed up when I have full service...if i have 1 bar it works fine!
 

nbdiver

Member
Bronze
Jul 7, 2008
246
0
16
Scottsdale, AZ
#9
I can report the opposite...I have had poor 3G coverage at my house since I bought the phone and all of sudden (actually days after I did the update) my phone now gets 2-3 bars consistently at my house whereas before I was mostly on Edge? Not sure what the change could be? Ironically I put on a Bodyguardz face cover and since I did that the reception got better but I know that can't be the reason...just ironic!
 

matt33263

New Member
Bronze
Jun 9, 2008
87
0
0
Texas
#10
I can report the opposite...I have had poor 3G coverage at my house since I bought the phone and all of sudden (actually days after I did the update) my phone now gets 2-3 bars consistently at my house whereas before I was mostly on Edge? Not sure what the change could be? Ironically I put on a Bodyguardz face cover and since I did that the reception got better but I know that can't be the reason...just ironic!
I'm right there with you! I only bought my phone yesterday though but when I got it home I could not use 3G I then upgraded my phone to 2.0.2 and I now have great service here.