3GS iPhones can no longer restore to 3.0

RossMc

Zealot
Gold
Jun 28, 2009
1,124
2
38
28
Newcastle, UK
#1
As of this morning 3GS owners can no longer restore to firmwares 3.0 or 3.0.1. This is due to the fact that Apple has stopped signing these files and if you try and restore using one you'll get an error. So this means you should be very very careful until 3.1 is jailbroken because if you mess up your phone... you can only go up to 3.1 as of now. Additionally if you do not have your IBSS and IBEC signatures and you restore, you may never be able to jailbreak again.

iPhone 3G and first generation owners should still be able to restore with no problems.

via [Big Boss Blog]
 
Last edited by a moderator:

rojocrandall

Member
Bronze
Mar 2, 2009
424
5
18
#2
9/9/9 Tweet from saurik sums it up for me:
"The shear number of man-hours that have globally been destroyed because of Apple's insistence on evil engineering practices depresses me. :("
 
Aug 13, 2009
6
0
0
#6
yeah, i just heard that earlier this morning. Wow, last wed night I restored and captured both files and stored my ecid on cydia....whew....close one. Now we have to patiently wait for the dev team. I have a question though. I have two other phones that are 3gs for family members that do not want to fool around with jailbreaking. They would just be confused by it. However, when I go to sell the phones for them when we are eligible for the iPhone Excalibur or whatever in 2 years then are they screwed as far as unlocking goes do to this new security on the 3gs or will the dev team eventually be able to jailbreak and then modify the baseband to work with ultrasnow? I have heard without the two files, ibss and ibec then unlocks are not possible if you update, however jailbreaks are with the ecid file stored on cydia, if you were able to get it on there before Apple started getting nasty with not signing certificates anymore for old fw. :sneaky:
 

RossMc

Zealot
Gold
Jun 28, 2009
1,124
2
38
28
Newcastle, UK
#7
yeah, i just heard that earlier this morning. Wow, last wed night I restored and captured both files and stored my ecid on cydia....whew....close one. Now we have to patiently wait for the dev team. I have a question though. I have two other phones that are 3gs for family members that do not want to fool around with jailbreaking. They would just be confused by it. However, when I go to sell the phones for them when we are eligible for the iPhone Excalibur or whatever in 2 years then are they screwed as far as unlocking goes do to this new security on the 3gs or will the dev team eventually be able to jailbreak and then modify the baseband to work with ultrasnow? I have heard without the two files, ibss and ibec then unlocks are not possible if you update, however jailbreaks are with the ecid file stored on cydia, if you were able to get it on there before Apple started getting nasty with not signing certificates anymore for old fw. :sneaky:
I done the same thing my iPhone was away for repair and I got it back early morning Wednesday and got iBEC & iBSS straight away before I done anything else because I remembered I might need them sometime and also got my ECID files on Cydia.

Glad I did it now :cool:
 

ZipZap

Member
Silver
Dec 15, 2007
529
1
18
#8
Perhaps a class action lawsuit will follow as I don't think Apple has the right to force people to upgrade... and for 3GS that is exactlywhat they are doing.

Its the same with Microsoft not having the right to force me to Windows 7.

Apple sucks.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#9
Perhaps a class action lawsuit will follow as I don't think Apple has the right to force people to upgrade... and for 3GS that is exactlywhat they are doing.

Its the same with Microsoft not having the right to force me to Windows 7.

Apple sucks.
How did you construe that Apple is forcing you to upgrade?
They are doing nothing illegal by not allowing downgrading.
The choice to upgrade to 3.1 is yours, you simply press the "no" button if you don't want the update. Both my iPhones are still on 3.0.1.
 
Jun 19, 2007
33,493
4,550
113
Upper Marlboro, MD
#12
Still possible to downgrade 3.1 to 3.0 or 3.01:
http://www.blogsdna.com/3911/how-to-downgrade-iphone-3gs-31-to-30-os.htm

You need iTunes 8.2 to do it as 9.0 won't allow a downgrade.
This article was written on July 7. It seems to be focused on the 3.1 beta. I don't think this method will work on 3.1 final as Apple isn't signing any previous firmware versions as of this week.

I downgraded from 3.1 beta to 3.0.1 myself with no problem, only keeping the 3.1 beta baseband, which is not the same as the baseband in 3.1 final.
 

ZipZap

Member
Silver
Dec 15, 2007
529
1
18
#13
How did you construe that Apple is forcing you to upgrade?
They are doing nothing illegal by not allowing downgrading.
The choice to upgrade to 3.1 is yours, you simply press the "no" button if you don't want the update. Both my iPhones are still on 3.0.1.
Not really sure why you not seeing this clearly.

If I cannot restore my phone to 3.0 then I am forced to upgrade at some point.

You know as well as anyone, that restores are presently a way of life for the iPhone. You also know that Apple is not quick to fix issues.

As far as I am concerned this is not an appropriate action for Apple to take and why I say....THEY SUCK.
 

ZipZap

Member
Silver
Dec 15, 2007
529
1
18
#14
Yeah what's the secret?
 

AeroCare

Zealot
Gold
Jul 16, 2009
1,210
25
48
All over the World !
#16
So it's better to keep iTunes 8 and not switch to 9? I'm not even thinking about upgrading to 3.1 as I need tethering. Just asking about the iTunes 9.
 

RossMc

Zealot
Gold
Jun 28, 2009
1,124
2
38
28
Newcastle, UK
#17
iTunes 9 is meant to be okay with Jailbroken/Unlocked iPhones but im just going to stick with iTunes 8 for now until a jailbreak/unlock for 3.1 is released just incase.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#18
Aero, tethering does still work with iTunes 9 as long as you stay on 3.0.1.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#19
Not really sure why you not seeing this clearly.

If I cannot restore my phone to 3.0 then I am forced to upgrade at some point.

You know as well as anyone, that restores are presently a way of life for the iPhone. You also know that Apple is not quick to fix issues.

As far as I am concerned this is not an appropriate action for Apple to take and why I say....THEY SUCK.
If you are forced to restore then, yes you'll have to go with the latest firmware, but I doubt that's illegal on their part. You could read through the Terms of Service if you want, you electronically signed it when you set the phone up, it's about 150 pages. But unless you're restoring, the choice to upgrade is yours. It will still never become a class action lawsuit, because there is really no reason legitimate reason to stay on old firmware. Most people that do it are waiting for a jailbreak, unlock, or want the old tethering hacks to still work or something else that is probably outside of the TOS.
 

ignite600

New Member
Jan 19, 2009
12
0
0
Central FL
#20
what about 3G phones that have upgraded to 3.1? can they be downgraded to 3.0 or 3.0.1? if so, how can this be done.