3GS won't wake up right away

Deke736

Member
Bronze
Jul 24, 2008
142
2
18
Near St. Louis, MO
#1
Lately, my 3GS doesn't wake up right away. Sometimes it takes 2 or 3 presses on the home button to get to the screen to wake up. Is anyone else having this issue?
 
Jul 26, 2009
1
0
0
#2
Does the screen flicker like it might wake up, but then goes blank again? Mine's done that three times now, twice a day or two ago and once today. It woke up on my next try. I was pressing the sleep button, not the home button, though.
It also lags a tiny bit sometimes. Maybe just a second or two, but it doesn't wake as soon as I release the button. Is that normal, or did yours do that before it started not waking at all?
 

Deke736

Member
Bronze
Jul 24, 2008
142
2
18
Near St. Louis, MO
#3
Nope, no flicker, just takes about 10 seconds to wake up after pressing the home button. I'm going to try to restore it today to see if that helps, if not I'm going to take it to Apple. It's just really annoying.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,507
113
Utah
#4
^ That's exactly what I would do.

A couple people here have had defective home buttons. Apple will replace it.
 
Aug 2, 2009
4
0
0
Bethlehem, PA
#5
The identical thing happens to my iPhone as well. I've had it since late June and within the past month or so whenever I press the Home button to wake it from sleep mode it doesn't wake right away, and when it does finally wake it shows the iPod controls as if I was listening to music, but I wasn't listening to any music. Also, sometimes when I plug it into the charger it doesn't respond right away, either.

This is all very frustrating. It doesn't happen all the time, only sporadically. Is this something that Apple would warrant as being defective and replace? Or because it can't be repeatable every time would they say it's user error or something and not help me out?

Thanks for your help!

-Mike
 

coonbri

New Member
Aug 28, 2009
1
0
0
#6
Lately, my 3GS doesn't wake up right away. Sometimes it takes 2 or 3 presses on the home button to get to the screen to wake up. Is anyone else having this issue?

I am having the exact same issue. Did you get this resolved?

I just read through this thread again and noticed the last one posted by Mike regarding the iPod controls showing. Mine does that as well. Did you all find out why this is happening? My phone has been fine since I bought it 6 weeks ago. I added no software to it, just pictures and videos.

Thanks!
Brian
 
Aug 2, 2009
4
0
0
Bethlehem, PA
#8
Coonbri:

To remedy the slow wake response I restored my iPhone in iTunes. I also deleted a bunch of free apps--both on the phone and also from itunes--that I downloaded and hardly ever used. Since then the phone has only had a delay while coming out of sleep mode once, it's been flawless in every other respect.

I figured out why the iPod controls pop up: The iPod controls pop up because no matter what state the iPhone is in when it's on--actively using, or in sleep mode--when you double-tap the Home Button the iPod controls will come up. So when you're trying to wake the phone from sleep mode and it doesn't wake right away, of course you're going to hit the button again. And pressing it again is what brings up the iPod controls.

Try the restore from iTunes and see if that helps you out, and also maybe try deleting any apps that you don't use. I can't attest if this is what actually is causing the delayed response in other iPhones, but restoring the phone and deleting some apps is what worked to cure my phone from the delays.

Hope this helps.

-Mike
 

harris218

New Member
Aug 31, 2009
18
0
1
#9
Mine has done this as well, I have a 16GB 3GS. I am thinking it might be more of a network thing. It seems the pause mat be due to the iPhone searching the network. After all we are talking about AT&T......
 

BrownGem

Zealot
Gold
Feb 27, 2009
1,623
22
38
Texas
#10
Mine has done this as well, I have a 16GB 3GS. I am thinking it might be more of a network thing. It seems the pause mat be due to the iPhone searching the network. After all we are talking about AT&T......
I don't think this is normal even if searching for a signal. I have had poor signal before but I have never had an unusual lag in the device waking up. My 3G and 3GS never had this issue.