3rd Party Apps Glitch Issue

bacon_and_rice

New Member
Bronze
Jul 9, 2008
45
0
0
#1
is anyone having this problem? all of my 3rd party apps just stopped working that i downloaded from the apps store, nothing new was downloaded to trigger this issue. i've had it happen to me 3 times already. when i click on an app, it opens for 5 seconds and then it goes back to the dashboard. the other primary apps like the camera, calendar, notes, etc apps work fine.

i've spent all weekend with tech service with Apple who can't figure out the bug, other than i need to deal with it by constantly backing up my phone, doing a stock restore, and re uploading. but with the 30 minute back up time, and doing such is just ridiculous. i was showing a sales team at work today how they should switch to the iPhone 3g for the work force, and then after playing with it, none of the 3rd party apps. there goes that potential referral for the iPhone. i supported Apple by buying a new mac book and iPhone v1 and 3g. but them telling me i have to pay 10% restocking fee because THEIR product is defective, and i'm not even wanting to return it, but simply EXCHANGE it for the same iPhone! wth is wrong with this picture. i told Apple they are on crack rocks if they think they want me to pay that amount.
 

sgrizzle

New Member
Jul 17, 2008
29
0
0
#2
I'm having the exact same issue. I just did a complete reset/restore and still having the same issue.
 

sgrizzle

New Member
Jul 17, 2008
29
0
0
#3
I think I found the problem. My Credit Card on the iTunes store had expired. I tried deleting some apps and resyncing to reload and it said 'you are not authorized to use these applications'

I updated my credit card, "authorized the computer" and resynced the apps. now they work.
 

Ohmster

Member
Silver
Jan 26, 2008
533
21
18
SoCal
#4
Had the same issue. I deleted the application from the iPhone and then set the Applications tab to 'sync'. On the next sync the applications reappeared and have been working ever since.
 

bacon_and_rice

New Member
Bronze
Jul 9, 2008
45
0
0
#5
interesting that you said that. Usually a restore fixes it, this is the first time it still doesn't work for me after restore. I know my iTunes credit card is still good, I just got a bill electronically for it.

I'll try deleting them and restoring the applications only
 

adambodkins

Member
Bronze
Jul 15, 2008
112
1
18
#6
I had the same issue two days ago actually since day 1 but got it resovled two days ago after spending at total of 1hr 43 min 27 sec on hold with Apple I finally made it through to someone and they talked me through everything on doing a restore. Her name was sarah and she was even nice enough to tell me how to sync to contacts. She stayed on the phone with me the whole time walking me through every step even engaging me in friendly conversation. But the moral to this story is that we did a complete restore and upgraded to the newer 2.0 and works flawlessly. Only problem still having is my contacts lagging and my phone has only once went silent without fliping the toggle.
 

mlass

Member
Silver
Jun 19, 2007
678
0
16
#7
interesting that you said that. Usually a restore fixes it, this is the first time it still doesn't work for me after restore. I know my iTunes credit card is still good, I just got a bill electronically for it.

I'll try deleting them and restoring the applications only
Another one of those restores that fixes everything.
 

mlass

Member
Silver
Jun 19, 2007
678
0
16
#8
I have had two updates on APPs that both stated to correct this problem.

You have to remember, a lot of APP's never had the chance to actually test it on an iPhone 3G.