999's Fight Club - New Source + my 1000th Post!

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#1
1.1.4 Update: The Source URL Has been Changed to http://dezign999.com/repo

There's something in the Air... No, not the Macbook Air, but a host of cool stuff to spice up your iPhone! I'm ringing in my 1000th post to officially launch this thing, lets ride it till the wheels fall off! Seriously, I'm expecting my host to send me a strongly worded letter, so lets get their bean counters counting!

To Add My Source
Add the line below to your Installer Sources:
http://dezign999.com/repo

What's Currently Available



WallPapers
  • Alex P. Keaton for President '08
  • Mercedes Benz Logo
  • Zelda - iPhone
  • Sexy Panther Cologne
  • I Love Lamp
  • This is why im hot
  • Parappa!
  • PSPgirl

SummerBoard Themes
  • Basic Black
  • Leopard999
  • HBO's Rome
  • PSPgirl

Icon Replacements
  • NES - Donkey Kong
  • iZoo -> iBejeweled2

Fixes
  • Wallpaper - Wallpaper Directory Permissions for 1.1.4
  • TapTapRevoFix - TTR Media Permissions for 1.1.4
  • iShare - iShare App Permissions for 1.1.4

App Themes
  • Garf -> Simon999
  • TapTapRevolution -> TTR: Colors

Apps
  • Blank.app
  • Peelr (Unzip) Coming Soon!

Ringtones
  • Knight Rider Theme

To view any of this from your iPhone, just press the "More Info" link where applicable in Installer. You'll find a nice screenshot and description page for all the packages.

To Previous Source "misc999" Users
I recommend that you Uninstall any packages from "misc999" that you wish to update with the new "Fight Club" packages. This will also alleviate any confusion with seeing previous packages listed as new when you've already got them installed. Once everything is uninstalled, you can delete the "misc999" Installer source, its no longer there so it doesn't get updated when refreshed.

What Lies Ahead
Now that I know how powerful and easy Installer is to get some of the stuff I've cobbled together for my iPhone out there into the hands of community members, I've got a lot more on the horizon. I still have a number of Wallpapers to convert and add to the source, and there's that nagging issue of the "Transparent Icons" never quite getting done. Thats one beast I plan on tackling for sure.

I'll also continue to post tweaks and any other Terminal commands to help out those less enthusiastic about running Putty or Terminal. If you have any such tweaks just pop a message here and I'll see what we can do about getting it automated through Installer.

Expect more SummerBoard themes and icons as well, I have a handful more that need Installer scripting and html.

Ahhh, its good to be back on my "main" that x666x just didn't feel right... :)
 
Jul 6, 2007
1,832
7
38
26
Marietta, GA
about.me
#2
Congratulations on your 1,000th post! And thanks for all the stuff you put together for us! i had almost everything you hosted on your old source and I am in the middle of uninstalling/refreshing the new source. Thanks!
 

chris

Administrator
Administrator
Jun 10, 2006
11,813
1,779
113
Long Island, NY
#3
Thanks for all your contributions to EIC. Welcome to the Genius club.;)
 

Bone

Zealot
Gold
Feb 11, 2008
1,214
2
38
#4
congratulations again x999x!
 

lman

New Member
Silver
Oct 18, 2007
632
0
0
#5
thanks a lot man, really appreciate all your doing. As for the tweaks...any chance you want to do the ones for ilog? Thanks ahead of time...

also i used your TTR fix, which worked wonderfully and now i can download and save songs, but i don't have any sound...?
 

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#6
Thanks guys! MonkeysRock, iFoneBone, thanks for helping sort out the details with the previous installer source!

Chris, thanks for hosting this community, many of us wouldn't have a home without you!

Iman, do the tweaks actually work? I've been in and out of that thread and I don't think I've read that anyone got iLog to work 100% yet.

Last but not least, I've added 3 new Wallpapers to my Installer Source!

  • Original Apple - Beatles
  • Dark Apple Logo
  • Sweet Dreams are made of Cheese!
 

lman

New Member
Silver
Oct 18, 2007
632
0
0
#8
well fixes definently work because with your fix for ttr mine is now working so I don't see why the fix for ilog wouldn't work?
 

tundra

New Member
Bronze
Jul 15, 2007
57
0
0
New Jersey
#9
first off I would like to say thanks for your contributions to the iPhone community. I would like to know if there is anyway you could perhaps create a fix for mobilefinder. Hope requesting something doesn't cause amy issues. Thanks again.
 

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#11
how is this good its messed up my iPhone GREAT
got to start again thanks a lot :mad:
Hi, could you please be a little more specific as to what your problem is so that we can offer some help? I viewed another thread of yours regarding some trouble you're having and the error you are receiving is synonomous with an Installer with an out of date Community Sources. Thats not an error on my Source's part, and its no reason to restore your phone.

I'm afraid that you're jumping the gun here because you're new to the modding scene, so just take a step back and slow down. We might be able to save you some time restoring that way.

@Iman

Well, I know the fixes on my Source work because I've seen successful reports of people doing this fix manually on their own through the Terminal. I haven't seen such positive reports for iLog however. Much like Customize theres a few "it works for me!" posts amongst a sea of "didn't work for me" posts. I would sincerely like to avoid posting a fix that is hit-or-miss for users, I'd prefer everything works as intended.

If you would like to have a go trying to get this "fix" done through my source, PM me all the links to posts with Terminal commands that are known to get it working and I'll put up a Beta Source for you to test on.

@Tundra

Its no problem making requests, thats how things get done! Regarding your issue with MobileFinder, what seems to be the problem? I'm going to preemptively answer my own question just incase this is your problem. If you find that you can't alter files its most likely because the permissions on the file you're attempting to alter does not allow any rights to the user "root."

I find myself jumping in and out of Terminal on the iPhone doing /bin/chmod and /bin/chown quite a bit right now to get around this issue. I'm not sure theres another way of doing it without a full on application update with the user "mobile."
 

tundra

New Member
Bronze
Jul 15, 2007
57
0
0
New Jersey
#12
Hi, could you please be a little more specific as to what your problem is so that we can offer some help? I viewed another thread of yours regarding some trouble you're having and the error you are receiving is synonomous with an Installer with an out of date Community Sources. Thats not an error on my Source's part, and its no reason to restore your phone.

I'm afraid that you're jumping the gun here because you're new to the modding scene, so just take a step back and slow down. We might be able to save you some time restoring that way.

@Iman

Well, I know the fixes on my Source work because I've seen successful reports of people doing this fix manually on their own through the Terminal. I haven't seen such positive reports for iLog however. Much like Customize theres a few "it works for me!" posts amongst a sea of "didn't work for me" posts. I would sincerely like to avoid posting a fix that is hit-or-miss for users, I'd prefer everything works as intended.

If you would like to have a go trying to get this "fix" done through my source, PM me all the links to posts with Terminal commands that are known to get it working and I'll put up a Beta Source for you to test on.

@Tundra

Its no problem making requests, thats how things get done! Regarding your issue with MobileFinder, what seems to be the problem? I'm going to preemptively answer my own question just incase this is your problem. If you find that you can't alter files its most likely because the permissions on the file you're attempting to alter does not allow any rights to the user "root."

I find myself jumping in and out of Terminal on the iPhone doing /bin/chmod and /bin/chown quite a bit right now to get around this issue. I'm not sure theres another way of doing it without a full on application update with the user "mobile."

I mainly use mobilefinder to delete some customize addons and for other reasons. but it no longer allows file deletion. i am sure this has something to do with permissions seeing it worked fine with 1.1.2 and 1.1.2
 

lman

New Member
Silver
Oct 18, 2007
632
0
0
#13
Thats understandable 999, i'll try it sometime soon. The only reason i didn't do it myself was because when i downloaded terminal it didn't work for me...asked me for my password or something (that was after downloading the fix for it). If you know what my password would be? I saw somewhere that it could be something like alpine?

Oh any chance you knew why i had no sound in TTR? I used your fix and installed your theme as well and it works great, but i have no sound haha.

Thanks for your help so far.
 

bean22

New Member
Bronze
Dec 13, 2007
65
0
0
#14
First i just want to say thanks x999x for the useful themes and fixes.

So, everything i downloaded from your source works perfectly except the iAppaDay Wallpaper fix. After i installed it the wallpapers would not save to my wallpaper library or my camera roll. I tried uninstalling the fix, and it set the permissions back to 0755, but would not actually uninstall. Instead i got the "Main Script Execution Failed" error.

I don't think it matters, but i performed the "save to wallpaper library" fix(changed permissions to 0777) with WinSCP about a week ago and the wallpapers were saving to my library just fine. Then today i discovered your fix and installed it because i want to be able to save to my camera roll as well. Do you think that installing your fix after i had already set the permissions caused the problem?

Either way, I hope you can help me get it working. The best part about the Wallpaper app is being able to save the ones you want. Please let me know what you think...

P.S. if you look at the "Manually Uninstall" thread, i explained all the details of the problem
 

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#15
Thats understandable 999, i'll try it sometime soon. The only reason i didn't do it myself was because when i downloaded terminal it didn't work for me...asked me for my password or something (that was after downloading the fix for it). If you know what my password would be? I saw somewhere that it could be something like alpine?

Oh any chance you knew why i had no sound in TTR? I used your fix and installed your theme as well and it works great, but i have no sound haha.

Thanks for your help so far.
Did it always "not" have sound? I'm not doing anything extraordinary wiht my fix, simply giving the folder the application stores its files in a permission of 777 so the app can view the files as a different user.

Try inserting and removing your headphones. Launch iTunes and turn up the volume, then launch TTR again. Worth a shot, but typically, sound not working after a jailbreak usually requires another jailbreak to sort things out :T

Also, your password is alpine, however it won't work without the SUID fix for Vterm. I believe you can find it under Tweaks. Without the fix you'll be told your password is incorrect even though its valid.
 

lman

New Member
Silver
Oct 18, 2007
632
0
0
#16
As for TTR, its the only thing that doesn't have sound. All the other apps that i have downloaded after jailbreaking work perfectly with regard to sound. I never did have sound, but before your fix it didn't even work, i couldn't download the sonds...Now i can download the songs and play them, there is just no sound...

Thanks for the info on the terminal fix though, i'll try that out soon

thanks
 

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#17
As for TTR, its the only thing that doesn't have sound. All the other apps that i have downloaded after jailbreaking work perfectly with regard to sound. I never did have sound, but before your fix it didn't even work, i couldn't download the sonds...Now i can download the songs and play them, there is just no sound...

Thanks for the info on the terminal fix though, i'll try that out soon

thanks
Okay, this *may* be the issue: TTR is running under Mobile and saving its downloaded tracks as Root. Try uninstalling the TTR fix and reinstalling it. I do a -R to recursively apply +777 to all files inside of /var/root/Media/TTR. Reinstalling will apply the 777 permissions to your newly downloaded files that may have lower settings.

Let me know if this works. If not, try reinstalling TTR as well, (uninstall my mod and fix first).
 

jjsquizz

Member
Bronze
Nov 10, 2007
252
0
16
Los Angeles
#18
Nice stuff. I am bowing as I type. In the middle of unistalling and reinstalling a;most everything. CONGRATS!
 

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#19
First i just want to say thanks x999x for the useful themes and fixes.

So, everything i downloaded from your source works perfectly except the iAppaDay Wallpaper fix. After i installed it the wallpapers would not save to my wallpaper library or my camera roll. I tried uninstalling the fix, and it set the permissions back to 0755, but would not actually uninstall. Instead i got the "Main Script Execution Failed" error.

I don't think it matters, but i performed the "save to wallpaper library" fix(changed permissions to 0777) with WinSCP about a week ago and the wallpapers were saving to my library just fine. Then today i discovered your fix and installed it because i want to be able to save to my camera roll as well. Do you think that installing your fix after i had already set the permissions caused the problem?

Either way, I hope you can help me get it working. The best part about the Wallpaper app is being able to save the ones you want. Please let me know what you think...

P.S. if you look at the "Manually Uninstall" thread, i explained all the details of the problem
Thanks for posting, I will definitely look in to this. This is the second report of an issue with saving to the Wallpaper Library.

I will also check why you received the error when you uinstalled the script, I just now tried uninstalling mine and it worked without any error. You're the first to report of the error so I'm hoping it's an isolated incident.

If you're saavy with WinSCP/CyberDuck, could you please tell me who the owner is of these folders?

/var/mobile/Media/DCIM

/Library/Wallpaper

If it's 501 that would be "mobile" if it's 0 that would be "root." I believe 501 owns both of my folders, if this is not the case for you, I may need to add a /bin/chown to the installer script to change the folder owner.
 

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#20
Nice stuff. I am bowing as I type. In the middle of unistalling and reinstalling a;most everything. CONGRATS!
Thanks!

Hope you like the new stuff, and if you have any requests just post em!

I'd really like to flesh out the Wallpaper section of my source, let me know if theres anything you'd like to see added. :)