Accelerometer acting up, hardware or software?

Jun 16, 2008
1,177
12
38
Tinley Park, IL
#1
Every once in a while, my Accelerometer goes whack, where all of accelerometer based programs all rotate to landscape and I can't get it to go any other way.... until a hard reset that is. I can't successfuly repeat the issue on que, so that make me wonder if it's not a software thing, i.e. not one specific issue is causing the glitch. But if it is hardware, wouldn't it be doing it all the time, or at the same time interval from the reset, which its not.

I really hate to have to return this one too, since its my replacement. Not to mention since its so random, with my luck, it wouldn't act up for my genius appointment.

Any thoughts, ideas? I do plug the phone into an Apple 3G dock at home, a macextreme USB charger at work and a "direct into my stereo" charging plug that I get the "this accessory will not charge" and "not made for iPhone" warnings on the phone when I plug it into my car, if that might have something to do with it.

I'm actually starting to wish that I had stuck with my v1.....
 

miggs1310

Member
Bronze
Jul 29, 2008
426
0
16
#2
you don't have to have a genius appointment to do an exchange. i exchanged mine for cosmetic reasons and was in and out in around 10 minutes, no questions asked. meanwhile there was a line of people waiting for their genius appointments...
 

subzerohf

New Member
Aug 14, 2008
3
0
1
#3
This is happening to me, too! And we are not alone; other iPhone owners have similar accelerometer problem, if you check in the Apple Discussion forum. No definitive answer from anyone; no cure either :(
 
Jun 16, 2008
1,177
12
38
Tinley Park, IL
#4
This is happening to me, too! And we are not alone; other iPhone owners have similar accelerometer problem, if you check in the Apple Discussion forum. No definitive answer from anyone; no cure either :(
yeah, I saw that thread and you're right, there were no good answers. I figure I'd post here since not much has been discussed. I really hate to go for #3, but who knows...
 

Ace4261991

New Member
Silver
Jun 18, 2007
530
0
0
#5
happens to me too id say just wait it out im sure theyll fix it in an update
 

iChristian

New Member
Bronze
May 28, 2008
315
0
0
#6
either you have a defective phone, its due to accidental damage, or you just might have to restore the phone and see if that works. if that doesn't work, go to Apple with a genius appointment and tell them your story and i'll bet they'd be glad to replace it for you. hope this helps.
 
Jun 16, 2008
1,177
12
38
Tinley Park, IL
#7
I'm thinkingits hardware, I've done 5 restores in different combos (set as new, back up restore and what not) and it still does it. Got an appointment for tomorrow to get it replaced. I hope the phone screws up again before 4pm!
 
Jun 16, 2008
1,177
12
38
Tinley Park, IL
#8
Update.

Well, as fate would have it, it appears that my 5TH restore solved the problem.... at least for now.

I went to my Apple appointment and of course the phone wasn't acting up. On top of that, the Apple genius told me that since I've done restores, my diagnosis history would be gone from the phone. I then say, what? He says that if I would have not restored my phone, the malfunction would have shown up in the diagnosis history. So then I ask why would the Apple care people tell me to do a restore and the genius said, "well, its the easiest way for them to fix an issue over the phone." The genius then adds that for the iPhone only, they'll take walk ins if your phone is currently having the issue.

So short story long, if your phone is acting up after the first restore, you're close to a Apple store AND you have the time, DO NOT RESTORE YOUR PHONE AGAIN! Take it in so they can see the issue first hand.
 

iChristian

New Member
Bronze
May 28, 2008
315
0
0
#9
So how does your phone work now? Everything back to normal?
 
Jun 16, 2008
1,177
12
38
Tinley Park, IL
#10
So how does your phone work now? Everything back to normal?
for the most part it's fine. once in a while, while in safari, the opaque volume adjustment screen pops up even though I didn't touch the volume and I got a "unable to connect to visual voice mail" pop up while I was listening to a visual voice mail (it did not affect the voice mail in any way) once, but thats been it. Everything else has been fine. SO, I'm not too upset that it didn't get replaced, because I just want a working phone regardless of which phone it is.
 
Jul 16, 2008
1,592
1
38
Colorado
#11
I think it's really a software problem and not hardware. Although not the same issue, I also had accelerator issues but they were solved with 2.0.1. I've not had to restore my phone once. I dealt with the accelerator issues and once I installed the update they went away. If 2.0.1 actually fixed something I'm convinced the next real upgrade might walk on water. I think software is largely responsible for most (not all) of issues people are having with the new phone.
 
Jun 16, 2008
1,177
12
38
Tinley Park, IL
#12
i'm leaning towards your way of thinking now. I'm still going to give it a few days before I declare sucsuess though. If it does work, it's just odd that it took the 5th restore for the issue to go away. Oh well, ignorance is bliss I guess here.
 
Jun 16, 2008
1,177
12
38
Tinley Park, IL
#13
I'm staring to hate this phone.

so as fate would have it, it did it again at 9pm. So I was actually happy because I was going to go and get it fixed in the morning. I don't even reset the phone so it will be nice and stuck for the morning and yeah..... for the first time ever, it appearently unstuck it self when I checked on it minutes later. It's never done that before, always just stayed froze until a reset.

Urgh, well I'm still going to stop in tomorrow and see if they'll at least scan it to see if the issue was stored in the diagnosis history or what ever the Apple guy called it. Urgh.
 
Jul 16, 2008
1,592
1
38
Colorado
#14
so as fate would have it, it did it again at 9pm. So I was actually happy because I was going to go and get it fixed in the morning. I don't even reset the phone so it will be nice and stuck for the morning and yeah..... for the first time ever, it appearently unstuck it self when I checked on it minutes later. It's never done that before, always just stayed froze until a reset.

Urgh, well I'm still going to stop in tomorrow and see if they'll at least scan it to see if the issue was stored in the diagnosis history or what ever the Apple guy called it. Urgh.
Hopefully they can sort it out with info from the error files. Keep us posted. I really think my issue was software related but not so sure about yours now. I'd bet you walk out with another phone today.
 

iChristian

New Member
Bronze
May 28, 2008
315
0
0
#15
This whole situation seems very annoying to say the least. They should just replace the phone or give you more assistance.
 

unitas

Member
Bronze
Jul 16, 2007
64
0
6
#16
I've had the same Accelerometer problems with safari and landscape mode. I had to hit the home button to exit out. I've also had the volume icon pop up for no reason.

I have two more issue that may be normal I'm not sure: When I turn my brightness all the way down the screen flickers slightly. Also, when I'm not looking at the iPhone directly, the screen has a blueish tint or a negative affect. It reminds me of looking at low quality lcd tvs from the side.

Hope that makes sense, does anyone have the same issue? I'm thinking about bringing this one back to the Apple Store.
 
Jun 16, 2008
1,177
12
38
Tinley Park, IL
#17
I've had the same Accelerometer problems with safari and landscape mode. I had to hit the home button to exit out. I've also had the volume icon pop up for no reason.

I have two more issue that may be normal I'm not sure: When I turn my brightness all the way down the screen flickers slightly. Also, when I'm not looking at the iPhone directly, the screen has a blueish tint or a negative affect. It reminds me of looking at low quality lcd tvs from the side.

Hope that makes sense, does anyone have the same issue? I'm thinking about bringing this one back to the Apple Store.
I haven't had the brightness issue, but then again I haven't turned it all the way down yet. Is your phone new out of a retail box or a replacement?
 

iChristian

New Member
Bronze
May 28, 2008
315
0
0
#18
Replacements can sometimes be a blessing and sometimes be a curse. =/
 
Jun 16, 2008
1,177
12
38
Tinley Park, IL
#20
Replaced the phone.... again....

I finally was able to get the phone to act up and brought it in. Well they did a hard reset and said "all fixed!", so I said "No its not!" and explained that the hard reset was only a temporary fix. They said that usually anything fixable through a hard reset is not eligible for warranty repair, but they were going to help me out, out of "good faith". So now, I'm officially on phone #3....

And of course I had to buy new crystal covers cause they never go on right the second time and yeah, both the new ones I bought got screwed up... I did leave the last one on, but I have a bunch of dust under it that is annoying as hell, so I guess its off to the Apple store later this week to spend another 15 bucks.... and yes, I did try the shower on in the bathroom thing and no dice.