Accessing Wi-Fi hat has Splash Screen log-on

Lysimakus

New Member
Jul 10, 2007
8
0
0
#1
I can't access many of the hotel free wifi points because they have a splash screen that requires acceptance of the "Public" nature or a fair use disclaimer PRIOR to letting you access the server. This is not problem with a laptop, but the Wi-Fi access of the iPhone simply returns a "Cannot access" message. How do you get past this block to free internet access. :oops:
 
Jul 15, 2007
20
0
0
#2
I can't access many of the hotel free wifi points because they have a splash screen that requires acceptance of the "Public" nature or a fair use disclaimer PRIOR to letting you access the server. This is not problem with a laptop, but the Wi-Fi access of the iPhone simply returns a "Cannot access" message. How do you get past this block to free internet access. :oops:
had the same problem at coffee shops. apparently the routers are not set up to automatically authenticate the iPhone's request for network connection. i called caribou and they manually authenticated it. i think this means that we have to call tech support everytime there is a new network to get it working
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#3
I ran into that problem today at a local video/book/music store (Hastings). But what I found was that that darned DNS issue was causing me to not see the final login page (in Hastings case it's just an agreement to terms page).

Once I fixed the DNS issue I was fine. And just like at hotels and hotspots, after I connected via a browser (captured port 80) I was able to check email and other Web-related stuff without issue.


But in your case, monstermonkey, it doesn't seem like you had to do anything DNS wise. Do those coffee shops capture port 80 to force a browser-based authentication?


--
Mike
 
Jul 15, 2007
20
0
0
#4
I ran into that problem today at a local video/book/music store (Hastings). But what I found was that that darned DNS issue was causing me to not see the final login page (in Hastings case it's just an agreement to terms page).

Once I fixed the DNS issue I was fine. And just like at hotels and hotspots, after I connected via a browser (captured port 80) I was able to check email and other Web-related stuff without issue.


But in your case, monstermonkey, it doesn't seem like you had to do anything DNS wise. Do those coffee shops capture port 80 to force a browser-based authentication?


--
Mike
i did not do anything to the DNS. because i have no idea what that is or how to do it. teach me? if i go to a new wifi spot with a web-browser based authentication, i see a blank page on safari. at that point, i have hit the end of the tunnel of my knowledge about networks
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#5
i did not do anything to the DNS. because i have no idea what that is or how to do it. teach me? if i go to a new wifi spot with a web-browser based authentication, i see a blank page on safari. at that point, i have hit the end of the tunnel of my knowledge about networks
Hmmm if you didn't do anything, it probably wasn't DNS related.

DNS is what converts friendly URL names (like Google.com) into the numeric IP addresses that the Internet uses (e.g., 64.233.187.99 for Google.com).

To get from Google.com to 64.233.187.99 a DNS server is needed, kind of like looking up someone's phone number using their name with a phone book. This DNS server is accessed by its IP address, and this address is normally provided by the router you connect to (via DHCP). In the case of typical home or small office WiFi routers the router uses its own IP address as the DNS address (internally it forwards those requests to a "real" DNS server with a public IP address).

For some reason the iPhone doesn't like some routers using their own IPs as DNS IPs. The fix is to supply your own DNS IP addresses to the WiFi connection (either your ISP's, or one of many publicly available DNS server IPs).

But again, since you didn't have to do anything on your iPhone to correct the problem I suspect it wasn't a DNS issue.

And I really was hoping it was: DNS is easily fixed right on the iPhone. But if it's something else it might be harder to fix.

I'm going to test this again with another browser-authenticated WiFi network as soon as I get the chance.



--
Mike
 
Jul 15, 2007
20
0
0
#6
Hmmm if you didn't do anything, it probably wasn't DNS related.

DNS is what converts friendly URL names (like Google.com) into the numeric IP addresses that the Internet uses (e.g., 64.233.187.99 for Google.com).

To get from Google.com to 64.233.187.99 a DNS server is needed, kind of like looking up someone's phone number using their name with a phone book. This DNS server is accessed by its IP address, and this address is normally provided by the router you connect to (via DHCP). In the case of typical home or small office WiFi routers the router uses its own IP address as the DNS address (internally it forwards those requests to a "real" DNS server with a public IP address).

For some reason the iPhone doesn't like some routers using their own IPs as DNS IPs. The fix is to supply your own DNS IP addresses to the WiFi connection (either your ISP's, or one of many publicly available DNS server IPs).

But again, since you didn't have to do anything on your iPhone to correct the problem I suspect it wasn't a DNS issue.

And I really was hoping it was: DNS is easily fixed right on the iPhone. But if it's something else it might be harder to fix.

I'm going to test this again with another browser-authenticated WiFi network as soon as I get the chance.



--
Mike

thanks tinman. that was helpful. i didn't do anything to the DNS. but it seems like its a good trick to know. can you show me how to do that?

by the way - i tried to reply to this post on the iPhone and ran into a weird problem. i was in the reply text box in which i had quoted your reply. your reply was bigger than the text box. but there was no scroll bar. so i could not scroll down to the end of the quote within the text box in the iPhone. what gives? so now i am on the mac to reply :(

its also neat how some folks are able to put their iPhone signature within text boxes.
 

Lysimakus

New Member
Jul 10, 2007
8
0
0
#7
Accessing Wi-Fi Free Spots with iPhone

It is not DNS related. Normally the SSID option in WIndows will let you open the advanced tab and you can specify the log-in characteristics. iPhone has no such option. It relys on an auto connect without user input. Many of the free spots put up a splash screen (local IP) advising you of the "public" nature of the access point before connecting you to their router. Some of the hotel systems use a non-transmitting WAP that require you to enter the SSID, and then you can access the splash screen with your browser and complete the log-in which connects you to their router. In both of these cases, the iPhone has no facility to connect through that I have been able to find. Of course, my background is almost entirely Windows based although I have a G4 that I use just for experimenting with networking. I just don't have enough experience with the internals of Apple's networking to know if there is a way that I am missing. :p

I'm sure the October release of Leopard will fix this and provide for some sort of file explorer and hopefully fix the syncing problem with MS Office 2003.
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#8
It is not DNS related.
In my case it was, as overriding DNS allowed the hotspot to work. This was repeatable.


Normally the SSID option in WIndows will let you open the advanced tab and you can specify the log-in characteristics. iPhone has no such option.
I've never had to specify another login option for any hotspot I've come across when using Windows. What, precisely, were you referring to when you wrote "SSID option in Windows?"


It relys on an auto connect without user input. Many of the free spots put up a splash screen (local IP) advising you of the "public" nature of the access point before connecting you to their router.
Yes, that is a captive portal and they are of course quite common.

Some of the hotel systems use a non-transmitting WAP that require you to enter the SSID, and then you can access the splash screen with your browser and complete the log-in which connects you to their router.
Are your referring to an AP not broadcasting its SSID? (A complete waste of time from a security standpoint, IMO.)

In both of these cases, the iPhone has no facility to connect through that I have been able to find.
I guess I am not following you. But there are several common techniques for implementing captive portals, one of which is the redirection of DNS:

"Redirection by DNS

When a client requests a website, DNS is queried by the browser. The firewall will make sure that only the DNS provided by DHCP can be used by unauthenticated clients (or, alternatively, it will forward all DNS requests by unauthenticated clients to that DNS server). This DNS server will return the IP address of the Captive Portal as a result of all DNS lookups.

Some naive implementations don't block outgoing DNS requests by unauthenticated clients. Instead, the DHCP server uses as a DNS server a server that returns the IP address of the Captive Portal to unauthenticated clients. These implementations are very easy to bypass: a user simply needs to configure his computer to use an external DNS. This is why it is important to implement a firewall that ensures no inside clients can specify or use an outside DNS server."

http://en.wikipedia.org/wiki/Captive_portal


--
Mike
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#9
thanks tinman. that was helpful. i didn't do anything to the DNS. but it seems like its a good trick to know. can you show me how to do that?
OK, but don't bother with this unless you have a problem! (And if you mess something up be sure to "Forget" that WiFi network.)

If you have connected to a WiFi network but cannot surf via Safari try this:

1.) From the main screen go to Settings, and from Settings go to Wi-Fi.

2.) The Wi-Fi network you are currently connected to will have a blue check next to it, over on the left. For that same WiFi network, tap the blue circle (with ">" inside) to get to more options.

3.) Look at both the Router and DNS IP addresses. If they are the same, you might have a DNS issue, and continue on to step 4. If they are not the same you probably don't have a DNS issue, so only continue on if you have no other options.

4.) Tap inside the DNS field, and the cursor will be positioned at the end. Delete everything there. Enter the following instead:
208.67.222.222, 208.67.220.220

5.) Tap Wi-Fi Networks to go back to exit that screen.

6.) Press the Menu button to go back to the main screen and try Safari again.

by the way - i tried to reply to this post on the iPhone and ran into a weird problem. i was in the reply text box in which i had quoted your reply. your reply was bigger than the text box. but there was no scroll bar. so i could not scroll down to the end of the quote within the text box in the iPhone. what gives?
You should be able to get around that. I find it easier to do in portrait orientation (change orientations before bring up the keyboard). You can also scroll inside that box but it can be tricky. If all else fails you can tap and hold to get the magnifying glass, and then just drag down till you see what you want to see (might take awhile).



--
Mike
 

Lysimakus

New Member
Jul 10, 2007
8
0
0
#10
DNS Redirestion

I've never had to specify another login option for any hotspot I've come across when using Windows. What, precisely, were you referring to when you wrote "SSID option in Windows?"

The wireless window gives a lot of options. I also use a utility program from Netgear that "sniffs" WAP's and provides many options of configuring the WAP for connect. Normally in Windows all of this handled automatically, but apparently not with the iPhone. For the vast majority of iPhone users, they have no idea of what an IP is much less the DNS and DHCP.

Are your referring to an AP not broadcasting its SSID? (A complete waste of time from a security standpoint, IMO.)

I guess I am not following you. But there are several common techniques for implementing captive portals, one of which is the redirection of DNS:

"Redirection by DNS

I understand exactly how this works, and therein lies the problem with the iPhone. The DNS redirecton is read by the iPhone as a connect failure and it simply returns the "Can't connect" message.

Sometimes, I can enter the IP of a DNS server and the captive port will allow me through, but in most hotel systems (iBahn and STSN), it will not connect.

I think Apple needs to clean up this WAP log-on and make it more user friendly like the auto features in Windows that automatically bring up the browser window with the captive log-on screen.

Jon
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#11
I've never had to specify another login option for any hotspot I've come across when using Windows. What, precisely, were you referring to when you wrote "SSID option in Windows?"

The wireless window gives a lot of options.
What options? I asked for specifics. For that matter, define "wireless window" (XP or Vista, etc.).


I also use a utility program from Netgear that "sniffs" WAP's and provides many options of configuring the WAP for connect.
Again I don't follow you... How does configuring an AP have anything to do with a client device? It sounds like you are using WAP to mean the client device. WAP to me means Wireless Access Point.


I understand exactly how this works, and therein lies the problem with the iPhone. The DNS redirecton is read by the iPhone as a connect failure and it simply returns the "Can't connect" message.

Sometimes, I can enter the IP of a DNS server and the captive port will allow me through, but in most hotel systems (iBahn and STSN), it will not connect.
You wrote earlier that it wasn't a DNS issue though. And as I noted, I did have success by overriding DNS in the one instance where I had a problem.


I think Apple needs to clean up this WAP log-on and make it more user friendly like the auto features in Windows that automatically bring up the browser window with the captive log-on screen.
I travel a lot on businesss, use XP and Vista (and VMs), and never have had a browser window open automatically (nor would I want it to). When I open a browser window, that is when the redirect occurs.

And I should note it was only one hotspot where I had a problem (fixed by overriding DNS). The rest redirected Safari, as I would expect.

I would imagine this site, and all iPhone sites, would be overrun with WiFi complaints if they didn't work at captive portal hotspots.


BTW: If you reply with quotes, please use the quote feature. Makes it much easier to follow. Thx.



--
Mike
 

Lysimakus

New Member
Jul 10, 2007
8
0
0
#12
WiFi Connect Problem

What options? I asked for specifics. For that matter, define "wireless window" (XP or Vista, etc.).

The wireless window I use is a Netgear utility I use.

Again I don't follow you... How does configuring an AP have anything to do with a client device? It sounds like you are using WAP to mean the client device. WAP to me means Wireless Access Point.

yes, worded incorrectly. I meant configuring the device to the WAP.


You wrote earlier that it wasn't a DNS issue though. And as I noted, I did have success by overriding DNS in the one instance where I had a problem.

Changing the DNS doesn't work here. I've been traveling for three weeks now and I have been unable to connect to the iBahn and STSN networks with the iPhone. I connect with the laptop and using Ipconfig/all I can obtain all the WAP's parameters but manually entering them still won't connect, even using ISP or public DNS addresses. With some of other public hotspots, the iPhone shows a connect but Safari can't access any site, either by direct IP or site name. This is not true for all sites, many do connect, but about half don't and it seems they are the ones with the immediate re-direct.


I travel a lot on businesss, use XP and Vista (and VMs), and never have had a browser window open automatically (nor would I want it to). When I open a browser window, that is when the redirect occurs.

Yes, again that's what I meant.

And I should note it was only one hotspot where I had a problem (fixed by overriding DNS). The rest redirected Safari, as I would expect.

I would imagine this site, and all iPhone sites, would be overrun with WiFi complaints if they didn't work at captive portal hotspots.

There does seem to be a lot of chatter about this. With the iPhone being so new, many are struggling with just connecting it to their home network. I had no problem connecting at home and was pleased to see that Apple included WPA2. My Ibook didn't have WPA2.

BTW: If you reply with quotes, please use the quote feature. Makes it much easier to follow. Thx.

I don't know why, but the "quote feature doesn't work for me. I'm using Firefox, so I've highlighted my response. And thanks Mike for your expert advice. Sounds like you've gotten farther than I have with my iPhone. I too travel extensively, both here and in Europe and Asia and have never had any trouble with the laptop. This iPhone is a different breed of cat from what I'm accustomed to.

--
Mike
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#13
I don't know why, but the "quote feature doesn't work for me. I'm using Firefox, so I've highlighted my response. And thanks Mike for your expert advice. Sounds like you've gotten farther than I have with my iPhone.
No, thank you for starting this thread. It's obvious by your experiences that the iPhone does have issues with certain WiFi authentication systems out there--so if and when I do run into one I won't think I'm nuts if I can't get it to work. Hopefully this can be corrected quickly though, assuming it's really the iPhone at fault (as compared to the Duke incident).

BTW: I often quote manually using [ quote ] text I want to quote [/ quote ] (without the spaces of course).


--
Mike
 

jeepshots

Member
Bronze
Jul 10, 2007
68
0
6
#14
Well guys, this has been a interesting read. I'll have to file away the DNS trick (gotta type it up in a note). However, I have experienced the issue being discussed. I was at the hospital yesterday evening, and they have a guest wi-fi. I connected to it just fine, but couldn't get out the door, as it did a redirect. I never got an authentication/acceptance screen on Safari, just a timeout. If I go back, I'll try the DNS thing. But the original issue does happen.
 

Lysimakus

New Member
Jul 10, 2007
8
0
0
#15
Latest Software Update fixes this problem

Just a note that the latest iPhone software update seems to have fixed this problem. Just returned from another trip and the hotel Wi-Fi enabled the splash screens for sign-ons. Same hotels where it didn't work before.
 

z3r0c001

New Member
Oct 9, 2007
2
0
0
Los Angeles, CA
#16
I've been a victim of this fault too. I go to USC and they have something called netreg splash screen that pops up whenever you connect to USC Wireless network, my laptop (MacBook Pro, running Max OS X 10.4.10) has no problem with that but my iPhone and my friend's iPod Touch hangs with the network. I tried using DNS override and it worked for iPhone but did not work for iPod touch, so its still a puzzle for me.

thanks
z3r0

update : now it works with iPod touch too
 

Joejoejoe

New Member
Oct 14, 2007
2
0
0
#17
I've been a victim of this fault too. I go to USC and they have something called netreg splash screen that pops up whenever you connect to USC Wireless network, my laptop (MacBook Pro, running Max OS X 10.4.10) has no problem with that but my iPhone and my friend's iPod Touch hangs with the network. I tried using DNS override and it worked for iPhone but did not work for iPod touch, so its still a puzzle for me.

thanks
z3r0
I need to access USC wireless with my iPhone too...

How do I do a DNS override?
 

z3r0c001

New Member
Oct 9, 2007
2
0
0
Los Angeles, CA
#18
How to over ride settings

Once you connect to USC Wireless, navigate to Settings --> Wi-Fi

now there is USC Wireless with a little arrow on right hand side, so just click that and it will take you to settings page, and there is DNS option, so just click that, delete whatever is there and replace it with,

208.67.222.222, 208.67.220.220

including comma, and you are done....

lemme know if it works for you or not..

z3r0