AirDrop glitch...

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

jmp316

Evangelist
Gold
Jul 10, 2008
1,048
141
63
#1
So my wife and I both have the iPhone 5, recently updated to iOS 7. As we were out today I decided to test the AirDrop feature by sending her a picture. When I attempt to AirDrop it to her, surprisingly, my name and picture comes up as HER phone. Assuming a glitch, I messed around with some contact info., resets, etc., but could not fix this.

Yes, we do share an Apple ID, but I just assumed that this wouldn't matter because they are two separate devices. Reading some on the Apple discussion forums, many others are in my same situation.

I know it's not the biggest concern in the world, but it's driving me nuts! I want to know which device I'm sending something to!

I'm hoping for a fix soon. Anyone else notice this?
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,201
143
63
#2
I tried this last night with my wife. My wife's phone (my old iPhone 5) showed up as me in my choices, and my new iPhone 5s shows up as my daughter when she received the pic.
 

radtechy

Contributor
Bronze
Jul 20, 2011
496
41
28
#3
I tried this last night with my wife. My wife's phone (my old iPhone 5) showed up as me in my choices, and my new iPhone 5s shows up as my daughter when she received the pic.
I had the same problem. I haven't got around to it but I think you go to iCloud and under my info out you're pic on it maybe it will show it right. Just a thought


Sent from my iPhone 5 using Tapatalk
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,201
143
63
#5
But do the right names show? I can send things to my wife's phone, but it shows I'm sending it to myself and she shows she is receiving from my daughter.
 

radtechy

Contributor
Bronze
Jul 20, 2011
496
41
28
#6
The names are right. The pictures in the bubbles were wrong. I did a similar thing like you. My wife got my 5 and u for a 5S which seems like what you did.

Now my pictures for the contact bubbles are correct now


Sent from my iPhone 5 using Tapatalk
 

Docd

Contributor
Silver
Oct 16, 2011
650
66
28
#7
I'm having a different problem. I can only see people when they have set their airdrop to everyone, but they see me just fine it doesn't matter if I'm set to contacts only or everyone, they must be set to everyone to see them. Yes they are in my contacts, it's my wife and kids.


Sent from my iPhone using Tapatalk -
 
Last edited by a moderator:
Oct 28, 2013
1
0
1
#8
I'm in the same boat, airdrop shows my iPhone as my wife's. I called Apple they said its a contact issue but had no real solutions yet.
 
Nov 27, 2013
9
0
1
#9
Hi I'm having some airplay problems as well! Since latest ios7 update I have no icon that indicates airplay is available - on bbc iplayer or YouTube ? This is the same on iPad or my ipod touch5. I'm about to reset my atv since reading this thread. If it works I'll keep you all posted
Many thanks
Brian


Sent using iCafe app
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,505
113
Utah
#10
Hi I'm having some airplay problems as well! Since latest ios7 update I have no icon that indicates airplay is available - on bbc iplayer or YouTube ? This is the same on iPad or my ipod touch5. I'm about to reset my atv since reading this thread. If it works I'll keep you all posted
Many thanks
Brian
Did you drop off of WiFi? The icon disappears when you're on cellular.

If you are on WiFi and it's still not showing up, try a hard reset. Press the home and power buttons at the same time and let go of both when you see the Apple logo.
 
Nov 27, 2013
9
0
1
#11
Hi Europa, many thanks for the ideas. Have already tried hard reset and the same for the Apple TV - no joy. iPad and iPod touch both have latest updates, not sure that is a good thing! I am successfuly streaming spotify premium to an old iPod touch docked to my hi fi system from my Apple iMac. I use a third party software to do this- airfoil.
Any other ideas?
Brian


Sent using iCafe app
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,505
113
Utah
#12
So it's just those two apps? Try deleting and reinstalling BBC Player and YouTube. If that doesn't work, try an alternate YouTube app. I use Jasmine. It's a lot better than the default YouTube app, in my opinion.
 
Nov 27, 2013
9
0
1
#14
Oops just woken up - I noticed for the first yor topic title is air drop NOT airplay! This could possibly be why you cannot help me - I think I maybe beyond help! Just in case someone can - it's the airplay icon that has disappeared? Many thanks for trying!
Brian


Sent using iCafe app
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,505
113
Utah
#15
Oops just woken up - I noticed for the first yor topic title is air drop NOT airplay! This could possibly be why you cannot help me - I think I maybe beyond help! Just in case someone can - it's the airplay icon that has disappeared? Many thanks for trying!
Brian
I knew you were talking about AirPlay. Did you try reinstalling those two apps?
 
Nov 27, 2013
9
0
1
#16
Yes! No joy. Watched bbc iplayer and YouTube last night and no sign of the airplay icon. I'm impressed with your mind reading capabilities! How many Apple devices am I holding up?
Brian


Sent using iCafe app
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,505
113
Utah
#17
Uninstall YouTube and check if AirPlay works from the mobile YouTube website. If so, I'd just use that or one of the alternate YouTube apps.
 

Mthoroughbred

Zealot
Silver
Dec 16, 2008
740
100
43
#18
My problem with airdrop is that it's slow to show the person that available for airdrop. Sometimes it won't even show the person at all. I just wish it was a little faster establishing the connection.
 

Napoleon PhoneApart

Moderator
Senior Moderator
Jun 19, 2007
33,438
4,531
113
Upper Marlboro, MD
#19
My problem with airdrop is that it's slow to show the person that available for airdrop. Sometimes it won't even show the person at all. I just wish it was a little faster establishing the connection.
I noticed the same thing when I visited Mindi this last time. It's too slow to establish the connection most of the time.