Alarm problem with DST

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
42
Philly
It's a bug that doesn't seem to affect everyone for whatever reason. Deleting and reinstating your alarms should fix it.
 

greasemuntney

Member
Bronze
Apr 4, 2010
103
2
18
Alabama
To fix your alarm.
Remove all alarms and then reboot your phone. (Shut down and then turn back on). Then reset your alarm to the time you want. The next time it will go off at the correct time. I have done this from the first time and all works.
 

iBanana

Member
Silver
Jan 15, 2010
713
4
18
United States
My phones time was all funny this morning. I woke up at 6:15 ( or so I thought ) got in the shower and when I got out my work phone said it was 8. I looked at my iPhone and it said 7. I restarted both to find that it was in fact 8. Alarm for 7:30 never went off. I'll have to reset my alarms for tomorrow.
 

partizan

Member
Bronze
Feb 25, 2008
302
3
18
Milton, Ontario
My phones time was all funny this morning. I woke up at 6:15 ( or so I thought ) got in the shower and when I got out my work phone said it was 8. I looked at my iPhone and it said 7. I restarted both to find that it was in fact 8. Alarm for 7:30 never went off. I'll have to reset my alarms for tomorrow.
Had the same weird issues myself.
 

Ltzguy

Zealot
Gold
Jun 22, 2010
1,331
96
48
Right here
I can't get mine to work correctly. I have hard reset my phone, cut it off and cut it back on, turned airplane mode on/off. I have deleted all my alarms and tested several times. If I set on repeat, it won't work. If I set repeat on never, it works. This morning it woke me up an hour early. Any ideas?
 

(L)

Contributor
Bronze
Nov 7, 2010
277
28
28
Arizona
My phones time was all funny this morning. I woke up at 6:15 ( or so I thought ) got in the shower and when I got out my work phone said it was 8. I looked at my iPhone and it said 7. I restarted both to find that it was in fact 8. Alarm for 7:30 never went off. I'll have to reset my alarms for tomorrow.
Same thing happened to me Sunday. I set my alarm but it never went off. I woke up the clock said 8:30 so I thought I was late for work when I got to work all my clocks and computers at work said 7:55. So I was actually early to work rather than late.


Sent from my iPhone 4 using iCafe app
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
42
Philly
I can't get mine to work correctly. I have hard reset my phone, cut it off and cut it back on, turned airplane mode on/off. I have deleted all my alarms and tested several times. If I set on repeat, it won't work. If I set repeat on never, it works. This morning it woke me up an hour early. Any ideas?
I think the order of operations is important. Did you do it like this?:

1. Delete all alarms
2. Reboot the device normally
3. Hard reboot the device just to be safe
4. Recreate your alarm
 

Appleboy

Member
Bronze
Jan 24, 2011
151
1
18
I had my alarm set to 0700, alarm went off at 6, was in AZ time so no adjustment to daylight savings.. Weird
 

nealh

Contributor
Silver
Apr 3, 2008
699
25
28
I think the order of operations is important. Did you do it like this?:

1. Delete all alarms
2. Reboot the device normally
3. Hard reboot the device just to be safe
4. Recreate your alarm
I just did this and set the alarm to repaeat on Tuesday at 7:05am(I set it 20 min ago)..the alarm simply did not go off. Very odd bug. I am still on fw 4.1
 

(L)

Contributor
Bronze
Nov 7, 2010
277
28
28
Arizona
I had my alarm set to 0700, alarm went off at 6, was in AZ time so no adjustment to daylight savings.. Weird
Same here. Az shouldn't change times at all but my phone switch times on it's own


Sent from my iPhone 4 using iCafe app
 

nealh

Contributor
Silver
Apr 3, 2008
699
25
28
There's your problem. You need to update. There's really no reason to be on 4.1 any more these days.
I have no reason to upgrade and 4.1 worked after the last DST. Not sure why it wont now? Very odd. I am very happy at 4.1 jb(no advantage to 4.2.1 for me and I will wait and see on 4.3)
 

partizan

Member
Bronze
Feb 25, 2008
302
3
18
Milton, Ontario
I think the order of operations is important. Did you do it like this?:

1. Delete all alarms
2. Reboot the device normally
3. Hard reboot the device just to be safe
4. Recreate your alarm
In addition to what Dave said, go into Setting>General>Date&Time>Set Automatically set the switch to OFF. Seems to work for me.