Alpine IDA-X001 works with iPhone 1.0.1?

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

2JZ GZE

New Member
Aug 13, 2007
9
0
0
#2
Yes, using the full speed iPod connection cable. I believe its kce-422i.

Mine works just fine, although you cannot view album art, which is a total bummer! (I called Alpine and they said that the artwork should show, but it doesn't)

Julian
 

SCMedic

New Member
Bronze
Jul 7, 2007
95
0
0
#3
Yes, using the full speed iPod connection cable. I believe its kce-422i.

Mine works just fine, although you cannot view album art, which is a total bummer! (I called Alpine and they said that the artwork should show, but it doesn't)

Julian
Mine worked with the X001 since day one.. Hell, it even rings through the speakers...
 

tasslehawf

New Member
Bronze
Jun 21, 2007
32
0
0
Los Angeles, CA
#5
Here we go. ZD Net tried it and it didn't work:
http://blogs.zdnet.com/Apple/?p=676

The iDA-X001’s has unmatched iPod friendliness. It has controls that act just like your iPod from the front panel of the head unit. Menus are navigable like the iPod, it has search options are like the iPod and you can even view album art as you would on the iPod.
Unfortunately, as you can see from the photos, it isn’t compatible with iPhone, throwing the standard “This accessory is not made to work with iPhone” dialog box. The second photo (below) is from the iDA-X001’s display.[it says 'iPod Error']

Also this one:

I went to replace my 3 yr old alpine headunit, the face does not always work when it opens. So anyway, I went to a local high end electronics store (ABT) and the salesperson was nice enough to try my iPhone with the newer iDA-X001...it was a definate NO GO. there were errors on both the iPhone, and the head unit... good news is, the bluetooth add on worked flawlessly. so for me, I will leave my 80 gig ipod in the glovebox, and let the iPhone work just as a phone
http://forums.macrumors.com/archive/index.php/t-326472.html
 
Last edited by a moderator:

tasslehawf

New Member
Bronze
Jun 21, 2007
32
0
0
Los Angeles, CA
#6
Just found this one:

http://www.iluvtechnology.com/blog/

Apple released a firmware update for the iPhone earlier this week. Walt Mossberg had reported that the update improved compatibility with many car adapters and other devices.
I plugged my iPhone into my Alpine iDA-X001 and unfortunately it still doesn’t work. I get the same iPhone error on the Alpine, and the same incompatibility error on the iPhone. I was hoping Apple and Alpine would be working closely to make sure future devices were compatible, including the current Nano, but that may not be the case.
I’ll keep trying though!
So who knows it may or may not work?
 

SCMedic

New Member
Bronze
Jul 7, 2007
95
0
0
#7
I actually got the iPhone incompatibility error, but the IDA still let me play m usic... No album art though...


Still works. Tried it today.
 

2JZ GZE

New Member
Aug 13, 2007
9
0
0
#8
yes its been working for me. When I plug it in with the KCE-422i iPod Cable, it states that I should enter into airplane mode so I will receive less interference. Other than that, it works fine.

Before I had the update and the KCE-422i Cable, I just had the ipod USB docking cable and the firmware that came with the phone when I got it. This did not let me use my iPhone with the ida-x001.

Julian
 

col3man

New Member
Aug 6, 2007
25
0
0
Ogunquit Maine
#10
Wait- I tried mine and it would not work either; I have the X001 and I got the same error- I got the "would you like to initiate airplane mode" error- Is the "high speed cable" the one which came with the head unit? or is it the "other" which plugs not into the USB but a serial-looking port? Lets get to the bottom of this.. if it works on some peoples, and not on others, it's got to be solvable?

Coleman.
 

2JZ GZE

New Member
Aug 13, 2007
9
0
0
#12
Wait- I tried mine and it would not work either; I have the X001 and I got the same error- I got the "would you like to initiate airplane mode" error- Is the "high speed cable" the one which came with the head unit? or is it the "other" which plugs not into the USB but a serial-looking port? Lets get to the bottom of this.. if it works on some peoples, and not on others, it's got to be solvable?

Coleman.
The High speed cable is a different cable from the one with the USB (the one that comes with the Stereo).

Go buy the full speed cable (kce-422i) and thank me later :cool: TRUST ME IT WILL WORK!
 

Redfor

New Member
Bronze
Jul 31, 2007
301
0
0
Fort Knox, KY area
#13
hmmmm

CDA-9883CD/MP3/WMA/AAC Receiver - iPhone Compatible!

Kinda funny... Before the patch I could control my iPhone through the head unit, but it only played through the iPhones speaker.
After the 1.01 patch I cant do a thing. The HU just says iPod and wont do anything. Just figured Id have to wait for another patch, But with the HU not being initially designed to work with a iPhone I really cant complain, still works great with my iPod.

Anyone else have a similar problem?
 

briancors

New Member
Aug 22, 2007
1
0
0
#14
ALPINE: "Airplane Mode Required" - No calls can be received?!?

Greetings, all!

I just got off of the phone with Alpine's tech support line, and they told me that indeed, with at least the 1.0.1 update to the iPhone that it should work with the IDA-X001. However, he stated that you need to place the iPhone into AIRPLANE MODE, to make it work.

I then asked, "So, does that mean you can't use it as a phone at all when you have it plugged in?"

He agreed with that question, and stated that the iPhone NEEDED to be in Airplane Mode when it's in use with the IDA-X001, via the sync port on the iPhone.

Can anyone confirm this statement? Because if I can't even RECEIVE calls when it's plugged into the IDA-X001 - I will more likely go with a standard head unit with an aux-in audio source on the back...

Many thanks,
-b
 

2JZ GZE

New Member
Aug 13, 2007
9
0
0
#15
it works fine without being in airplane mode. When phone calls come in, the music shuts itself off and you can hear the ringer on your car speaker. Remember people you need the FULL SPEED CABLE KCE-422i for this to work. If you haven't tried that cable and you are posting about how it doesn't work, go buy the cable! Remember it is not the cable that came with the unit!
 

TomTomTuning

New Member
Bronze
Aug 10, 2007
196
0
0
Camp Hill, PA
#16
I am looking to get a new headunit for my EVO but i wanted to go with a in dash receiver instead of a single din unit like the IDA-X001.

Any one know if the Alpine IVA-W205 will work with the iPhone

EDIT: Just checked the Alpine site and it say's it is. WOOT WOOT
 

Redfor

New Member
Bronze
Jul 31, 2007
301
0
0
Fort Knox, KY area
#17
... Just realized something the other day.. The reason i was having problems with my iPhone and my head unit.. UNLOCK YOUR PHONE.. heh.. You Have to unlock your phone before attaching it to the cable otherwise you cant do anything from the HU.
Just thought I'd throw this tinny tid bit of info in case there's another idiot like me out there..
:p