An iPhone 3G with 2.1, Downgrading to 1.x.x?