Another Gmail Question

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Alexander

Zealot
Gold
Jun 28, 2007
1,724
0
36
Atlanta
#1
When I set up my Gmail account, I was sent my 500 and some-odd number messages. In my Gmail account, these messages have been archived (I archive all my mail - not delete - as Gmail suggests). I then went into my settings and selected "download messages only from now on", and resetup my account - however I still receive 500 messages.

I would normally just delete the 500 from my phone but seeing as to how there is no BULK delete option, I do not want to delete these one-by-one! Any suggestions?
 

UnseenLlama

New Member
Bronze
Jun 20, 2007
171
0
0
Indianapolis, IN
#4
It might be the Ohio State syndrome...we never had this problem at Penn State... :) Just kidding.

The only other option I would have suggested was the Gmail setting for "only download from this point on". Was it already selected? Or did you select it again and save your settings?
 

Alexander

Zealot
Gold
Jun 28, 2007
1,724
0
36
Atlanta
#5
That's good in the sense it would only show 25, but theres 500 in my inbox I don't need, so on the home screen I'll never have an accurate count of how many e-mails I have to read. How does everyone else with a Gmail account handle this?
 

420greg

New Member
Silver
Jun 26, 2007
845
0
0
Orlando, Florida
#7
I was only getting things that were in my inbox. 50 at a time.

Every time I started to delete, it would just go back to 50.
I had 2150 items in my gmail inbox. All marked as red.

I shut the gmail account off in the iPhone.
I archived all 2150 items in my gmail inbox.
Turned the gmail account back on.

Now my iPhone inbox and gmail inbox match.

I think the iPhone gmail thing just syncs with the gmail inbox.

You could always activate pop3 on your gmail account, the set it up in the iPhone as a pop3 account and it will give the delete from server option in the account settings.

This way if you delete it from your iPhone it will remove it from your gmail inbox also.
 

Alexander

Zealot
Gold
Jun 28, 2007
1,724
0
36
Atlanta
#8
OSU is where it's at. Except maybe not so much this past year :)

It wasn't selected on the initial download. Then I found this option and selected it, but that obviously won't make the 500 disappear that are already on the phone. So i deleted my Gmail account on the phone and set it up again - but still the same 500!
 

UnseenLlama

New Member
Bronze
Jun 20, 2007
171
0
0
Indianapolis, IN
#9
OSU is where it's at. Except maybe not so much this past year :)

It wasn't selected on the initial download. Then I found this option and selected it, but that obviously won't make the 500 disappear that are already on the phone. So i deleted my Gmail account on the phone and set it up again - but still the same 500!
Yeah, that's strange. If you deleted and recreated the account, it shouldn't have downloaded the 500 messages.

Maybe:
1. Delete the account
2. Select the settings in your web based Gmail to only download from now on
3. Setup Gmail on the iPhone

Will that work?
 

Alexander

Zealot
Gold
Jun 28, 2007
1,724
0
36
Atlanta
#10
Tried what you suggested, no luck.

I now went in and have everything archived, and have ALL my mail marked as read, and have the POP set for mail received from now on.

557 is a completely random number too. Under all mail I have 1,391. I just can't figure this out.
 

420greg

New Member
Silver
Jun 26, 2007
845
0
0
Orlando, Florida
#11
I think I just figured this out.

I had a random number also. Like 387 or something. I have deleted down to about 240.

I went to my gmail setting on the web and I had POP3 Enabled. And it said Download all messages since 12.19.05 (the day I created my gmail account).

I think when you set up you gmail account using the gmail icon on the iPhone it setting it up POP3 on the iPhone.Tthe default setting in the web gmail setting is 'Enable POP for all mail (even mail that's already been downloaded)'

That is why it was trying to send me all 2150 of may emails. Even archived and read.

Since I changed the pop setting to 'new only' they have stopped flowing in to my iPhone.

Go check you gmail pop settings. See what it is set to.
 

Alexander

Zealot
Gold
Jun 28, 2007
1,724
0
36
Atlanta
#12
Yeah I've set mine to "new mail only". They have stopped flowing but I guess I'm going to have to manually delete the mail already on my iPhone. Is that what you are going to end up doing?
 

420greg

New Member
Silver
Jun 26, 2007
845
0
0
Orlando, Florida
#13
Yeah I've set mine to "new mail only". They have stopped flowing but I guess I'm going to have to manually delete the mail already on my iPhone. Is that what you are going to end up doing?
I have a link in my iPhone gmail inbox that says 'get me the next 25'

Once I cahnged the POP setting in gmail to 'new only' the get the next 2 stopped working. I was stuck with the little 242 or 242 unread message.

SO I changed the POP setting back until I get all these deleted from the iPhone then I will change it to new only and then I should be all set.
 

typer922

New Member
Bronze
Jun 7, 2007
86
0
0
#14
I did everything that has been mentioned. I don't get the old emails anymore but everytime I send an email, it sends it (the sent mail) to my iPhone. My CC option is turned off and I have the Recent Mode turned off too. Any suggestions?
 

Alexander

Zealot
Gold
Jun 28, 2007
1,724
0
36
Atlanta
#15
Got it. Finally just decided to "forward new mail only" and manually deleted 570 emails one-by-one haha. Oh well it didn't take near as long as I thought it would.
 

420greg

New Member
Silver
Jun 26, 2007
845
0
0
Orlando, Florida
#19
Gmail says this is a feature.

From their help:

Why does my 'Sent Mail' get downloaded to my POP inbox?

When you enable POP, all messages are downloaded to your client, except for Spam, Trash, and Chats. If you don't want messages that you send from the web interface downloaded to your mail client's inbox, we suggest creating a filter within your client.

So I guess we need to make a filter that 'skips the inbox' for from=me
 

propedderkustoms

New Member
Bronze
Jun 30, 2007
45
0
0
#20
Gmail says this is a feature.

From their help:

Why does my 'Sent Mail' get downloaded to my POP inbox?

When you enable POP, all messages are downloaded to your client, except for Spam, Trash, and Chats. If you don't want messages that you send from the web interface downloaded to your mail client's inbox, we suggest creating a filter within your client.

So I guess we need to make a filter that 'skips the inbox' for from=me
But how in the world can we do that on the iPhone with a Gmail account?