Anyone else going to ignore MuscleNerd's warning?

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#1
I'm downloading 6.0.2 right now. I'm really looking forward to an iPhone 5 jailbreak and I did see MuscleNerd's warning, but I think I'm going to update anyway. I just don't believe that a new jailbreak for new hardware will require outdated firmware. I think it's going to work on the lastest firmware and that it will likely even require that it's updated, just like Absinthe 2.o did. Once the jailbreak is out, I'll be happy to stay put since it almost certainly won't work on the subsequent update (at least not for a while).

Screen Shot 2012-12-18 at 8.10.42 PM.png
 

liberated

Genius
Gold
Jul 19, 2007
3,237
487
83
#7
I'm tired of these warning by the developers, either put up or shut up. He does not give updates other than "improve chances"? really? Give us an update on the progress instead of meaningless warnings! LOL:rolleyes:
 

Kadelic

Genius
Gold
Jan 4, 2010
4,935
1,645
113
Dallas, TX
#11
I can't remember which dev team member responded immediately to MuscleNerds tweet, but he countered that to date there hasn't been a JB released that didn't support the current version of iOS. So there's that. If I were on 6.x myself I would have updated.