App Store not installing apps

srose

New Member
Bronze
Jun 10, 2008
57
0
0
#1
Hi
Everytime I download an app through AppStore on my iPhone whether it is an app or an update I get an error saying it cannot be downloaded.

Here is an example:
http://img209.imageshack.us/img209/8602/img0002cc2.png

I have to go on my PC and download it by clicking on my account and it has 1 download waiting which would be the app I was trying to get on my phine.

Why is this happening?

Please help
Thanks
 

stapes

New Member
Bronze
Oct 3, 2007
38
0
0
#2
Same thing happens to me. Very frustrating! When Im on my mac and try download it like the error says....well it never works for me. I've always had to delete the app and re-install it. My other issue is that some of my apps that I've downloaded via my phone are not showing up in my iTunes apps. And yes I've done the "check for purchases".
 

showguy

Member
Silver
Dec 2, 2007
769
15
18
Long Island, NY
#3
I always download my apps or updates on my pc. Never had much luck doing it on the phone.
 

kenneth

Zealot
Gold
Aug 19, 2008
1,465
0
36
Texas
#4
it's noted several times to purchase and update apps via iTunes. Alot of people have had problems with there phones when trying to buy and update apps from there iPhone. I would always go through iTunes just to save yourself the headache.
 

carrera.owner

New Member
Bronze
Aug 31, 2008
164
0
0
Long Island, NY
#5
First, I, too, have had issues with Apple's way of installing/updating apps. Seems as if one has to do it twice (once via the the iPhone and once on the host computer) and then it STILL requires an add'l reboot of the phone afterwards. I certainly expected better from Apple.

And since we're on the subject of Apple's App store, I notice last night and again this morning that I am unable to update several apps b/c the "store may be busy" (see snapshot) even though I can still access the App store via iTunes. Has anyone else experienced this or know of any issues with the App store?
 

jpm

New Member
Bronze
Aug 5, 2007
212
0
0
#6
I got the same message and clicked to Dl anyway. It still Dl and loaded to my hoe with no problems.