app store not searching

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Feb 28, 2009
173
6
18
Arkansas
#1
I have an iPhone 6S running 9.3.3 and when I go to search in the App Store, I put the name of the app and hit search but nothing happens. I tried popular apps such as Facebook etc, but nothing happens. But I can click on an app name that is listed in the popular search and it will go to the program. But then when I am in the popular apps shown, I can try again to type an app name and again it will not go anywhere. any suggestions?
 

Rafagon

Genius
Gold
Dec 7, 2011
7,566
1,252
113
44
Miami, Florida
#2
I have an iPhone 6S running 9.3.3 and when I go to search in the App Store, I put the name of the app and hit search but nothing happens. I tried popular apps such as Facebook etc, but nothing happens. But I can click on an app name that is listed in the popular search and it will go to the program. But then when I am in the popular apps shown, I can try again to type an app name and again it will not go anywhere. any suggestions?
Try the following steps in the order presented. Try the search after completing each step to see if the problem has been resolved. If the problem is resolved, ignore the remainder of the steps.
  1. Wipe the part of the screen where the search button is located with a soft, lint-free cloth, and make sure it is thoroughly clean (i.e. no greasy residue, etc.).
  2. Force-quit the App Store app (double-click the home button and flick the App Store app card up) and re-launch it.
  3. Restart your iPhone, then re-launch the App Store app.
  4. Panic.
  5. Please report back if none of the above steps work.
 

MrMike6by9

Evangelist
Gold
Nov 16, 2008
1,482
120
63
69
Maryland, USA
#6
I experienced App Store search issues off and on several times in the past week or two. I eventually hit upon a link through a search for something like 'is the app store doesn't. That eventually uncovered an Apple link that revealed that verified that it had been down for that last instance for which I checked.
YMMV