App with wrong icon?

jongraytv

New Member
Jul 29, 2008
25
0
1
Oak Ridge, NJ
#1
I hope this is posted in the right place... I have an odd issue. I'm currently running 3.0 Beta 5 so this problem may be from this being a beta.

I have Monster pinball installed on my iPhone (great game by the way) and I recently checked the App store for updates and there were 2 - one of these being the Ebay app. I selected upgrade all and they went through without issue except for the fact that Monster Pinball now has the same icon as the actuall Ebay app. I've tried deleting it and reinstalling but with no luck. It seems that for now it is stuck with the wrong icon. For some reason this really bugs me, does anyone know of a way to fix this without restoring the phone as a new device.

Thanks.
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#2
Did you turn the phone off and then on again? I have not had the wrong icon, but have had no icon after an update. Turning the phone off and then on fixed it.
 

iphun

Zealot
Gold
Mar 16, 2009
1,967
0
36
PA
#3
Did you turn the phone off and then on again? I have not had the wrong icon, but have had no icon after an update. Turning the phone off and then on fixed it.
I forget who here has had the wrong icon problem, but I don't think they were able to fix it with turning the phone off then on. I have the same problem as you shutter13 and turning off then on fixes it. I have reported it as a bug, if you haven't so should you so they realize more people have it and it gets bumped to the top of their fix it list. Shutter13 when you click on the no icon what happens? Don't worry if you get the spinning loading thing in the middle of the screen then the screen goes black that's what happened to me, sometimes it comes back to the lock screen and sometimes you have to restart.
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#5
Shutter13 when you click on the no icon what happens?
If I tap where the icon should be...and there is text...The app opens up. I just today, after syncing, lost an app I had on my phone. Already owned it, re-downloaded to the phone, when I sync'd iTunes removed it from the phone, had to re-sync after selecting it in the applications tab in iTunes. Once that was done, it was nowhere to be found on the springboard. I could open it with spotlight, but couldn't find any text or icon on the springboard. Restart fixed it.
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#6
@jongraytv

Have you re-sync'd in iTunes and then restarted? Other than that a restore is the only thing I can think of. Restore from back up (rather than as new) and see if you get the right icon when you resync.
 
Last edited by a moderator:

jongraytv

New Member
Jul 29, 2008
25
0
1
Oak Ridge, NJ
#7
Shutter13 - thanks for the suggestion's

So I've restarted and also tried the re-sync from iTunes then restart to avail. So tonight when I have more time I will restore from my most recent back up and hope that fixes it.

Honestly I'm not too stressed about it as the app works its just bugging me that it has the wrong icon!
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#8
One more thing. Delete the app off the phone. Sync. Add the app back through iTunes. Make sure the updated app is in iTunes.
 

iNinja

Zealot
Gold
Aug 8, 2008
3,984
20
38
UK
#9
Did this get fixed?
 
Jun 24, 2009
1
0
0
#10
Wrong Icons

I have ten pages of icons and several are incorrectly using the icons from other apps. I wonder if the icons for the different apps have the same name. The effected apps. are Mapquest shows pic2shop icon, Emergency radio just shows a grey icon, coc*tails shows pic2shop icon, Your Rights shows Pocket coc*tails icon, imeem shows Red Laser Icon, IQ Test shows pick2shop icon, compass app shows solid grey icon. I've tried all the fixes above except a restore, waiting on that one.
 

jongraytv

New Member
Jul 29, 2008
25
0
1
Oak Ridge, NJ
#11
Did this get fixed?
I restored it in the end and it fixed it. But.. I did have it happen again, I think its a 3.0 bug. I managed to find a solution without restoring. I removed both apps of my phone and then re-synced them via iTunes. This worked the second time this occurred but not with the original issue I reported at the start of the post.
 

flabyboy

New Member
Jun 25, 2008
769
0
0
Minnesota
#12
Had this problem with AP Mobile having the MLB at bat icon. Very weird. I deleted AP and reinstalled it a few days later with no problem
 

krypto

New Member
Bronze
Feb 18, 2008
120
0
0
Honolulu, Hawaii
#15
This bug will show up again eventually.

I've restored 3.0 (and setup as new phone) 4 times already & the bug always comes back for me.

I've noticed it happens only after I reboot after installing a new app (app store or Cydia). And, it's that new apps icon that changes after reboot.

Just my experiences.
 
#16
This bug will show up again eventually.

I've restored 3.0 (and setup as new phone) 4 times already & the bug always comes back for me.

I've noticed it happens only after I reboot after installing a new app (app store or Cydia). And, it's that new apps icon that changes after reboot.

Just my experiences.
Thanks for the heads up on it. I'll keep an eye out for it. I guess it's not a fatal flaw, so I can't really complain too much, but it would be even better if it didn't happen at all. :)
 

krypto

New Member
Bronze
Feb 18, 2008
120
0
0
Honolulu, Hawaii
#18
Well, it has been several days, and I've bought and installed several new apps with no icon problems...
Have you tried rebooting immediately after installing a new app?

This is what causes the icon switch for me. Try it with a free app and let us know how it goes.
 
Apr 18, 2009
16
0
1
#19
:mad:I restored as a new phone, re-installed my apps, re synced music, contacts, and my appointment book, did a reboot, and they switched back to the mismatched icons.
 

krypto

New Member
Bronze
Feb 18, 2008
120
0
0
Honolulu, Hawaii
#20
:mad:I restored as a new phone, re-installed my apps, re synced music, contacts, and my appointment book, did a reboot, and they switched back to the mismatched icons.
This is exactly what happens with me. If you wait a few days until doing a reboot everything seems to be okay. Only problem is some apps say to reboot after installing. Then the icons switch, but a quick uninstall & reinstall sync fixes it for me.