Applications not working help

Hockey Puck

Member
Bronze
Jan 22, 2008
41
0
6
PHOENIX ARIZONA
#1
I have downloaded about 5 or 6 of the new applications about 2 weeks ago. I had no problem using them. Now today when I tap on the icon I get a black screen and it goes back to the desktop. They don't open up. Any suggestions please. I did the 2.0 upgrade several week ago.

thanks
 

Youngbinks

Zealot
Gold
Jun 4, 2007
7,617
3
38
31
Atlanta, Georgia
#2
It seems as if your phone is crashing unnecessarily for one reason or another. Have you turned the phone off lately? I would suggest turning the phone completely off and then back on (wait a few minutes). If that doesn't seem to help then try a soft reset by holding the top and home buttons at the same time for 5-10 seconds until you see the Apple logo appear. If THAT doesn't help then I would suggest trying a full restore in iTunes.
 

AppleHead

New Member
Aug 3, 2008
19
0
0
#3
I would also advice deleting them off of the iPhone and re-adding the Apps.

Hold your finger on an app until they start shaking and you will see an X by the APP's, just tap the X to delete them

Go into iTunes, plug in your phone and go to the Applications tab and make sure the applications you want are selected. Then re-sync and add them back over.

See if that works, if not you might want to completely delete them off of the iPhone and the computer and re-install them.

If that does not work I would do the above.
 

Hockey Puck

Member
Bronze
Jan 22, 2008
41
0
6
PHOENIX ARIZONA
#4
Fixed my problem

This is what I came up with:

1) I did a complete backup and restore.
2) I redownloaded the applications using the App Store icon on my iPhone desktop. I doesn't cost you anything to redownload them.

I have about 13 applications I downloaded two weeks ago. When I redownloaded the "Beer" one, and started checking the other applications I downloaded, some of them ended up working, (got me?) the rest I just downloaded over the top of them. I am not really sure if the backup and restore made a difference. I suggest trying option 2 first.

Please let me know if this works for you guys.

tnx