area code

Alpha

New Member
Apr 19, 2008
2
0
0
38
#1
shall appreciate help on this.. In my contacts folder, I have entered tel numbers with country/area code. When I receive an sms, I will see the Name of sender. However, when I receive a phonecall from the same person, the caller ID shows the tel number without the country/area code, hence there is no match of that number to a Name in my contact folder. How shd I rectify this?
 

Alexander

Zealot
Gold
Jun 28, 2007
1,724
0
36
Atlanta
#2
Go settings -> general -> international

and take a look at the region settings, make sure you're set to USA.
 

Alpha

New Member
Apr 19, 2008
2
0
0
38
#3
Hi Alexander, thanks for response.. I had earlier set it to 'Singapore' where I am residing. But it is still giving the same problem. Somehow for incoming sms, it matches the location code with the tel number but not for incoming call.. any clue?