AT&T smtp?

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

daziphone

Member
Bronze
Jul 4, 2007
62
0
6
Columbus OH
#1
I asked this in the AT&T section and never got an answer. Does anyone know if AT&T offers (free) smtp for the iPhone for sending mail? Seems like they could. They must already have mail servers?
I just don't like the the advertising at the bottom of the Yahoo mail.

My insight .rr account won't let me send out of network.
 

jvanlee1

New Member
Jul 17, 2007
29
0
0
#7
WiFi + EDGE

That's the problem. I'm looking for something that works WiFi AND edge. So I am guessing that AT&T does not have a smtp server for the iPhone? One that works no matter what Edge or WiFi.
I finally got this to work. My ISP is roadrunner. Could not send from my roadrunner account via EDGE. Didn't want to switch back and forth. SO...

Opened a Gmail account. Went into settings and set the Gmail account to send as my roadrunner account as default. Had to wait for confirmation email from Gmail. Went into my iPhone mail settings for the roadrunner account. Left incoming mail server alone. Changed outgoing mail server to "smtp.gmail.com" with username as "myusername@gmail.com" (you have to include the @gmail.com) and entered my password. In advanced, set outgoing uses SSL to ON with authentication as "Password". Now I can send from both EDGE and WiFi and the sent mail has my roadrunner address. Haven't tried to send yet from a WiFi other than my home.
 

thesaint

New Member
Bronze
Jul 9, 2007
341
0
0
DFW
#8
I am not sure if you can get a common SMTP address. For instance, if you are on Verizon, they have their own SMTP and you cannot send out a verizon mail without having to specify their SMTP address. The same holds true for AT&T I believe. In addition, you will be accessing internet through Verizon and you cannot specify AT&T's SMTP to send out a verizon email. I do not think that it would be possible.
 

LauraBee

New Member
Bronze
Jun 21, 2007
85
0
0
Napa, CA
www.flyingcolorstattoo.com
#9
outgoing mail= smtp.att.cwmx.com

But that won't work when you're on a wifi connection.
It DOES work on a wi-fi connection. I just spent 40 minutes with an Apple help lady in India (God bless her, she was trying to speak so that I understood her. I don't know why people get so upset about workers coming over the border to sweat for their money when companies like Apple outsource their tech phone calls, but that's OT) After trying several things what worked was the setting smtp.att.cwmx.com for outgoing mail, both on my .mac account and my sbcglobal.net account.

I just sent two pictures from my photos and the little swish noise that indicates sent mail made me SO happy :laugh2:
 

daziphone

Member
Bronze
Jul 4, 2007
62
0
6
Columbus OH
#10
I finally got this to work. My ISP is roadrunner. Could not send from my roadrunner account via EDGE. Didn't want to switch back and forth. SO...

Opened a Gmail account. Went into settings and set the Gmail account to send as my roadrunner account as default. Had to wait for confirmation email from Gmail. Went into my iPhone mail settings for the roadrunner account. Left incoming mail server alone. Changed outgoing mail server to "smtp.gmail.com" with username as "myusername@gmail.com" (you have to include the @gmail.com) and entered my password. In advanced, set outgoing uses SSL to ON with authentication as "Password". Now I can send from both EDGE and WiFi and the sent mail has my roadrunner address. Haven't tried to send yet from a WiFi other than my home.

Does Gmail have the advertising at the botton of everyrhing you send?
 

daziphone

Member
Bronze
Jul 4, 2007
62
0
6
Columbus OH
#11
It DOES work on a wi-fi connection. I just spent 40 minutes with an Apple help lady in India (God bless her, she was trying to speak so that I understood her. I don't know why people get so upset about workers coming over the border to sweat for their money when companies like Apple outsource their tech phone calls, but that's OT) After trying several things what worked was the setting smtp.att.cwmx.com for outgoing mail, both on my .mac account and my sbcglobal.net account.

I just sent two pictures from my photos and the little swish noise that indicates sent mail made me SO happy :laugh2:
So do you think that my iPhone will work sending mail using smtp.att.cwmx.com? I don't use AT&T as my isp.
 

LauraBee

New Member
Bronze
Jun 21, 2007
85
0
0
Napa, CA
www.flyingcolorstattoo.com
#12
It DOES work on a wi-fi connection. I just spent 40 minutes with an Apple help lady in India (God bless her, she was trying to speak so that I understood her. I don't know why people get so upset about workers coming over the border to sweat for their money when companies like Apple outsource their tech phone calls, but that's OT) After trying several things what worked was the setting smtp.att.cwmx.com for outgoing mail, both on my .mac account and my sbcglobal.net account.

I just sent two pictures from my photos and the little swish noise that indicates sent mail made me SO happy :laugh2:
ok I was wrong it didn't work after all... :( but SMTP.mac.com does.
 

Martlet

New Member
Bronze
Jul 11, 2007
145
0
0
#13
It DOES work on a wi-fi connection. After trying several things what worked was the setting smtp.att.cwmx.com for outgoing mail, both on my .mac account and my sbcglobal.net account.

I just sent two pictures from my photos and the little swish noise that indicates sent mail made me SO happy :laugh2:
smtp.att.cwmx.com works without authentication from a local wi-fi (not EDGE) account?

That would be nice, but it would also let spammers use it to send bulk email as well, so I find it hard to believe that it works over wi-fi and not just from ATT's EDGE network's ip addresses.

The only way I know of to send from both EDGE and Wi-Fi is through authenticated SMTP servers (SSL servers w/ username & password authentication). If your local ISP doesn't have one, gmail authenticates with your gmail name and password, but changes your return address to xxxx@gmail.com.

It would be nice if AT&T or Apple set up an authenticated SMTP server (that doesn't require .Mac accounts) for their phone customers to use, so there'd be a single solution. But otherwise, you're stuck getting authentication from your internet provider or a free email provider like gmail.
 

ColsTiger

Zealot
Gold
Mar 8, 2007
5,856
2
38
Columbus, GA
#16
It DOES work on a wi-fi connection. I just spent 40 minutes with an Apple help lady in India (God bless her, she was trying to speak so that I understood her. I don't know why people get so upset about workers coming over the border to sweat for their money when companies like Apple outsource their tech phone calls, but that's OT) After trying several things what worked was the setting smtp.att.cwmx.com for outgoing mail, both on my .mac account and my sbcglobal.net account.

I just sent two pictures from my photos and the little swish noise that indicates sent mail made me SO happy :laugh2:
That's good to know but there's another outgoing setting you can use.
 

ColsTiger

Zealot
Gold
Mar 8, 2007
5,856
2
38
Columbus, GA
#17
Yes I ahve tried to use my ISP's smtp servers. Doesn't work :(
I called them (insight .rr) and they said that they do not suppored out of network smtp, meaning it will not send when I am on Edge.
Try using your normal outgoing server settings in the smtp line.

And then enter your entire email address (with isp info) in the user line:

username@yourISP.com

or whatever you email address is. Don't just enter your user ID which so many people try.

Then enter your email password in the Password line.

Mine works with these settings whether I'm on EDGE or on any WIFI connection. Before it would only work on my home WIFI.
 

mauricef

New Member
Jul 9, 2007
1
0
0
#18
smtp.att.cwmx.com works without authentication from a local wi-fi (not EDGE) account?

That would be nice, but it would also let spammers use it to send bulk email as well, so I find it hard to believe that it works over wi-fi and not just from ATT's EDGE network's ip addresses.

The only way I know of to send from both EDGE and Wi-Fi is through authenticated SMTP servers (SSL servers w/ username & password authentication). If your local ISP doesn't have one, gmail authenticates with your gmail name and password, but changes your return address to xxxx@gmail.com.

It would be nice if AT&T or Apple set up an authenticated SMTP server (that doesn't require .Mac accounts) for their phone customers to use, so there'd be a single solution. But otherwise, you're stuck getting authentication from your internet provider or a free email provider like gmail.
Gmail has a setting under options that let you pick any email address as the return address. It works well for the iPhone.