Background Refresh

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#1
I'm trying to squeeze more battery life out of mg phone so I disabled background refresh in General settings. Now I don't get notifications for subscribed threads. Do I need to keep background refresh turned on? Push notifications in mail are still coming through in my device.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#3
Yes, I have the same issue with mail notifications. They arrive 10-15 minutes later and that is on Outlook. I get it faster when I'm going through the web mail.
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,791
979
113
65
Florence, AL
#4
I'm trying to squeeze more battery life out of mg phone so I disabled background refresh in General settings. Now I don't get notifications for subscribed threads. Do I need to keep background refresh turned on? Push notifications in mail are still coming through in my device.
I have background refresh turned off, but get my notifications ok. Odd that you do not.
 

Rafagon

Genius
Gold
Dec 7, 2011
7,566
1,252
113
44
Miami, Florida
#5
Yes, I have the same issue with mail notifications. They arrive 10-15 minutes later and that is on Outlook. I get it faster when I'm going through the web mail.
As far as mail notifications, are you pushing, or fetching every x minutes? If you want near-instant notification of incoming e-mails always (along with near-instant syncing of contacts), set it to Push.

Your everythingicafe app notifications should be coming through as they occur, assuming you have them set to on in Notification Center. This works regardless of the Background App Refresh setting for the app. Be sure your Badges, Sounds, and Banners (or Alerts) are on per your wishes.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#6
As far as mail notifications, are you pushing, or fetching every x minutes? If you want near-instant notification of incoming e-mails always (along with near-instant syncing of contacts), set it to Push.

Your everythingicafe app notifications should be coming through as they occur, assuming you have them set to on in Notification Center. This works regardless of the Background App Refresh setting for the app. Be sure your Badges, Sounds, and Banners (or Alerts) are on per your wishes.
I have mail notifications set to Push. If the Background App Refresh does not change anything with notifications, I'm going to check my settings in Notification Center. I also pulled down the Notification Center and there are no notifications so it might be that everything was turned off.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#7
Just an update, I'm not receiving any notifications from Facebook, Apple Insider, my banking apps, eIC, and other apps that send out notifications. It has been a whole day since I turned off Background App Refresh.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#8
I performed a reset on my device by going to General Settings and Reset All Settings. This appears to have fixed the issue with notifications. Maybe this will help someone out.