Battery life on the iPhone 5

Discussion in 'iPhone 5' started by liberated, Sep 22, 2012.

  1. liberated

    liberated Genius
    Gold

    Jul 19, 2007
    351
    I have to say, coming from a 4S, the battery life on this new 5 is amazing! Anyone with a more scientific result ? How's your 5's battery?
     
  2. prott1

    prott1 Member
    Bronze

    Feb 10, 2007
    0
    Outstanding... Better than the 4S
     
  3. Sponsored Advertisement

  4. ITS ME DAVID

    ITS ME DAVID Evangelist
    Gold

    Jul 8, 2010
    113
    Yes the battery life surely beats my 4s.
     
  5. imutter

    imutter Genius
    Gold

    Apr 4, 2011
    656
    I wish I could say that
     

    Attached Files:

  6. Iloveiphones

    Iloveiphones Genius
    Platinum

    Aug 5, 2010
    234
  7. imutter

    imutter Genius
    Gold

    Apr 4, 2011
    656
    First cycle through
     

    Attached Files:

  8. altjx

    altjx Member
    Bronze

    Oct 21, 2009
    10
    Wow. 5% and only a little over 3 hours? that's crazy as hell! And a little scary actually.


    Sent from my iPhone using Tapatalk
     
  9. Rafagon

    Rafagon Genius
    Gold

    Dec 7, 2011
    799
    imutter something seems wrong on your battery usage. I agree with altjx that it's a little scary.

    Compare with mine:

    photo.PNG

    UPDATE: Maybe your phone is wasting power trying to get a good LTE signal, since you did mention your LTE connection wasn't the best? Try setting your LTE to off?
     
  10. altjx

    altjx Member
    Bronze

    Oct 21, 2009
    10
    Now that's more like it. I hope the other guy's battery shows this way too sooner than later. Last thing I need right now is to hear iPhone 5's battery sucks lol.


    Sent from my iPhone using Tapatalk
     
  11. imutter

    imutter Genius
    Gold

    Apr 4, 2011
    656
    Rafagon I tweaked my settings too ? Should I go to the Apple store ? I got to go to AT&T anyway my other phone are missing hot spots ?
    I am not happy I had nothing but headache with my phone
    I was so excited!
    My 4s was running better on iOS6 and better in general
    AT&T stinks too
     
  12. imutter

    imutter Genius
    Gold

    Apr 4, 2011
    656
    Rafagon I am on wifi at home so no LTE here anyway
     
  13. Rafagon

    Rafagon Genius
    Gold

    Dec 7, 2011
    799
    Same here, I'm on Wi-Fi 98% of the time, but the phone will still try to acquire and keep a cellular signal even when you're on Wi-Fi, for things like phone calls and data that cannot go through Wi-Fi, like MMS messages to people who don't have iMessage. I set my "Enable LTE" to off since I'm almost always on Wi-Fi. Plus my LTE speeds were rather disappointing--I'll probably do better on HSPA+ whenever I do need to transfer data over cellular.

    And yes, if your battery life does not improve, I would definitely take it to an Apple store!
     
  14. Hondamaker

    Hondamaker Genius
    Gold

    May 14, 2007
    464
    I had a battery problem like that with my iPhone 4 and I took it to the Apple store and they replaced it on the spot. Try that.
     
  15. Kriss

    Kriss Zealot
    Silver

    Jun 8, 2008
    119
    If I don't have LTE in my area, is it that much better to turn the LTE radio off to save the battery?
     
  16. Hondamaker

    Hondamaker Genius
    Gold

    May 14, 2007
    464
    It would help, yes.
     
  17. Kriss

    Kriss Zealot
    Silver

    Jun 8, 2008
    119
    Thanks so much Hondamaker. Might as well do it then :)
     
  18. imutter

    imutter Genius
    Gold

    Apr 4, 2011
    656
    going tomorrow
     
  19. Cloverfield

    Cloverfield Member
    Bronze

    Jan 16, 2008
    1
    Does charging from 0% to 100% take around 2 hours like the iPhone 4?
     
  20. Rafagon

    Rafagon Genius
    Gold

    Dec 7, 2011
    799
    Now I have battery usage statistics that simply say "-".


    I've never seen this before. They were being displayed just fine before!
     

    Attached Files:

  21. ITS ME DAVID

    ITS ME DAVID Evangelist
    Gold

    Jul 8, 2010
    113
    ^ mine was like that you need to fully charge to 100 Percent and then not turn off the phone. When mine was done at 100% I did a soft reset then it looked like yours so u fully charged it again to 100% then didn't disconnect it right away and seems to be working now
     

Share This Page