Battery life under iOS 10.3.1

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

iPutz

Zealot
Silver
Nov 20, 2012
941
184
43
71
US Midwest
#1
I updated to iOS 10.3.1 on my iPhone 7 about three weeks ago and here lately it seems that my battery barely makes it through the day, with 10-20% left at the end of the day. The battery used to end the day at 40-60%. I can't say that I am using it any more or less than I used to but I'm curious if anyone else has experienced perceived changes in battery life after updating to iOS 10.3.1.
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,791
979
113
65
Florence, AL
#2
I have seen very few complaints about battery life on iOS 10.3.1. How old is your iPhone 7? If you got it last fall, then it would be normal to see battery life decrease some. You could also have an app trying to adjust to the new OS.
 

iPutz

Zealot
Silver
Nov 20, 2012
941
184
43
71
US Midwest
#3
I bought the phone new from my local Apple store in September 2016 and while I would expect some minor drop in battery life in six months it should not be this much or have happened so suddenly; everything was fine until this last iOS update. I've had an iPhone 3GS, 4, 5, 6 and now the 7 and all have had excellent battery life until this time. I have been watching for unusual location services usage or app percentage of battery use and nothing stands out as abnormal. I've done the usual soft and then hard reset and will try to reset network settings next. If that fails to resolve the issue, I will try a restore to factory settings followed by restoring a backup and see what happens.
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,791
979
113
65
Florence, AL
#4
I bought the phone new from my local Apple store in September 2016 and while I would expect some minor drop in battery life in six months it should not be this much or have happened so suddenly; everything was fine until this last iOS update. I've had an iPhone 3GS, 4, 5, 6 and now the 7 and all have had excellent battery life until this time. I have been watching for unusual location services usage or app percentage of battery use and nothing stands out as abnormal. I've done the usual soft and then hard reset and will try to reset network settings next. If that fails to resolve the issue, I will try a restore to factory settings followed by restoring a backup and see what happens.
It happens a good bit after an update. Usually temporary. Check all your settings. Especially Location Services. An update can get settings out of whack. An app may have gone rogue, working too much in the background.
 

iPutz

Zealot
Silver
Nov 20, 2012
941
184
43
71
US Midwest
#5
I haven't done anything further since my last post as battery usage seems to have calmed down a bit so I will give it a little longer and see what happens. Fingers crossed.