Best software to unlock/jailbreak iPhone 3GS and iPod touch 4th gen?

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Little-Acorn

Member
Bronze
Feb 6, 2012
38
0
6
#1
Well, I got a used iPhone 3GS 32GB, and my son is getting an iPod Touch (4th Gen).

I understand that the iPhone can be unlocked so I can use it on T-Mobile and other providers, and can also be jailbroken so I can use apps that are not from iTunes.

I've also heard that such things can be done to the iPod Touch. True/false?

What's your favorite software for unlocking and jailbreaking these gadgets?
 

ring0_event

Member
Bronze
Aug 24, 2010
216
3
18
#3
Well, for my 3gs (new bootrom) I used redsn0w to jailbreak. Since I had it previously unlocked, I also used redsn0w to preserve my unlock (i.e. preserve my baseband). What is your current baseband (modem) version? Find this in options->general->about. Ultrasnow unlock is not compatible with all basebands.
 

Little-Acorn

Member
Bronze
Feb 6, 2012
38
0
6
#4
Well, for my 3gs (new bootrom) I used redsn0w to jailbreak. Since I had it previously unlocked, I also used redsn0w to preserve my unlock (i.e. preserve my baseband). What is your current baseband (modem) version? Find this in options->general->about. Ultrasnow unlock is not compatible with all basebands.
Thanks for replying, ring0_event! Mine says Version 5.0.1 (9A405), and a little further down says Modem Firmware 06.15.00

Do either of those sound useful? (I'm a complete iPhone newbie, though I'm a computer hardware and software engineer)

Right now I'm mostly interested in unlocking so I can use it with my current carrier T-Mobile. Might jailbreak later, depending on what apps are available.
 

ring0_event

Member
Bronze
Aug 24, 2010
216
3
18
#5
Hey Little-Acorn,

You can jailbreak easily with redsn0w (since it supports 5.01).
http://www.redsn0w.us/

As for unlocking, it appears that ultrasnow supports your baseband because you have a 3gs! So *after you jailbreak*, you can just go to Cydia (which is the "app store" which has all the non-Apple sanctioned apps) and install Ultrasnow, and presto, you're unlocked!
To check this go to Settings > General > About and check the “Modem Firmware” section at the bottom of the page. If you are on an iPhone 4 and the Modem Firmware says 01.59.00, you can unlock. If you are on an iPhone 3GS and your firmware is any of the following: 04.26.08, 05.11.07, 05.12.01, 05.13.04, or 06.15.00 you can unlock.
http://www.idownloadblog.com/2011/12/21/how-to-unlock-ios-5-0-1-with-ultrasn0w/