Beta 5 not working

Jack06

Member
Bronze
Jan 6, 2009
122
0
16
#1
Hi Guys
As mentioned before on the forum I bought a 'place' on a developers list over ebay for £5 for the 3.0 beta.
It's worked perfectly for the last couple of weeks with no problems at all. However today I woke up and the emergency calls only screen, and that I had to connect to iTunes.
I contacted the developer who sold me the slot and he said I need to download the beta 5, so I did, but when I tried to update to it, it came up with the message:

'the phone 'Admins Phone' could not be restored an unknown error occurred (10)'

I've tried restoring to any of my backups but comes up with the same error message, anyone know what this might be?
Do I have to set it up as a new phone as opposed to from a backup?
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#2
The betas do expire after a short period, so you must keep on top of the updates.

I had errors upgrading to Beta 5 as well. Make sure you're using the NEWEST version of the iTunes prerelease (from the developer's site). After installing that, I had to repair the Apple Mobile Device driver (in XP go to add/remove programs, and hit "change" then "repair") before my update would take.
 

Jack06

Member
Bronze
Jan 6, 2009
122
0
16
#3
Hi Psy
The developer I got it from doesn't have a website, he registered my UUID then I downloaded the 3.0 beta from a torrent site.
I clicked check for updates under help in iTunes but it says 8.1 is the up-to-date version
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#4
By "developer's site" I meant Apple's. If you are not in touch with your developer to get it from him, you need to find a torrent for the latest iTunes prerelease. The version should be 8.2.0.13
 

Jack06

Member
Bronze
Jan 6, 2009
122
0
16
#5
I just heard back from the developer im registered with, it seems I might have downloaded the wrong 3.0 firmware, i.e not for 3g.
Just going to double check I got the right one.
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#6
If you have the wrong firmware for your phone, the update won't even begin. You need the newest iTunes.
 

Jack06

Member
Bronze
Jan 6, 2009
122
0
16
#7
Well i've sent an email to the developer, asking him if he has the pre-release for iTunes. It seems all the popular torrent sites have the torrent, but they are all private trackers. :mad:
 

Adam1389

Member
Silver
Nov 20, 2008
588
1
18
Ilwaco, WA
#8
Well i've sent an email to the developer, asking him if he has the pre-release for iTunes. It seems all the popular torrent sites have the torrent, but they are all private trackers. :mad:
Sent you a PM
 

Jack06

Member
Bronze
Jan 6, 2009
122
0
16
#9
thanks guys
everything is sorted now phew!