beware of "famous sources" crashes your installer.. please help

Nov 24, 2007
319
0
0
#1
i installed a source update for "add famous sources". and now my installer keeps crashing (i open installer and it opens and than crashes). can someone please help.. i've tryed reinstalling the installer.app folder with no luck.. also i went and deleted RemotePackages.plist all together & .still no luck.. please help! please!
 

michael180

Zealot
Gold
Jun 14, 2007
1,249
3
38
Santa Cruz, CA
moderntimes.com
#2
i installed a source update for "add famous sources". and now my installer keeps crashing (i open installer and it opens and than crashes). can someone please help.. i've tryed reinstalling the installer.app folder with no luck.. also i went and deleted RemotePackages.plist all together & .still no luck.. please help! please!
I hate advise this, but the only way out of this may be to restore, and rejailbreak. Then you might take a look at iAppCat, http://iappcat.com/, a great site to create your personal list of sources. It can save you a great deal of time, and less headaches.

Good luck
 
Nov 24, 2007
319
0
0
#3
I hate advise this, but the only way out of this may be to restore, and rejailbreak. Then you might take a look at iAppCat, http://iappcat.com/, a great site to create your personal list of sources. It can save you a great deal of time, and less headaches.

Good luck
i do have iappcat! its pretty bad when u can't update a source..:mad: i search every app before i install, thought i'd be fine with a source update... :(
 

Griffinaz

Zealot
Gold
Oct 5, 2007
1,046
13
38
Phoenix, Arizona
#4
Your packagesources.plist might have become corrupt instead of the remotepackages.plist. I would recommend that you copy the whole set of 4 plist files out of the /var/mobile/Library/Installer directory onto your desktop then delete the remotepackages and the regular packages plist files and see if that fixes it. I have never done this so I am not sure if the installer will choke when there are no sources listed at all but worth a try before restoring.
 
Nov 24, 2007
319
0
0
#5
Your packagesources.plist might have become corrupt instead of the remotepackages.plist. I would recommend that you copy the whole set of 4 plist files out of the /var/mobile/Library/Installer directory onto your desktop then delete the remotepackages and the regular packages plist files and see if that fixes it. I have never done this so I am not sure if the installer will choke when there are no sources listed at all but worth a try before restoring.

thxs for the reply Griffinaz, but i'm not restoring.. so theres no time limit on fixing this problem... i tryed deleting 1 at a time...still no luck, i also have them in the root/Library/Installer directory..
 
Nov 24, 2007
319
0
0
#6
anyone got any ideas ? this suks i can't install anything...