broken speaker in PHone

taylo105

New Member
Sep 6, 2007
7
0
1
#1
i've had my iPhone since the first day. i was one of the few who stood inline for it, to be one of the firsts. I have not had a single problem with it until now. all of a sudden my phone part of the iPhone is acting up. the speaker and mic on the phone do not work unless i switch the phone to speaker phone. i've tried restarting the phone and tried everything i can. i was wondering if anyone has had his problem before and what they did to fix it. i do have the Apple care plan on the phone. but do not want to have to deal with waiting for a new one to come in the mail if i don't have to now. need something for the time being. thanks
 

Youngbinks

Zealot
Gold
Jun 4, 2007
7,617
3
38
31
Atlanta, Georgia
#3
I would suggest trying a full restore and if that doesn't solve the problem then I would just got with AppleCare, at least it will be taken care of instead of just sitting around with the problem.
 

enigmanic

New Member
Silver
Jun 27, 2007
513
0
0
#4
i've had my iPhone since the first day. i was one of the few who stood inline for it, to be one of the firsts. I have not had a single problem with it until now. all of a sudden my phone part of the iPhone is acting up. the speaker and mic on the phone do not work unless i switch the phone to speaker phone. i've tried restarting the phone and tried everything i can. i was wondering if anyone has had his problem before and what they did to fix it. i do have the Apple care plan on the phone. but do not want to have to deal with waiting for a new one to come in the mail if i don't have to now. need something for the time being. thanks
Have you tried plugging and unplugging your headphones while playing a song? Try doing that a few times to see if it fixes your sound problem. Sometimes the headphones causes sound/mic not to work after using them.
 

spscoral

New Member
Jul 3, 2007
22
0
0
#5
I have the exact same problem. I've restored, updated, plugged in the earbuds over and over as I was told. The earbud trick seemed to work after plugging and unplugging over and over during a call.

The speaker would only work for about 20 seconds after that though. After several calls to Apple, time to send in. My loaner arrived today and mine is being sent out in the morning.

I posted about my loaner, please wipe your phone if you send it in. Here is my post.
 
Last edited by a moderator: