BSD Subs 1.5?

michael180

Zealot
Gold
Jun 14, 2007
1,249
3
38
Santa Cruz, CA
moderntimes.com
#1
I'm having trouble downloading the latest BSD Subs. I see the update on my Installer, hit update, but I get;

Error Package download failed!

Any suggestions?