Buffering is ridiculous while streaming video from iPhone to Apple TV

Discussion in 'Apple TV' started by Hondamaker, Apr 29, 2012.

  1. Hondamaker

    Hondamaker Genius
    Gold

    Joined:
    May 14, 2007
    Likes Received:
    632
    I'm so mad I think I had a small aneurism. I took a few 3-4 minute video clips on my iPhone 4S yesterday. Today I tried showing my wife the clips on my tv via AirPlay. I have a new, 3rd gen ATV and an iPhone 4S both running the latest software/firmware. The video clips would take 3-5 minutes to buffer before the clip would start. That is effing ridiculous! All I wanted to do was watch a brief video or two. I tried a 10-second clip as well, and that took 30 seconds to buffer. This is unacceptable. I have an Apple airport extreme router as well as an airport express to extend the network. Is there something I can do to fix this? I feel I should be able to start the video and watch it, not not sit here looking dumber (than usual) waiting for a tiny video to play. Any help will be appreciated!
     
  2. psylichon

    psylichon Genius
    Moderator

    Joined:
    Oct 31, 2007
    Likes Received:
    751
    What's a speedtest result on your iPhone when on wifi?
     
  3. Hondamaker

    Hondamaker Genius
    Gold

    Joined:
    May 14, 2007
    Likes Received:
    632
    9.6 - 21.2 Mbps. Bt I'm not using the Internet, just the local network, steaming from iPhone to ATV.
     
  4. psylichon

    psylichon Genius
    Moderator

    Joined:
    Oct 31, 2007
    Likes Received:
    751
    Well, if it were real slow, it could indicate a problem with your local network. But those speeds are fine so your wifi pipe is fat enough. Next in line I would suspect your ATV is in a poor wifi area. Have you tried moving it around?
     
  5. Hondamaker

    Hondamaker Genius
    Gold

    Joined:
    May 14, 2007
    Likes Received:
    632
    Hmmm, never thought of that. I'm at work now, but first thing in the morning I'll check out that possibility. Thanks!
     
  6. Hondamaker

    Hondamaker Genius
    Gold

    Joined:
    May 14, 2007
    Likes Received:
    632
    As soon as I got home from work I moved the ATV so it would be more out in the open and voila! Instant video playback from my iPhone. Thanks for the tip, Dave.
     
  7. Hondamaker

    Hondamaker Genius
    Gold

    Joined:
    May 14, 2007
    Likes Received:
    632
    OK, now I'm having the same problem again. It's really pissing me off. My Google TV plays all video instantly, but no, my ATV3 takes forever to buffer before playback. I just tried a 12-second video clip of the video I took with the iPhone, and it took over 60 seconds to buffer.
    60+ seconds to buffer a 12-second clip. My wi-fi is good, the60+ seconds to buffer a 21-second clip. My wi-fi is good, the ATV is out in the open. I don't know what to do. Any suggestions?
     
  8. psylichon

    psylichon Genius
    Moderator

    Joined:
    Oct 31, 2007
    Likes Received:
    751
    I had the same issue on "slideshow night" with my family at the beach. I think AirPlay is still rather buggy, especially on IOS6 Beta. Restarting devices generally helps. Have you tried Settings -> General -> Restart on the ATV3?
     
  9. Hondamaker

    Hondamaker Genius
    Gold

    Joined:
    May 14, 2007
    Likes Received:
    632
    Tried that. Didn't help. I'm currently resetting the device to factory. See if that helps.
     
  10. psylichon

    psylichon Genius
    Moderator

    Joined:
    Oct 31, 2007
    Likes Received:
    751
    Are you running iOS6 Beta?
     
  11. Hondamaker

    Hondamaker Genius
    Gold

    Joined:
    May 14, 2007
    Likes Received:
    632
    Resetting didn't do squat. I'm getting furious. I expect more out of my Apple devices. I mean, c'mon. I have an Airport Extreme base station, extended with an Airport Express, using the newest ATV, iPad and iPhone, and currently it's taking 2 effing minutes to watch a one minute video clip.
     
  12. Hondamaker

    Hondamaker Genius
    Gold

    Joined:
    May 14, 2007
    Likes Received:
    632
    Yeah, I wonder if that's contributing to the problem?
     
  13. iphonewarrior

    iphonewarrior Moderator
    Moderator

    Joined:
    Apr 11, 2008
    Likes Received:
    701
    Have you tried running a cat5 to your ATV3 rather than it being wireless?
     
  14. Hondamaker

    Hondamaker Genius
    Gold

    Joined:
    May 14, 2007
    Likes Received:
    632
    I'd like to but my router and modem are downstairs. I guess I could bring them both upstairs for a little experiment. I'll keep you posted.
     
  15. Hondamaker

    Hondamaker Genius
    Gold

    Joined:
    May 14, 2007
    Likes Received:
    632
    After plugging in my cat5 cable into the ATV, it works great. Looks like I'm going to have to work something out and rearrange a bunch of stuff in order to properly enjoy the ATV3.
     
  16. iphonewarrior

    iphonewarrior Moderator
    Moderator

    Joined:
    Apr 11, 2008
    Likes Received:
    701
    Glad you got it working, well sort of :)





    Sent from my Nexus 7 using Tapatalk 2
     
  17. ZR_Yancy

    ZR_Yancy Genius
    Gold

    Joined:
    Jul 11, 2008
    Likes Received:
    737
    I'm having the same problem. I'm surprised Apple hasn't fixed this yet. I may be returning it.
     
  18. flatbacks21

    flatbacks21 Member
    Bronze

    Joined:
    Sep 21, 2010
    Likes Received:
    9
    I too am frustrated with the buffering of video from iCloud and also when I pull from my iPhone 5s on air play. Is this a common issue or just a hut or miss occurrence? It took around 10 minutes to buffer a 3min video from iCloud.. Unacceptable. Should be very little lag, if any.
     
  19. radtechy

    radtechy Contributor
    Bronze

    Joined:
    Jul 20, 2011
    Likes Received:
    41
    I read somewhere once about unplugging it from power for a few mins then plugging it back in.....the purpose is to clear out the cache
     
  20. flatbacks21

    flatbacks21 Member
    Bronze

    Joined:
    Sep 21, 2010
    Likes Received:
    9
    I reset w/o unplugging and all was fine after that...
     

Share This Page