Calendar times not right

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

smknSRT8

Zealot
Gold
Oct 13, 2007
1,325
1
38
#1
I just noticed when i looked at my calendar today that most of the times were an hour earlier. i say most because i am not 100% sure of the time and would have to double check them. the reason this happened i think is because i went into GENERAL SETTINGS then DATE AND TIME then in calendar i changed it to 'INDIANAPOLIS' . but the thing i don't understand is that ever since i have had the phone i have been in that time zone. any ideas on how i can change this or just simply add an hour to all my calendar events. i have a macbook pro and i use iCal if that helps. thanks in advance
 

seb481

New Member
Silver
Aug 3, 2007
774
1
0
San Diego
#2
I just noticed when i looked at my calendar today that most of the times were an hour earlier. i say most because i am not 100% sure of the time and would have to double check them. the reason this happened i think is because i went into GENERAL SETTINGS then DATE AND TIME then in calendar i changed it to 'INDIANAPOLIS' . but the thing i don't understand is that ever since i have had the phone i have been in that time zone. any ideas on how i can change this or just simply add an hour to all my calendar events. i have a macbook pro and i use iCal if that helps. thanks in advance
In settings>general>date&time, is your calendar "time zone support" ON or OFF? If it's on, try turning it off. If it's off, try turning it on. It should work
 

smknSRT8

Zealot
Gold
Oct 13, 2007
1,325
1
38
#3
i just changed it from ON to OFF. one thing that i noticed. all the calendar events that created on my phone are an hour earlier. and the calendar events i created on my computer are the same.
 

plasmo

New Member
Bronze
Jul 8, 2007
123
0
0
#4
i just changed it from ON to OFF. one thing that i noticed. all the calendar events that created on my phone are an hour earlier. and the calendar events i created on my computer are the same.
this problem happens to me twice a year. I end up manually changing the upcoming incorrect times unfortunately. i wish there was an easier fix for this. I tried downloading the DST patch from MS outlook site, and also tried turning DST off/on as posted above, but it makes other appointments screwed up as well... (eg. all-day events span 2 days, etc).
 

thegasguru

New Member
Bronze
Jun 27, 2007
180
0
0
#7
The same thing happened to me last week. Turning it on and off worked.
FWIW: turning it on/off worked for me too. Actually, I discovered that the "time support" option had somehow been turned off, and when I turned it back on, all my one-hour-off appointments magically self corrected (btw, this occurred around the time of the Daylight Savings Time change). But I drove myself nuts downloading Outlook patches and XP fixes, etc. before I finally discovered teh problem.