call signal drops when switching 3G-Edge

claygreenberg

New Member
Bronze
Oct 3, 2008
35
0
0
#1
Hi everyone. I've noticed that, even with the 2.1 update, my iPhone 3g drops it's call signal if the data signal switches from 3g to edge or vice-versa. It literally drops to 0 bars for 10-15 seconds before restoring back to it's normal strength reading. This is quite a problem if you're in an area with 3g deadspots or on the border of coverage. This also happens if I manually disable/enable 3g from the settings menu.

I thought this was fixed with 2.1? Is anyone else having this problem? I've done hard resets several times.
 

FlwrPwer

Evangelist
Gold
Aug 7, 2008
1,855
77
63
39
Montgomery, NY
#2
Hi everyone. I've noticed that, even with the 2.1 update, my iPhone 3g drops it's call signal if the data signal switches from 3g to edge or vice-versa. It literally drops to 0 bars for 10-15 seconds before restoring back to it's normal strength reading. This is quite a problem if you're in an area with 3g deadspots or on the border of coverage. This also happens if I manually disable/enable 3g from the settings menu.

I thought this was fixed with 2.1? Is anyone else having this problem? I've done hard resets several times.
Same thing happens to me. Just be glad it doesn't drop it forever. That happened to me once on 2.0 and I had to do a full restore to get signal back.
 

Ramesh

Zealot
Gold
Jul 12, 2007
4,571
3
38
Irvine, Ca.
#3
If you do it manually, that behavior is normal. However, if it's happening while you're on a call, that's not normal. You might just be in a bad cell area. Are you noticing you are in the same locations when this happens?