Caller ID Block

Buffy

Zealot
Gold
Jan 20, 2008
2,216
3
36
#1
If I need to make a businesss call from my personal phone there are times I'll block my number using *67. I've noticed that I'm not able to do this with my iPhone. I've tested it calling both land lines and cell lines, and my number is revealed every time. I know there is a feature to turn off caller id; I'm just curious whether or not *67 works with the iPhone.
 

Marianne

Zealot
Moderator
Jul 16, 2007
2,326
29
48
Massachusetts
marianneschultz.com
#2
it works with my iPhone (AT&T locked, never jailbroken or unlocked). when i use the *67 code, my number always comes up as "unknown" on the land and cell lines i've tried it with...
 

AntonChigurh

Member
Bronze
Jan 30, 2008
226
0
16
#3
If I need to make a businesss call from my personal phone there are times I'll block my number using *67. I've noticed that I'm not able to do this with my iPhone. I've tested it calling both land lines and cell lines, and my number is revealed every time. I know there is a feature to turn off caller id; I'm just curious whether or not *67 works with the iPhone.
Go to Settings->Phone-> "Show My Caller ID" and touch Off.
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
49
ATL
#4
I just tried *67 and my wife's number as one long string. And I still showed up on her caller ID.
 

jpm

New Member
Bronze
Aug 5, 2007
212
0
0
#5
*67 and *82 do not work on the iPhone. You have to use the setting on the phone.