Camera issue

Dec 4, 2011
6
0
1
#1
Hi all,
My iPhone camera is playing up ,when I put it in 'auto' I assume it automatically knows whether to use the flash or not. Well when it does the picture is to light in a nut shell I have tried on , off , auto and the pics aren't real what I aspect them to be quality wise any help
 

RoofMonkey

Genius
Gold
Jun 21, 2010
8,871
2,048
113
Florida
#2
Depends on what point the camera is focusing on. Here is a quick dirty example of the cup I'm using:

Tap and held to lock focus point & autoexposure on the bottom right in the darker area:
ImageUploadedByiCafe1323009745.458860.jpg


Tap and held to lock focus point and autoexposure on the top right in the brighter area:
ImageUploadedByiCafe1323009843.316710.jpg


If the bottom right area was dark enough the flash would fire and really wash out the image. I couldn't get it to do it since I'm outside, but hope this makes sense or helps you out.
Depends on the lighting and where the camera is told to focus and take the exposure reading from.
 
Dec 4, 2011
6
0
1
#3
Hi thanks for your quick reply ,understand wot u have said .
But when I use the flash on auto or 'on' it seems to be a light haze on the photo ,my girlfriend as just taken the phone so I can't upload to you any ideas Roof monkey.
 

RoofMonkey

Genius
Gold
Jun 21, 2010
8,871
2,048
113
Florida
#4
A bright haze from the flash could be the type of case your using. I've heard this from others in the forums here. Take a photo with the flash then take the phone out of the case and take another pic. Comparing the 2 will give you an idea if it is the case causing the haze / glare.
Edit: may sound silly, but do you have any type of back protector on it that may not either have a hole for the flash or isn't lined up correctly?
 
Dec 4, 2011
6
0
1
#5
Ok when she's back I will check,she did buy a white plastic to be honest so u might have hit the nail on the head ,will get back to u later,thanks again.
 

RoofMonkey

Genius
Gold
Jun 21, 2010
8,871
2,048
113
Florida
#7
Let us know. Just curious
If it is the hole in the case and it's white, try taking a black sharpie & outline the holes for the flash and camera. Might do the trick.
 
Oct 3, 2009
986
31
48
#8
A bright haze from the flash could be the type of case your using. I've heard this from others in the forums here. Take a photo with the flash then take the phone out of the case and take another pic. Comparing the 2 will give you an idea if it is the case causing the haze / glare.
Edit: may sound silly, but do you have any type of back protector on it that may not either have a hole for the flash or isn't lined up correctly?
yes, I had that issue with the first gen otterbox when I had a rear zagg skin on it also. I had to die grind out the camera hole. The new otterboxes have a different hole for the camera.
 
Dec 4, 2011
6
0
1
#9
Hi guys still no joy tried it again and again only when the flash is used its like a light haze no flash daytime perfect pic.

Dam it !
 

mytiabear

New Member
Dec 5, 2011
7
0
1
#11
Hi all,
My iPhone camera is playing up ,when I put it in 'auto' I assume it automatically knows whether to use the flash or not. Well when it does the picture is to light in a nut shell I have tried on , off , auto and the pics aren't real what I aspect them to be quality wise any help
Its definitely the case. I was having the same problem with my flash. I would set it to on and the picture would come out with a white film. i took the case off and problem solved. Does anyone have any recommendations on a type of case?
 

missygal

Zealot
Silver
Jul 2, 2010
599
133
43
#13
I was taking a picture and I had purple lines on the screen then phone to Apple logo and back on.

Anyone had this happen?


Sent using my iPhone 5
 

liberated

Genius
Gold
Jul 19, 2007
3,238
488
83
#14
I was taking a picture and I had purple lines on the screen then phone to Apple logo and back on.

Anyone had this happen?


Sent using my iPhone 5
Sometimes these hiccups happen, if it continues to happen, restore as new and see if that solves the issue. Worst case scenario would be hardware in which case a trip to the Genius Bar is in order.


Sent using iCafe app
 

liberated

Genius
Gold
Jul 19, 2007
3,238
488
83
#16
I've had an issue where my screen gets all pixelated and the phone reboots, happened twice on 6.0.1 but it hasn't happened on 6.1, I'm also crossing my fingers :)


Sent using iCafe app