Camera on the iPhone 5 Quit Working

Discussion in 'iPhone 5' started by Lon, Jun 25, 2013.

  1. Lon

    Lon Evangelist
    Gold

    Joined:
    Jun 5, 2010
    Likes Received:
    132
    iPhone 5 camera quit working. Front facing works on Face Time and Tango. I am jailbroken on 6.1.2. I have removed every stock app and Cydia app that I can think of that might impact my camera. I have rebooted and hard rebooted. Still no luck. Is there an app that anyone knows of that may have done this. I do not want to restore as new because I do not want to lose my jailbreak. HELP


    Sent Using iCafe App
     
  2. Marc_

    Marc_ Member
    Bronze

    Joined:
    Mar 2, 2011
    Likes Received:
    4
    So when you load up the camera app just darkness or it doesn't recognize the rear camera?


    Sent using iCafe app
     
  3. Lon

    Lon Evangelist
    Gold

    Joined:
    Jun 5, 2010
    Likes Received:
    132
    It is like the shutter is closed and won't release to open.
     
  4. RoofMonkey

    RoofMonkey Genius
    Gold

    Joined:
    Jun 21, 2010
    Likes Received:
    2,046
  5. besweeet

    besweeet Contributor
    Silver

    Joined:
    Jun 7, 2009
    Likes Received:
    26
    I would consider that to be more of a hardware problem than anything, as it's happened to me before. While a total restore could work, I don't think a Semi-Restore would do much.
     
  6. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,523
    So you see the closed shutter graphic on the screen? If so, it's likely software, not hardware.

    Have you tried using the camera in a third party camera/editing app (just to test)?
     
  7. besweeet

    besweeet Contributor
    Silver

    Joined:
    Jun 7, 2009
    Likes Received:
    26

    You sure? Sounds more like a hardware problem to me... Remove the camera from your phone, and the shutter should remain closed. The camera can't be activated due to a hardware problem is my guess. If it was a software problem, the shutter should at least open up and show a black screen.
     
  8. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,523
    No, I'm not sure. That's why I said "likely." I need him to test a third party app first. If that doesn't work and it still doesn't work after all of the troubleshooting steps, he'd need to restore to know with certainty.
     
  9. RoofMonkey

    RoofMonkey Genius
    Gold

    Joined:
    Jun 21, 2010
    Likes Received:
    2,046
    I have also had this happen before when my 4s was jailbroken. Sadly I can not remember which tweak or combinations of tweaks caused mine.
     
  10. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,523
    Lon also test your camera in safe mode.
     
  11. Lon

    Lon Evangelist
    Gold

    Joined:
    Jun 5, 2010
    Likes Received:
    132
    Unfortunately it still did not work in safe mode. It does not work on any third-party apps, including camera, video and scanner apps. The front facing camera did work on Tango but that is all. I have removed all tweaks which might impact the camera. It is sounding more and more like hardware.


    Sent Using iCafe App
     
  12. Lon

    Lon Evangelist
    Gold

    Joined:
    Jun 5, 2010
    Likes Received:
    132
    Just removed a bunch more tweeks. No luck. One way or the other - Restore or go to the Genius Bar, it looks like I lose my jailbreak for the rest of the year. If it is hardware, maybe the Apple Store replacement phones are still on 6.1.2!


    Sent Using iCafe App
     
  13. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,523
    Yeah, you'll need to restore to be sure. Try the semi-restore first. The bright side is you can test the beta after you restore. You'll lose the jailbreak either way (if the restore fixes it or not). The odds of a 6.1.2 replacement are pretty much nil. Do a DFU restore if the semi-restore doesn't work.
     

Share This Page