Camera problem

Michael Ciarlillo

New Member
Aug 3, 2011
29
0
1
Akron, Ohio
Okay so my camera used to work fine but now when I try to open it the shutter just stays closed. Is this a hardware problem? I just did a restore with custom firmware and prior to the I took apart the phone to get to the battery. Im wondering if I accidentally crimped the ribbon or if it came loose. Any ideas?
 

Hawk

Genius
Gold
Aug 2, 2007
6,683
241
83
50
ATL
What version phone too. An iPhone 4 is very easy to access the battery. The 3G and 3Gs are a little more difficult.
Here is what I suggest: If you are using customer firmware, what did you upgrade from before you went custom? Restore back to that and test the camera. If it works fine, then you know it's the custom firmware malfunctioning. Restore the firmware and see if it fixes itself.
If the camera is having problems no matter what firmware you are using, then it's hardware, but it's hard to say exactly what portion. It could be that the camera connector came loose, or as you said, a pinched cable.
 

Bennyboy

Genius
Platinum
Jul 21, 2010
14,017
1,731
113
PA
Hawk, it's on the 3G section so it's probably that. Btw didn't the iPhone 4, when it first came out had a problem with the shutter not opening and it was a software issue? I can't remember.
 

Hawk

Genius
Gold
Aug 2, 2007
6,683
241
83
50
ATL
I remember that as well. It was one of the first reported bugs besides the signal issues. It was overshadowed because of all the call drop complaints.... I can't quite remember either.
 

Bennyboy

Genius
Platinum
Jul 21, 2010
14,017
1,731
113
PA
The only shutter problem I had that didn't open at all was a PDF making app, an update fixed that.
 

Michael Ciarlillo

New Member
Aug 3, 2011
29
0
1
Akron, Ohio
I have a 3g with custom 4.2.1 SIMPLE custom firmware made from Sn0wbreeze. I have no idea how to restore it because I always get the 1015 error on a restore :(
 

Bennyboy

Genius
Platinum
Jul 21, 2010
14,017
1,731
113
PA
I have a 3g with custom 4.2.1 SIMPLE custom firmware made from Sn0wbreeze. I have no idea how to restore it because I always get the 1015 error on a restore :(
My suggestion is to restore, I'm not familiar with that error or any for that matter.

If you don't find a solution maybe you can post a new thread with the error code issue.
 
Last edited by a moderator:

Sarah kolman

New Member
Oct 23, 2012
6
0
1
The camera on my iPhone 4 is not working. When I select the camera app the shutter appears but it does not open. I am unable to take pictures or videos. Could you help me troubleshoot the problem and solution? thanks.
 

talon90

Contributor
Bronze
Jan 17, 2009
290
29
28
Did your camera app work previously before and it has recently stopped working? Have you performed a reset of the phone? Hold down the power button and the home button until the Apple symbol appears and release, it will power off.
 

Sarah kolman

New Member
Oct 23, 2012
6
0
1
The camera did work before--it suddenly stopped working recently. I have tried resetting in that way several times and it didn't solve the problem. Other ideas? Thanks for troubleshooting with me.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,404
113
Utah
Is it jailbroken? If so, do you have any Cydia camera or photo apps installed?
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,404
113
Utah
Since you have already done a hard reset, the next step is restoring in iTunes.
 

talon90

Contributor
Bronze
Jan 17, 2009
290
29
28
Plug you iPhone in to your computer via the USB cable and open iTunes. Click once on the phone in the list on the left menu. On the info tab you will see the details of the phone and its operating system. You should also see a button that says backup now and a button that says restore.
 

Sarah kolman

New Member
Oct 23, 2012
6
0
1
My computer would not recognize the USB connection to my iPhone but it would my iPad. A pop up appeared saying it did not recognize USB connection due to device malfunction. I reset all settings through the settings menu on the phone. It took an hour to reset and restore settings from iCloud. The camera problem was not resolved. Anything I can try next?