Cannot connect to iTunes Store

  1. jaybird360

    jaybird360 New Member

    Joined:
    Aug 23, 2007
    Likes Received:
    0
    Anyone else getting this error message when using the new iTunes button that was available after the upgrade? My WiFi is definitely on ...the buttons at the bottom (featured, top tens, search, downloads) do highlight when i tap them but nothing appears on the screen ..just the error message "Cannot connet to iTunes store".
     
    #1
  2. chris

    chris Administrator Administrator

    Joined:
    Jun 10, 2006
    Likes Received:
    1,492
    I am having the same problem. I've also seen mention on Apple Discussion Forums.
     
    #2
  3. Avatar

    Sponsored Advertisement

  4. chris

    chris Administrator Administrator

    Joined:
    Jun 10, 2006
    Likes Received:
    1,492
    Here's a fix that worked for me from the Apple Discussion forums.
    • Select Settings
    • Select General
    • Reset
    • Reset Network Settings
    • Allow Reboot
    • Select WiFi
    • Select your network
    • Try iTunes WiFi Store
    Good luck!

    -Chris
     
    #3
  5. kurrupt_1

    kurrupt_1 New Member

    Joined:
    Apr 21, 2008
    Likes Received:
    0

    I did the reset but now I can't log to my wifi network. The screen comes up but it wont let me type in the password.

    Any thoughts?
     
    #4
  6. trippstadt

    trippstadt New Member

    Joined:
    Oct 24, 2008
    Likes Received:
    0
    This worked for me, but not at first. After I did this, I had to go into Settings, then General, then Network connections, and add my WiFi network at work (it's not discoverable), including the name, security type (WEP) and password. Then, it STILL didn't work. I got onto Safari and that immediately brought me into a wifi webpage that asked for an additional id and password, which I entered. THEN I went to the App Store and EVERYTHING worked. Now, my network at work is different than many of those you'd be using, but once I did the reset and put myself into a positiion such that my browser was fully capable of surfing, I was able to do everything. What changed between the "before reset" config and the "after reset" config? I have no idea, but now I can use iTunes no problem on my work wifi, and couldn't earlier.

    Hope this helps somebody.
     
    #5
  7. crashtc2

    crashtc2 New Member

    Joined:
    Oct 26, 2008
    Likes Received:
    0
    iTunes is NOT available on the 3g network

    Not sure if this matters in your case, but it might.

    iTunes is not available on the 3G network provided by AT&T. You have to connect to some other wifi network if you want it to work.

    I have no idea why. It seems pretty stupid. But there it is.
     
    #6
  8. iamse7en

    iamse7en Member Bronze

    Joined:
    Jul 27, 2007
    Likes Received:
    0
    This is not true

    [redacted]
     
    #7
  9. psylichon

    psylichon Genius Moderator

    Joined:
    Oct 31, 2007
    Likes Received:
    757
    Appstore is available off Wifi, iTunes store is not. They are different apps on the iPhone, of course.
     
    #8
  10. seb481

    seb481 New Member Silver

    Joined:
    Aug 3, 2007
    Likes Received:
    0
    Found a fix for that problem.
    1. SSH to /private/var/mobile/Library/Caches/com.apple.mobile.installation.plist
    2. back up and delete the file
    3. Reboot

    Worked like a charm for me
     
    #9
  11. newbv11

    newbv11 New Member

    Joined:
    Nov 23, 2008
    Likes Received:
    0
    sebefore81 has the best solution.it works! Thanks a lot
     
    #10
  12. denture59

    denture59 New Member

    Joined:
    Jan 28, 2009
    Likes Received:
    0
    Thanks for info Chris. Did reset and reboot and all working now. :laugh2:
     
    #11
  13. simcafe

    simcafe New Member

    Joined:
    Feb 10, 2009
    Likes Received:
    0
    Hi, Im on a Jailbroken 2.2.1 T-Mobile UK, and got the feared "Cannot connect.." message, and could not connect to AppStore or iTunes over 3G or Edge.
    Removing "com.apple.mobile.installation.plist" did not solve the problem - it just comes back after a reboot. I've tried rebooting it in several ways (Bossprefs, power off/on) to no avail.
    Then I got tired of it and completely reinstalled the phone from scratch. After Pwning/Yellowsnowing, i did not recover the previous iPhone data in iTunes, so that's a proper clean install. Without doing anything else, I tried the app store first thing and it gave the same "Cannot connect.." :( Safari did work so connection was fine.
    Then I entered my original o2 sim to which it was previously locked, and it did work..
    But still not on T-mobile.
    So, this problem is a little deeper than I hoped for, any ideas are very welcome.
     
    #12
  14. Gmun

    Gmun New Member

    Joined:
    May 1, 2009
    Likes Received:
    0
    I know the FIX

    Gents, I struggled with it myself. Here is the solution
    -check for the date on your iPod touch
    -Ensure it is the correct date, iPod touch resets to 2000.
    -Change to current date and voila you will be connected to iTunes Store
    :eek:
     
    #13
  15. dtandan

    dtandan New Member

    Joined:
    Sep 25, 2009
    Likes Received:
    0
    Did this - still does not work
     
    #14
  16. Europa

    Europa Genius Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    3,632
    You probably won't get a reply. His post is over a year old and it was the only one he ever made on this forum.
     
    #15
  17. mcqt

    mcqt New Member

    Joined:
    Dec 4, 2009
    Likes Received:
    0
    How?


    sort of new to this...but how do you SSH into that?
     
    #16
  18. wlt.

    wlt. New Member

    Joined:
    Dec 24, 2009
    Likes Received:
    0
    A Problem Updating Genius in iTunes

    Hi, I'm new here and I'm hoping I am in the right forum . . .

    I have an iPhone 3G and I'm running iTunes 9 on a Windows XP OS. The iPhone sync's okay, but when I go to "Store" and <click> Update Genius, iTunes gives me this response . . .

    "We could not complete your iTunes Store request. An uknown error occurred (4002).
    There was an error in the iTunes Store. Please try again later."

    Since it's been a couple of month's "later," I figured I'd better seek help from those who know. Is it my Symantec NIS? I know the Windows Firewall is set to allow iTunes. I would like to "refresh" some playlists, but I get errors saying the Genius needs updating.

    . . . A catch-22. Has anyone seen this? Thanks. - wlt.
     
    #17
  19. That happens when your connection speed is slow. Have you run a speed test?
     
    #18
  20. wlt.

    wlt. New Member

    Joined:
    Dec 24, 2009
    Likes Received:
    0
    Am I In the Right Forum?

    I am having problems on my Windows XP machine accessing the iTunes Genius.

    I have iTunes 9.0 (re-installed once) which sync's with my iPhone just fine. However, if I want to create a Genius playlist, which iTunes does not recognize, e.g. Boz Scaggs, "Loan Me a Dime," iTunes says to "update Genius."

    When I move to update Genius, I get the message "We could not complete your iTunes Store request. An unknown error occurred(4002)." Everything worked fine with iTunes 8.0, I mean Genius had no problems with ANY song or accessing the Store.

    Sure, I can access the Store if I want to buy something; otherwise NO WAY.

    If this is the wrong forum, please tell me where to go . . .

    Thanks.
     
    #19

Share This Page