Can't Login to Netflix App

  1. CanadianNemo

    CanadianNemo Genius
    Gold

    Joined:
    Aug 31, 2010
    Likes Received:
    399
    I haven't been able to login to the Netflix app on my 4S for a couple days now. I've tried deleting and re-installing the app several times.

    It keeps saying that the login has timed out and to check that my username and password are correctly entered (which I've obviously done - reset my password just in case though - plus my account is working fine on my laptop). Netflix was working great on my iPhone up until a couple days ago but now I can't figure out for the life of me what's wrong.

    It's definitely not my wifi because I've checked my wifi connection already, and everything else on my iPhone works like a charm.

    Any suggestions would be very much appreciated!
     
    #1
  2. Rugaby

    Rugaby Genius
    Gold

    Joined:
    Feb 18, 2011
    Likes Received:
    1,322
    Screenshots?
     
    #2
  3. Avatar

    Sponsored Advertisement

  4. CanadianNemo

    CanadianNemo Genius
    Gold

    Joined:
    Aug 31, 2010
    Likes Received:
    399
    Of course when I try again it won't give me that same message about the username and password! But here's what it gave me this time (tried twice and two different messages), then the black screen is now what it's stuck on?!
     

    Attached Files:

    #3
  5. CanadianNemo

    CanadianNemo Genius
    Gold

    Joined:
    Aug 31, 2010
    Likes Received:
    399
    Agh! I just got in! Go figure after 2 damn days of problems, it works 5 minutes after posting in here. In any case, I'm sure it will happen again since it seems like I have problems with the app every few days. I've had to delete and reinstall seriously at least 10 times.
     
    #4
  6. Rugaby

    Rugaby Genius
    Gold

    Joined:
    Feb 18, 2011
    Likes Received:
    1,322
    So the unable to connect error is very very very common. Most common reason is a network outage from Netflix servers.
    I checked Netflix support site for the login timeout error and didn't see anything. All of the login errors it says to delete app or restart Apple product over again.

    Not much help I know. Have u tried creating another login? Well that would be stupid Because your login works on other devices (laptop). Sorry typing out loud. Has to be the app itself.
    If you have another email addy try creating a new login and what not see if you still get the error.
     
    #5
  7. Rugaby

    Rugaby Genius
    Gold

    Joined:
    Feb 18, 2011
    Likes Received:
    1,322
    Well I am glad it worked out regardless of the reason why lol
     
    #6
  8. CanadianNemo

    CanadianNemo Genius
    Gold

    Joined:
    Aug 31, 2010
    Likes Received:
    399
    Well, misery loves company, so it's nice to know the connectivity problem isn't just with me. First world problems eh? ;)
     
    #7
  9. Rugaby

    Rugaby Genius
    Gold

    Joined:
    Feb 18, 2011
    Likes Received:
    1,322
    Right!
     
    #8
  10. efuseakay

    efuseakay Contributor
    Silver

    Joined:
    Nov 11, 2008
    Likes Received:
    62
    Next time you have any problems, just post here... they will surely fix themselves in a matter of minutes! ;)
     
    #9
  11. Slymo

    Slymo New Member

    Joined:
    Jan 4, 2013
    Likes Received:
    0
    I get the "wrong user name and password" all the time with the app. I have cleared the cache, uninstalled you name it but it never works. I can login to netflix with a browser on my iPhone and today I downloaded a third party queue app and was able to login which is pretty funny.
     
    #10
  12. CanadianNemo

    CanadianNemo Genius
    Gold

    Joined:
    Aug 31, 2010
    Likes Received:
    399
    Should I be concerned about this when I didn't make any changes at all?

    ImageUploadedByiCafe Forums1358306737.532593.jpg
     
    #11
  13. Docd

    Docd Contributor
    Silver

    Joined:
    Oct 16, 2011
    Likes Received:
    53
    You know with all the problems you had and now this, I think I would change my password just in case.
     
    #12
  14. CanadianNemo

    CanadianNemo Genius
    Gold

    Joined:
    Aug 31, 2010
    Likes Received:
    399
    Sigh...can someone do me a favour and tell me if their Netflix is down right now too?
     
    #13
  15. Rugaby

    Rugaby Genius
    Gold

    Joined:
    Feb 18, 2011
    Likes Received:
    1,322
    Oh Ginny. That sigh made me want to hug you. Damn you Netflix.
     
    #14
  16. CanadianNemo

    CanadianNemo Genius
    Gold

    Joined:
    Aug 31, 2010
    Likes Received:
    399
    I'll take the hug. ;)
     
    #15
  17. Rugaby

    Rugaby Genius
    Gold

    Joined:
    Feb 18, 2011
    Likes Received:
    1,322
    Have I ever said no to you?
     
    #16
  18. Europa

    Europa Genius
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    3,886
    1. Go to Settings on your phone > Netflix > Reset > On.
    2. Then go to the Netflix website on your computer > Your Account > Your Streaming Plan > Manage Devices and Computers > Activate a Device

    Let me know if that doesn't work. You might need to adjust a setting on your router. Does it work on other WiFi networks and 4G?
     
    #17
  19. Napoleon PhoneApart

    Senior Moderator

    Joined:
    Jun 19, 2007
    Likes Received:
    3,318
    Damn, you're sexy when you talk routers and networks and, and...
     
    #18
  20. Europa

    Europa Genius
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    3,886
    Just in case the suggestions in my previous post don't help, and Netflix does work on other WiFi networks and 4G but not on your WiFi network, you can try changing a setting on your iPhone before making any adjustments on your router. Sometimes Netflix looks like a rebind attack and DD-WRT blocks it. Changing it to Google's DNS server will fix that:

    On the phone, go to Settings, WiFi, then click the blue arrow next to your network, go to DNS and change it to 8.8.8.8.
     
    #19
  21. SpyBot

    SpyBot New Member

    Joined:
    Jan 30, 2013
    Likes Received:
    0
    It seems to go through fazes. Sometimes it just won't work for a day or two. Them *ba-bam!* runs perfect. I'm betting it's something on their side. Hard to complain, though. It's a pretty phenomenal service. :)
     
    #20

Share This Page