Can't send email from comcast.net account

Discussion in 'iPhone' started by pepperco, Jul 1, 2007.

  1. pepperco

    pepperco New Member

    Joined:
    Jul 1, 2007
    Likes Received:
    0
    Hello,

    What a cool little gizmo we have !

    only one thing...I can't seem to SEND emails from
    my comcast.net account. The mailboxes imported
    just fine, and I can receive email, but no sending.

    I get the error message....
    CANNOT SEND EMAIL
    the sender address XXXXX@comcast.net
    was rejected by the server.

    How do I fix this ?

    THANKS !
     
  2. Sponsored Advertisement

  3. wjp09

    wjp09 Zealot
    Gold

    Joined:
    Feb 25, 2007
    Likes Received:
    25
    most of the time I can't send email either earlier today it worked fine but now nothing
     
  4. hoop

    hoop New Member
    Bronze

    Joined:
    Jun 27, 2007
    Likes Received:
    0
    dude i have comcast too and all u need to do is call customer support and they have ppl there that will help, they help me setup my WiFi so now it work on my router )
     
  5. wjp09

    wjp09 Zealot
    Gold

    Joined:
    Feb 25, 2007
    Likes Received:
    25
    sorry but it is not the wifi that is messing it up it clearly has something to do with att
     
  6. DD0

    DD0 New Member
    Bronze

    Joined:
    Jun 21, 2007
    Likes Received:
    0
    Comcast does something lame, like not let you use their outgoing server for mail programs. I remember talking to them about something when I set up my mac mail and they wouldn't help. I use gmail though so I just ended up using theirs. Hopefully they've changed their terrible stance on that by now.
     
  7. slipperypete

    slipperypete New Member
    Bronze

    Joined:
    May 20, 2007
    Likes Received:
    0
    I had the same error message with my roadunner accounts yesterday for most of the day. Than, it just started working. Not sure why or how
     
  8. deac

    deac Member
    Bronze

    Joined:
    Jun 29, 2007
    Likes Received:
    0
    I have never been able to send emails with Road Runner webmail on my iBook. I asked them about it one time and got some kind of techie answer I can't explain but that basically it was not possible -- something about the ip you are on with the WiFi not being recognized or something so like above I ahve to use gmail to send from the road.

    Was expecting the same with the iPhone IF IF IF IF I ever get activated........ 35 hrs and counting
     
  9. slipperypete

    slipperypete New Member
    Bronze

    Joined:
    May 20, 2007
    Likes Received:
    0
    I am not using webmail. The settings for my roadrunner e-mails were automatically added to my phone when I sync'ed for the time. With the exception of about 3 hours yesterday, I have been able to send a receive messages without a hitch
     
  10. deac

    deac Member
    Bronze

    Joined:
    Jun 29, 2007
    Likes Received:
    0
    that's geat to hear, pete. Look forward to it working. I of course wasn't talking about the iPhone since they have not awarded me the prized Activation status yet.......
     
  11. slipperypete

    slipperypete New Member
    Bronze

    Joined:
    May 20, 2007
    Likes Received:
    0

    hopefully you'll be activated soon. Once you are, you will not be disappointed.
     
  12. Napoleon PhoneApart

    Senior Moderator

    Joined:
    Jun 19, 2007
    Likes Received:
    4,112
    I just tried it. The first time, the "send" progress bar wouldn't budge, but a second try worked perfectly. However, the Hotmail account I sent the test message to received two copies.
     
  13. wjp09

    wjp09 Zealot
    Gold

    Joined:
    Feb 25, 2007
    Likes Received:
    25
    my two fixes are to either send them via safari or create a new email address both of which work sorry it can't help out your current situation though
     
  14. captain4004

    captain4004 New Member
    Bronze

    Joined:
    May 2, 2007
    Likes Received:
    0
    I use Comcast too and yeah I think they do some sneaky stuff with their e-mail server, I was having this problem but is working fine for now.
     
  15. pepperco

    pepperco New Member

    Joined:
    Jul 1, 2007
    Likes Received:
    0
    Thanks for all of the input....

    After messing with this email for a while I can only
    refer to it as "intermittent" or "iffy".

    I had a test email in my comcast outbox that would not send
    yesterday, when I woke up this morning it was still in my outbox.
    Then, inexplicably it sent at some point this morning. So I tried
    to send several emails on my iPhone using my comcast account.
    I few of them actually sent, but most of them just disappeared
    into never-never-land....darnit. They don't appear in my outbox
    or in my sent messages.

    Not good....I really use theses 3 comcast accounts a lot.
     
  16. pepperco

    pepperco New Member

    Joined:
    Jul 1, 2007
    Likes Received:
    0
    And now......out of the blue......I am sending email like a bandit !

    Works perfectly, after I hit send, I get the swooosh, jet take off.

    Quite an amazing age, where these situation magically resolve.

    I did not do ANYTHING different.

    Kind of scary actually.....:mad:
     
  17. mkenna

    mkenna New Member

    Joined:
    Jun 30, 2007
    Likes Received:
    0
    comcast email

    can anyone tell me the pop and smtp of comcastso i can try my email on the iPhone
     
  18. Napoleon PhoneApart

    Senior Moderator

    Joined:
    Jun 19, 2007
    Likes Received:
    4,112
    pop.comcast.net

    smtp.comcast.net
     
  19. pepperco

    pepperco New Member

    Joined:
    Jul 1, 2007
    Likes Received:
    0
    Is it against the law to quote myself ?

    Forget everything I said above, today
    my comcast emails won't send, what a drag.
     
  20. pepperco

    pepperco New Member

    Joined:
    Jul 1, 2007
    Likes Received:
    0
    Mine is working now..

    Here is what I know, don't take this as gospel
    because I'm no expert.....

    Apparently when iPhone imported my comcast mailboxes
    it did not auto populate the proper OUTGOING mail servers,

    I had to go in and manually add the host name
    smtp.comcast.net

    And add the user name....which is the complete
    email address for the main mailbox account,
    I had to add that main email for all 3 of my
    comcast mailboxes

    Also add the password

    Its working now and has been for 2 days.
     
  21. 76bronco

    76bronco New Member

    Joined:
    Jun 30, 2007
    Likes Received:
    1
    adding the password and user name (full email) to the outgoing server settings fixed the issues...problem solved. Thanks.
     

Share This Page