Can't send text to one number, but can receive them

anubis89

New Member
Dec 30, 2011
9
0
1
#1
Hey guys, so for some reason I'm not long able to send texts to one of my friends. The message acts like it was sent but they don't receive any. They can however see pictures I've sent and I can receive any texts that they send. This just recently started happening (yesterday morning) so I don't know what's causing it. It's weird because they can send/receive texts from other people and I can send/receive texts from other people as well. Doesn't make much sense! We have both turned off/on our phones and my friend has even reset theirs (it's not an iPhone however). Should I restore mine too or does it seem like some other problem? Thanks for any help!
 

~DS~

Member
Bronze
Dec 18, 2011
140
7
18
#2
Can you please tell, what carrier are you on, which generation of iPhone, what firmware it is on? The more informations, the better we can help.

And welcome to the site. :)
 

anubis89

New Member
Dec 30, 2011
9
0
1
#3
Sorry! It's an iPhone 4, iOS5.0.1, and Verizon. My friend is using a LG Rumor Touch on Sprint
 

Rugaby

Genius
Gold
Feb 18, 2011
7,122
1,220
113
Washington state
#4
Have you tried sending him a text by entering in his number. Or sending a group text and see if that works.
 

anubis89

New Member
Dec 30, 2011
9
0
1
#5
Ok so sending it as a group text worked. What does that mean lol?
 

anubis89

New Member
Dec 30, 2011
9
0
1
#7
Haha thats frustrating. Can you think of any reason why normal texts would stop going through (to him at least)? And is there any other solution that you can think of?
 

Rugaby

Genius
Gold
Feb 18, 2011
7,122
1,220
113
Washington state
#10
I don't know why it is doing it. Start a text message convo with him with his number entered twice and just leave it. See if the problem resolves itself. At least you (well I) found a way for you to get him texts.
 

anubis89

New Member
Dec 30, 2011
9
0
1
#11
Yeah thanks for that! It's been hella annoying taking screenshots of my text and then sending it to him lol. That and emails....brings me back! Haha. Thanks again and hopefully it will fix itself eventually
 

Rugaby

Genius
Gold
Feb 18, 2011
7,122
1,220
113
Washington state
#12
Yeah thanks for that! It's been hella annoying taking screenshots of my text and then sending it to him lol. That and emails....brings me back! Haha. Thanks again and hopefully it will fix itself eventually
I occasionally get one right. Well at least better in this case.
Has to be a server error somehow. Have you tried adding his number to a new contact?
 

~DS~

Member
Bronze
Dec 18, 2011
140
7
18
#13
Looks like carrier related issue...Sprint, oh the horror...


Sent from my iPhone using iCafe app
 

anubis89

New Member
Dec 30, 2011
9
0
1
#14
Yeah, I've deleted and added it a few times. Doesn't seem to do anything.

EDIT: Haha, yeah I'll tell him to call Spring if it keeps it up
 

anubis89

New Member
Dec 30, 2011
9
0
1
#16
I can live with this for now lol. Thanks again
 

~DS~

Member
Bronze
Dec 18, 2011
140
7
18
#17
Try texting to your friends that uses AT&T or Verizon. You will soon see that it's Sprint to blame. I have my share of these horror myself. ;)


Sent from my iPhone using iCafe app
 

Rugaby

Genius
Gold
Feb 18, 2011
7,122
1,220
113
Washington state
#18
Try texting to your friends that uses AT&T or Verizon. You will soon see that it's Sprint to blame. I have my share of these horror myself. ;)


Sent from my iPhone using iCafe app
The op said that he could text everyone but one person. Odds are someone else he is texting is on sprint.
 

anubis89

New Member
Dec 30, 2011
9
0
1
#19
I'm not sure who all is on what provider, but I'll try and track down another Sprint user to see if it is actually Sprint or just something weird between our phones.
 
#20
Hiya, This same problem has happened to my boyfriends phone both have ipohne 4 verizon he can send and receive from everyone else and i can send and receive everyone elses but when i send to him i can not receive and he can receive the texts but it wont reply right like it shows it send and says delievered but i never get it.