Can't sync 1.02 unlocked iPhone with Leopard

javajack

New Member
Sep 27, 2007
10
0
0
#1
I have been using my unlocked iPhone successfuly for 6 months. I upgraded to Leopard a few days ago, as I had read syncing was not an issue but I have been unable to get iTunes 7.6 to recognize my iPhone. I tried installing an older version of iTunes (7.5) but got a message that my iTunes library had already been updated by a new version of iTunes, so I can't back out. I purchased my phone off ebay and don't know what unlock technology was used, probably anysim but not sure. I was reading about Jailbreak but they warn not to run if it is a 1.02 phone as it may brick the phone. Any advice would be very appreciated.
 
May 17, 2008
1
0
0
#2
unlocked iPhone and leopard problems

I am in the same situation--any luck in getting it sorted?

I have been using my unlocked iPhone successfuly for 6 months. I upgraded to Leopard a few days ago, as I had read syncing was not an issue but I have been unable to get iTunes 7.6 to recognize my iPhone. I tried installing an older version of iTunes (7.5) but got a message that my iTunes library had already been updated by a new version of iTunes, so I can't back out. I purchased my phone off ebay and don't know what unlock technology was used, probably anysim but not sure. I was reading about Jailbreak but they warn not to run if it is a 1.02 phone as it may brick the phone. Any advice would be very appreciated.
 

javajack

New Member
Sep 27, 2007
10
0
0
#3
yes, someone told me that the iTunes that came with th Leopard installer disc is not compatible. Download latest, full installer for iTunes trashing the old one and everything will be fine. Let me know if this works.

Jack
 

themanofthedark

New Member
Gold
Jan 5, 2008
2,674
0
0
25
Boston
#4
or you could force it into recovery mode and restore to 1.1.3/4 and unlock it again.

but first I recommend going somewhere where it may back up your phone first.