"can't verify server identity" when trying to add exchange account.

Discussion in 'iPhone' started by Vicente Furtado, Oct 11, 2011.

  1. Vicente Furtado

    Vicente Furtado New Member

    Joined:
    Oct 11, 2011
    Likes Received:
    0
    Hello guys.

    My company has an exchange server that uses port 8448. When I try to add my exchange account I get the error "can't verify server identity". Here are the things I've tried so far.

    1. In the server address I've tried: mail.server.com:8448, mail.server.com:8448/exchange, mail.server.com.

    2. username: domain\user, and just user.

    3. I've tried finding the advanced options to change port number but the account wouldn't save so that option was not available.

    This seems to be an issue with the server connecting at a non standard port, but I cant configure the iPhone 4 to connect at that port.

    Any help would be greatly appreciated.
     
  2. Target

    Target Evangelist
    Gold

    Joined:
    Oct 16, 2008
    Likes Received:
    168
    Does the company use Outlook Web Access feature? Commonly called OWA. Try mail.server.com/owa


    Target

    Sent from my iPhone using iCafe app
     
  3. Vicente Furtado

    Vicente Furtado New Member

    Joined:
    Oct 11, 2011
    Likes Received:
    0
    Yes it does. The problem is it connects over port 8448. So the URL looks like this: https://mail.server.com:8448/exchange.

    So when configuring the server address on the iPhone, I've tried to configure it as mail.server.com:8448/exchange, and mail.server.com:8448, and mail.server.com

    None of those worked, giving me the cant verify server identity error. My friend has a Droid and it has a third party app that allows you to change the port number of an exchange account and it worked with the Droid. I can't figure out how to customize the port number on the iPhone, since there are no advanced options during configuration.
     
  4. Vicente Furtado

    Vicente Furtado New Member

    Joined:
    Oct 11, 2011
    Likes Received:
    0
    I Solved this problem.

    In my case, there were some restrictions on IP address restriction in my OMA, Microsoft Active Sync, and Exchange OMA in IIS.

    So, on my exchange server I clicked on Administrative Tools > IIS > Expanded my server > Expanded Web sites > Expanded Default websites >

    right clicked exchange OMA > selected the directory security tab and under IP address and domain name restriction I changed from "by default all computer will be denied acces" to Granted access.

    Do the same for OMA, and Microsoft Active Sync. And I was able to connect to my exchange server by appending the port number :8448 after the server address on my iPhone.

    I hope this helps someone else!
     
  5. Target

    Target Evangelist
    Gold

    Joined:
    Oct 16, 2008
    Likes Received:
    168
    That is golden information. Thanks for sharing.


    Target

    Sent from my iPhone using iCafe app
     

Share This Page