Clearing iTunes Match

Discussion in 'iPhone' started by T4FF, Mar 8, 2012.

  1. T4FF

    T4FF New Member

    Joined:
    Mar 8, 2012
    Likes Received:
    0
    Hey, I've registered to get some help, tearing my hair out with this.

    Basically, I've signed up for iTunes Match and I switched it on on the iPhone however, my contract doesn't give me enough data, so I've decided to remove it for the time being. I switched off iTunes Match, cleared down all remaining songs and re-synced with iTunes...only now, I have a weird problem. I've taken a few screenshots to explain what is happening.

    Firstly, some of my albums still have an iCloud icon next to them even though Match is switched off.

    [​IMG]

    If I select a specific artist, some of the albums have iCloud icons next to them...

    [​IMG]

    But when I open up an album with a cloud, none of the songs show that they're not on the phone...

    [​IMG]

    BUT, if I then view the track list from the now playing section, you can see that this now shows duplicate entries for one song. If I select the one version, it plays, the other just sits there doing nothing.

    [​IMG]

    This rogue song doesn't appear in the track list and I've tried restores, clearing down, switching Match off and on, I just can't sort this.

    When I open Music on the iPhone it is constantly accessing the internet (the round ticker is...well...ticking), but this never seems to be resolved. Anyone come across this before? Any suggestions on how to resolve?

    Thanks in advance
     
  2. T4FF

    T4FF New Member

    Joined:
    Mar 8, 2012
    Likes Received:
    0
    Anyone have any suggestions? :(
     
  3. Tinman

    Tinman Evangelist
    Gold

    Joined:
    Jul 16, 2007
    Likes Received:
    183
    I fight with this myself. I "think" I have it worked out on my iPhone 4S. In my case iTunes Match was becoming a pain: it often would not play a song even with a good wifi connection. In fact I looked foolish a few times as I could not play a single song on my iPhone. I will still use Match for my iPad and macbook air. This is what I did to best try to eradicate it from my iPhone...

    I of course switched off Match. Then enabled music syncing in iTunes. Before syncing I enabled "Convert higher bit rate songs to 128 kbps AAC." I wanted to force overwriting of any lingering tracks. Then I synced in iTunes and unchecked the convert high bit rate songs option. Once again synced.

    Then I disabled music syncing in iTunes and synced.

    Going into the Music app on my iPhone I noticed there were still some tracks left (ugh!). So I manually deleted them all, careful to avoid the ones with cloud icons (those are only supposed to be there for purchased iTunes tracks--even without being a Match subscriber this is how it is supposed to be). A few times I accidentally played a cloud track so I would let it download then immediately delete it.

    This left me with only cloud tracks listed in the Music app--none downloaded. Strangely, some of those tracks were not purchased but rather my own tracks that were matched.

    Finally, I enabled music syncing again in iTunes again and synced. So far it seems to have cleared up the remnants of iTunes Match.



    Michael
     

Share This Page