Contacts not getting updated in iCloud

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

rugved1118

Member
Silver
Sep 27, 2013
637
13
18
#1
I would like to sync my contacts which are on iPhone 5 to iPhone 5S. I had previously synced using iCloud but now i am getting previously synced contacts and not the one which already exists. Can anyone help please ??


Sent from my iphone5
 
Last edited by a moderator:

jmp316

Evangelist
Gold
Jul 10, 2008
1,048
141
63
#2
I'm not sure if you still have your 5, but this is what I would do:

Go to iCloud.com on a computer. Click on contacts. Ensure all contacts are there and the way you want them. Next, delete all contacts from your 5s by turning off contacts sync in Settings>iCloud>toggle contacts off. Ensure all contacts are deleted by opening your contacts app. Then go back to settings app and toggle contacts on under iCloud.

That should do the trick...
 

rugved1118

Member
Silver
Sep 27, 2013
637
13
18
#3
Hello,
I have just figured out that new contacts are not getting added to the icloud...nor to my gmail. I have checked all the settings and it seems to be fine though. Can anyone please help ?
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,791
979
113
65
Florence, AL
#4
Hello,
I have just figured out that new contacts are not getting added to the icloud...nor to my gmail. I have checked all the settings and it seems to be fine though. Can anyone please help ?
What settings? Where are you looking? All your contacts will sync to your phone if you restore it. Just like the photos. I don't think you understand how it works. There is no place where you "add" contacts to iCloud.


Sent from my ancient but trustworthy iPhone 5. ☮
 

rugved1118

Member
Silver
Sep 27, 2013
637
13
18
#5
What settings? Where are you looking? All your contacts will sync to your phone if you restore it. Just like the photos. I don't think you understand how it works. There is no place where you "add" contacts to iCloud.


Sent from my ancient but trustworthy iPhone 5. ☮
Whenever i add new contacts on my iphone, it does not get synched to my gmail account.


Sent from my iPhone using Tapatalk
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,505
113
Utah
#6
What settings? Where are you looking? All your contacts will sync to your phone if you restore it. Just like the photos. I don't think you understand how it works. There is no place where you "add" contacts to iCloud.
You do not have to restore from a backup to sync contacts. They sync through Gmail and iCloud over the air. You can restore to factory settings, log into iCloud and then toggle contacts on and they will appear. You don't have to restore at all to get them on the phone - you can just log in.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,505
113
Utah
#7
I would like to sync my contacts which are on iPhone 5 to iPhone 5S. I had previously synced using iCloud but now i am getting previously synced contacts and not the one which already exists. Can anyone help please ??
Syncing contacts through multiple email accounts can cause conflicts exactly like you are describing. It's best to stick with one.
Whenever i add new contacts on my iphone, it does not get synched to my gmail account.
If you want to use iCloud, toggle off contacts in iCloud, then go to your Gmail account in the Settings apps and toggle contacts on. Make sure they are toggled off for every other email account. They are on by default.
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,791
979
113
65
Florence, AL
#8
You do not have to restore from a backup to sync contacts. They sync through Gmail and iCloud over the air. You can restore to factory settings, log into iCloud and then toggle contacts on and they will appear. You don't have to restore at all to get them on the phone - you can just log in.
Exactly! That's what I did about 2 weeks ago. It was the only way I had to straighten out a few issues.


Sent from my ancient but trustworthy iPhone 5. ☮
 
Jan 30, 2015
3
0
1
#9
This could be the technical issue... Report it to the service to get things fixed. But first go to your contacts, click the 'Groups' button at the top left and click 'show all contacts' (if it is on 'hide all contacts') then click 'Done' but make sure the 'All iCloud' button has a check mark on it. I hope it works