Cookies not saving on 1.1.4 ?

chcorey52

New Member
Silver
Dec 25, 2007
556
0
0
#2
Ahhhh thanks ive been wondering wtf was wrong with my phone the last few weeks
 

themanofthedark

New Member
Gold
Jan 5, 2008
2,674
0
0
26
Boston
#3
or, open terminal (on phone)
and enter this
(#=new command)

#login
#root
#alpine
#chmod 777 /private/var/mobile/Library/Cookies
#chmod 666 -R /private/var/mobile/Library/Cookies/*
#

weird, since I've been having this after restoring to 1.1.3/4 and setting up as a new phone.

only on this new phone, though. not my old.
 

moppsy

New Member
Jul 31, 2007
20
0
0
NJ
#4
or, open terminal (on phone)
and enter this
(#=new command)

#login
#root
#alpine
#chmod 777 /private/var/mobile/Library/Cookies
#chmod 666 -R /private/var/mobile/Library/Cookies/*
#
Actually, the permissions are correct, it's the ownership that's wrong.
The proper way to fix it is

chown -R mobile /var/mobile/Library/Cookies
 

themanofthedark

New Member
Gold
Jan 5, 2008
2,674
0
0
26
Boston
#5
interesting

my permissions were wrong, but you may be right also.
 

moppsy

New Member
Jul 31, 2007
20
0
0
NJ
#6
That depends on what you consider wrong.
Permissions on Cookies directory should be 700
You really don't want anyone but the owner to have access.
Cookies.plist permissions are kind of irrelevant after that, 644 is typical.
 

fretos86

New Member
Nov 12, 2007
20
0
0
#7
help with cookie fix

i was trying to install the cookie fix but it tells me ''main script execution failed' and i cannot understand the other way to do it. can anyone help me ?
 

24trepid

Member
Silver
Jan 13, 2008
502
0
16
Florida
#8
i was trying to install the cookie fix but it tells me ''main script execution failed' and i cannot understand the other way to do it. can anyone help me ?
Refresh your sources, and try again. If that doesn't work, power phone
off and back on. And try again.