Copilot not working on Jailbroken 3GS

Dick18

New Member
Jul 13, 2011
5
0
1
#1
I have a jailbroken iPhone 3gs and have installed a copy of copilot which seems to load ok and finds my position initially then freezes and keeps saying "trying to determine current position" and stays that way.
I have been in touch with copilot technical advice and have followed all of their instructions but still the same.
Is this to do with the jailbreak,the copilot or phone settings or am I missing something?
All other gps functions seem to work ok.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,437
5,562
113
Utah
#2
Thread moved.

It would be helpful if you included a list of your troubleshooting steps. Have you tried reinstalling the app? You could try a hard reset. Press the home and power buttons at the same time until you see the Apple logo flash. No data will be lost.

I doubt it has anything to do with the jailbreak, unless you unlocked. Some unlocking tools can cause problems with GPS.
 

iNinja

Zealot
Gold
Aug 8, 2008
3,984
20
38
UK
#3
I think it has more to do with the "installed a copy of copilot" - doesn't sound very legit to me, maybe im being an old cynic.
 

Dick18

New Member
Jul 13, 2011
5
0
1
#4
Thread moved.

It would be helpful if you included a list of your troubleshooting steps. Have you tried reinstalling the app? You could try a hard reset. Press the home and power buttons at the same time until you see the Apple logo flash. No data will be lost.

I doubt it has anything to do with the jailbreak, unless you unlocked. Some unlocking tools can cause problems with GPS.
I think it has more to do with the "installed a copy of copilot" - doesn't sound very legit to me, maybe im being an old cynic.
 

Dick18

New Member
Jul 13, 2011
5
0
1
#5
Yes I did unlock it and it is a legit copy, I tried hard reset and ended up having to reinstall and downgrade to 4.1. I have read that it could be the unlock is there any way of getting round this
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,437
5,562
113
Utah
#6
I think it has more to do with the "installed a copy of copilot" - doesn't sound very legit to me, maybe im being an old cynic.
He said he talked to Copilot tech support and they probably wouldn't have helped him if it wasn't legitimately purchased.
Yes I did unlock it and it is a legit copy, I tried hard reset and ended up having to reinstall and downgrade to 4.1. I have read that it could be the unlock is there any way of getting round this
Did you use the iPad's baseband to unlock? It can break GPS or cause a poor signal, which could explain the GPS signal dropping after you connect to Copilot. Try Googling iPad baseband GPS fix.
 

Dick18

New Member
Jul 13, 2011
5
0
1
#7
He said he talked to Copilot tech support and they probably wouldn't have helped him if it wasn't legitimately purchased.

Did you use the iPad's baseband to unlock? It can break GPS or cause a poor signal, which could explain the GPS signal dropping after you connect to Copilot. Try Googling iPad baseband GPS fix.
It's an iPhone 3gs and I used UltrasnOw to unlock it will that fix it?
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,437
5,562
113
Utah
#8
That can cause GPS problems as well. You could try resetting your network settings or restoring and unlocking again.
 

Dick18

New Member
Jul 13, 2011
5
0
1
#9
That can cause GPS problems as well. You could try resetting your network settings or restoring and unlocking again.
OK thanks will give it a whirl, let you know.