"Could Not Activate EDGE", so bogus, anybody else have problems?

SoccerSpartan20

New Member
Bronze
Jul 4, 2007
32
0
0
#1
Nothing on my phone will work with EDGE. Wifi seems to be working fine, but not when I use EDGE for weather, emails, voicemail, safari and maps. The little E icon is showing up, but nothing works. There is coverage in my area and I have all 5 bars. It seemed to work fine all last week, but it just stopped randomly! Also, when i tried to set up my voicemail greeting, it said "visual voicemail is currently unavailable." but that's probably because my EDGE network isn't connecting. SO FRUSTRATING! The phone and SMS works fine... at least that can keep me entertained for the meantime. Is it possible that the whole EDGE network is down or that it's being overwhelmed with too many users? Thanks for any advice!
 

tfg

New Member
Jun 20, 2007
213
0
0
#2
This happened to me a couple of weeks ago, and I wasn't even getting the E listed. I think it was down for about 4 or 5 hours and then it came back and was fine. Really the only significant time that it hasn't worked. It'll come back. Maybe try to power off and then on again just to be sure.
 

Conan

New Member
Bronze
Jul 19, 2007
374
0
0
#3
this happened to me yesterday.. it was like that when I hit safari but then I just reclicked safari and it worked.
 

brojimh

New Member
Bronze
Aug 1, 2007
142
0
0
Morris, AL
#4
I can't STAND the Edge network.

I am so very, very disappointed in Apple for choosing that cheesy last century network.

I CAN'T BELIEVE all that 3g signal is out there just floating around and not benefitting the greatest cellphone ever created!